aboutsummaryrefslogtreecommitdiff
path: root/games/uhexen2-extras
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
commit3a283e24f296371e9b753c09e3e62a92ef3d8703 (patch)
tree88e0a2bbddafb5c9bdc18e8e02c5e59fb9f9d471 /games/uhexen2-extras
parent7a0a8929bea1c510b4f30261d294a78b556b49d7 (diff)
downloadports-3a283e24f296371e9b753c09e3e62a92ef3d8703.tar.gz
ports-3a283e24f296371e9b753c09e3e62a92ef3d8703.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299119
Diffstat (limited to 'games/uhexen2-extras')
-rw-r--r--games/uhexen2-extras/Makefile35
1 files changed, 17 insertions, 18 deletions
diff --git a/games/uhexen2-extras/Makefile b/games/uhexen2-extras/Makefile
index 77a662be164f..ebe4fba50d40 100644
--- a/games/uhexen2-extras/Makefile
+++ b/games/uhexen2-extras/Makefile
@@ -22,28 +22,31 @@ RUN_DEPENDS= ${DATADIR}:${PORTSDIR}/games/uhexen2
NO_BUILD= yes
-OPTIONS= HEXEN2_DEMOS "Install pre-recorded demos for Hexen II" on \
- HEXEN2_LITS "Install colored light data for Hexen II" on \
- HEXEN2_MODS "Install several mods for Hexen II" on \
- HW_MODS "Install several mods for HexenWorld" on
+OPTIONS_MULTI= EXTRA
+OPTIONS_MULTI_EXTRA= HEXEN2_DEMOS HEXEN2_LITS HEXEN2_MODS HW_MODS
+OPTIONS_DEFAULT= HEXEN2_DEMOS HEXEN2_LITS HEXEN2_MODS HW_MODS
+HEXEN2_DEMOS_DESC= Install pre-recorded demos for Hexen II
+HEXEN2_LITS_DESC= Install colored light data for Hexen II
+HEXEN2_MODS_DESC= Install several mods for Hexen II
+HW_MODS_DESC= Install several mods for HexenWorld
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_HEXEN2_DEMOS)
+.if ${PORT_OPTIONS:MHEXEN2_DEMOS}
DISTFILES+= hexen2-demos${EXTRACT_SUFX}
PLIST_SUB+= HEXEN2_DEMOS=""
.else
PLIST_SUB+= HEXEN2_DEMOS="@comment "
.endif
-.if defined(WITH_HEXEN2_LITS)
+.if ${PORT_OPTIONS:MHEXEN2_LITS}
DISTFILES+= hexen2-lit_files${EXTRACT_SUFX}
PLIST_SUB+= HEXEN2_LITS=""
.else
PLIST_SUB+= HEXEN2_LITS="@comment "
.endif
-.if defined(WITH_HEXEN2_MODS)
+.if ${PORT_OPTIONS:MHEXEN2_MODS}
MASTER_SITES+= SF/${PORTNAME}/HoT%20-%20Other%20content/hexen2%20mods:mods
DISTFILES+= apocbot-0.2.0${EXTRACT_SUFX}:mods \
fo4d${EXTRACT_SUFX}:mods \
@@ -53,7 +56,7 @@ PLIST_SUB+= HEXEN2_MODS=""
PLIST_SUB+= HEXEN2_MODS="@comment "
.endif
-.if defined(WITH_HW_MODS)
+.if ${PORT_OPTIONS:MHW_MODS}
MASTER_SITES+= SF/${PORTNAME}/HoT%20-%20Other%20content/hexenworld%20mods:hw_mods
DISTFILES+= dungeonbreak${EXTRACT_SUFX}:hw_mods \
hexarena${EXTRACT_SUFX}:hw_mods \
@@ -65,24 +68,20 @@ PLIST_SUB+= HW_MODS=""
PLIST_SUB+= HW_MODS="@comment "
.endif
-.if empty(DISTFILES)
-IGNORE= needs at least one option selected
-.endif
-
do-install:
-.if defined(WITH_HEXEN2_DEMOS)
+.if ${PORT_OPTIONS:MHEXEN2_DEMOS}
${INSTALL_DATA} ${WRKDIR}/data1/*demo* ${DATADIR}/data1
.endif
-.if defined(WITH_HEXEN2_LITS)
+.if ${PORT_OPTIONS:MHEXEN2_LITS}
${MKDIR} ${DATADIR}/data1/maps
${INSTALL_DATA} ${WRKDIR}/data1/maps/*.lit ${DATADIR}/data1/maps
.endif
-.if defined(WITH_HEXEN2_MODS)
+.if ${PORT_OPTIONS:MHEXEN2_MODS}
.for f in apocbot fo4d hcbots
@(cd ${WRKDIR} && ${COPYTREE_SHARE} ${f} ${DATADIR})
.endfor
.endif
-.if defined(WITH_HW_MODS)
+.if ${PORT_OPTIONS:MHW_MODS}
.for f in db hexarena hwctf rk siege
@(cd ${WRKDIR} && ${COPYTREE_SHARE} ${f} ${DATADIR})
.endfor
@@ -91,4 +90,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>