aboutsummaryrefslogtreecommitdiff
path: root/games/uox3
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-06 21:48:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-06 21:48:31 +0000
commit4b3d6b959318ecb81d826b0c5e1a919f3fa81a38 (patch)
tree9d57c614a792a06741f9109bed3ac56c67d21f62 /games/uox3
parenta72a2ffef34f1cb0c21b1523b41cf3ed04f3eea9 (diff)
downloadports-4b3d6b959318ecb81d826b0c5e1a919f3fa81a38.tar.gz
ports-4b3d6b959318ecb81d826b0c5e1a919f3fa81a38.zip
- Fix build with gcc 4.2
PR: 116149 Submitted by: Scot Hetzel <swhetzel@gmail.com>
Notes
Notes: svn path=/head/; revision=198947
Diffstat (limited to 'games/uox3')
-rw-r--r--games/uox3/Makefile4
-rw-r--r--games/uox3/files/patch-al15
2 files changed, 13 insertions, 6 deletions
diff --git a/games/uox3/Makefile b/games/uox3/Makefile
index 52f8f5146ded..38146ff845b1 100644
--- a/games/uox3/Makefile
+++ b/games/uox3/Makefile
@@ -28,10 +28,6 @@ ALL_TARGET= linux
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
do-build:
cd ${WRKSRC}/dev && ${GMAKE} -f ${MAKEFILE} CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" ${ALL_TARGET}
diff --git a/games/uox3/files/patch-al b/games/uox3/files/patch-al
index 89072b089a3c..fdb28da995d5 100644
--- a/games/uox3/files/patch-al
+++ b/games/uox3/files/patch-al
@@ -1,5 +1,5 @@
---- work/dev/uox3.h.orig Sun Feb 14 18:56:03 1999
-+++ work/dev/uox3.h Sun Feb 27 11:28:45 2000
+--- work/dev/uox3.h.orig 1999-02-14 18:56:03.000000000 -0600
++++ work/dev/uox3.h 2007-09-06 05:37:55.229539705 -0500
@@ -3,10 +3,10 @@
//#define VER "0.69.02 (Test Build 03)" //Increment to 01 when putting out official test build
#define PRODUCT "Ultima Offline eXperiment 3"
@@ -42,6 +42,17 @@
#endif
#include "im.h"
#include "uoxlist.h"
+@@ -51,8 +57,8 @@
+ #include "worldmain.h"
+ // LINUX Definitions
+ #ifndef __NT__
+-#define max(a,b) (a) >? (b)
+-#define min(a,b) (a) <? (b)
++#define max(a,b) ((a) >= (b) ? (a) : (b))
++#define min(a,b) ((a) <= (b) ? (a) : (b))
+ char *strlwr(char *);
+ char *strupr(char *);
+ #endif
@@ -349,7 +355,7 @@
unsigned long int regen, regen2, regen3;
int runenumb; // Used for naming runes