aboutsummaryrefslogtreecommitdiff
path: root/games/utserver/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-04 13:59:49 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-04 13:59:49 +0000
commit340cd4aa318585ae4df1a5d95a0dc520daea833b (patch)
tree587550fb053cfc3803c1c369606754dfdfef853c /games/utserver/Makefile
parent682e9552815049ba1e577917c1cba01fdcacf155 (diff)
downloadports-340cd4aa318585ae4df1a5d95a0dc520daea833b.tar.gz
ports-340cd4aa318585ae4df1a5d95a0dc520daea833b.zip
- Update to 451
- Pass maintainership to submitter PR: ports/101339 Submitted by: Alexander Logvinov <ports at logvinov.com>
Notes
Notes: svn path=/head/; revision=169655
Diffstat (limited to 'games/utserver/Makefile')
-rw-r--r--games/utserver/Makefile89
1 files changed, 27 insertions, 62 deletions
diff --git a/games/utserver/Makefile b/games/utserver/Makefile
index ce195cdda415..36b4e261b3a6 100644
--- a/games/utserver/Makefile
+++ b/games/utserver/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= utserver
-PORTVERSION= 436
-PORTREVISION= 5
+PORTVERSION= 451
CATEGORIES= games linux
-MASTER_SITES= http://public.planetmirror.com/pub/lokigames/installers/ut/ \
- http://fileserver.talkware.net/ut/ \
- http://freebsd.unixfreunde.de/sources/
-DISTNAME= ut-server-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
+MASTER_SITES= http://public.planetmirror.com/pub/lokigames/installers/ut/:p436 \
+ http://fileserver.talkware.net/ut/:p436 \
+ http://freebsd.unixfreunde.de/sources/:p436 \
+ http://www.utpg.org/patches/:p451
+DISTFILES= ut-server-436.tar.gz:p436 ${PATCH451FILES}
+EXTRACT_ONLY= ut-server-436.tar.gz
+
+MAINTAINER= ports@logvinov.com
COMMENT= Unreal Tournament Dedicated Server for Linux
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
@@ -27,66 +28,30 @@ NO_CDROM= Size; the data set is much too big
NO_BUILD= yes
WRKSRC= ${WRKDIR}/ut-server
-UTDIR= ut-server/
-PLIST_SUB= UTDIR="${UTDIR}"
-EXTRA_PATCHES= ${WRKDIR}/patch-ngstatsut
-INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
-INSTALL_MY_DATA= ${INSTALL} -o ${SHAREOWN} -g ${SHAREGRP} -m 644
-
-# files which should be installed with executable perms
-EXECUTABLES= ucc ucc-bin ngStatsUT ngStatsUT.exe ngWorldStats \
- bgWorldStats ngWorldStats.exe
+UTDIR= ut-server
+PLIST_SUB= UTDIR="${UTDIR}/"
+SUB_LIST= UTDIR="${PREFIX}/${UTDIR}"
+SUB_FILES= pkg-message
+PATCH451FILES= UTPGPatch451.tar.bz2:p451
+EXTRA_PATCHES= ${WRKDIR}/patch-ngstatsut
pre-patch:
+ @${SED} -e "s!%%LOCALBASE%%!${LOCALBASE}!" \
+ -e "s!%%UTDIR%%!${PREFIX}/${UTDIR}!" \
+ ${FILESDIR}/template-patch-ngstatsut > \
+ ${WRKDIR}/patch-ngstatsut
+
+do-patch:
+ @${TAR} jx -C ${WRKSRC} -X ${FILESDIR}/excludefiles \
+ -f ${_DISTDIR}/${PATCH451FILES:C/:.*//}
# remove trailing ^M
@${FIND} -E ${WRKSRC} -type f \
- -iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|int|lst|pl|pm|sc|sh|scr|txt|url|uhtm)" \
+ -iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|int|lst|pl|pm|sc|sh|scr|txt|url|uhtm|inc)" \
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
- @${SED} -e "s!%%LOCALBASE%%!${LOCALBASE}!" \
- -e "s!%%LINUXBASE%%!${LINUXBASE}!" \
- -e "s!%%UTDIR%%!${UTDIR}!" \
- ${FILESDIR}/template-patch-ngstatsut > \
- ${WRKDIR}/patch-ngstatsut
-
-do-install: install-parse-plist install-run-scripts
-
-# Contributed by <lioux@FreeBSD.org>
-install-parse-plist: generate-plist
- @${PERL} -e 'open(FHANDLER,"${TMPPLIST}");' \
- -e 'open(FDIR,">${WRKDIR}/dirs.sh.tmp");' \
- -e 'open(FFILES,">${WRKDIR}/files.sh");' \
- -e 'while (!eof(FHANDLER)) {' \
- -e 'chop($$file = <FHANDLER>);' \
- -e '$$dir = $$file_partial = $$file;' \
- -e '$$file_partial =~ s!^${UTDIR}!!;' \
- -e 'print FDIR "${INSTALL_DIR}", \
- " ", "\"${PREFIX}/$$dir\"", \
- "\n" if $$dir =~ s!(^\@dirrm\s+)!!;' \
- -e 'if ($$file !~ m!^\@!) {' \
- -e '$$program_flag = 0;' \
- -e 'if ("${EXECUTABLES}" ne "") {' \
- -e 'foreach $$program_pattern \
- (split (/\s+/,"${EXECUTABLES}")) {' \
- -e '($$program_flag = 1 , break) \
- if ($$file =~ /$$program_pattern$$/);' \
- -e '}' \
- -e '}' \
- -e 'print FFILES ($$program_flag == 0) ? \
- "${INSTALL_MY_DATA}" : "${INSTALL_SCRIPT}", \
- " ", "\"${WRKSRC}/$$file_partial\"", \
- " ", "\"${PREFIX}/$$file\"", \
- "\n";' \
- -e '}' \
- -e '}' \
- -e 'close(FFILES);' \
- -e 'close(FDIR);' \
- -e 'close(FHANDLER);'
- @${SORT} ${WRKDIR}/dirs.sh.tmp > ${WRKDIR}/dirs.sh
-install-run-scripts:
-.for script in dirs files
- @${SH} ${WRKDIR}/${script}.sh
-.endfor
+do-install:
+ @${CP} -Rp ${WRKSRC}/ ${PREFIX}/${UTDIR}
+ @${RM} -f ${PREFIX}/${UTDIR}/System/libSDL-1.1.so.0
post-install:
@${CAT} ${PKGMESSAGE}