aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth-devel/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-23 22:20:16 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-23 22:20:16 +0000
commit24db010a8f9373e733cbe4ac8bf5fa92d3c5f03d (patch)
treea685765556339a0b19c7e259e505ab9a2c28f36c /games/wesnoth-devel/Makefile
parent91d45ad33976ff721b58522ac79b060474a02da6 (diff)
downloadports-24db010a8f9373e733cbe4ac8bf5fa92d3c5f03d.tar.gz
ports-24db010a8f9373e733cbe4ac8bf5fa92d3c5f03d.zip
Add wesnoth 0.6.1, a fantasy turn-based strategy game.
Battle for Wesnoth is a fantasy turn-based strategy game. Battle for control of villages, using variety of units which have advantages and disadvantages in different types of terrains and against different types of attacks. Units gain experience and advance levels, and are carried over from one scenario to the next campaign. PR: 60531 Submitted by: Mezz <mezz7@cox.net>
Notes
Notes: svn path=/head/; revision=96498
Diffstat (limited to 'games/wesnoth-devel/Makefile')
-rw-r--r--games/wesnoth-devel/Makefile75
1 files changed, 75 insertions, 0 deletions
diff --git a/games/wesnoth-devel/Makefile b/games/wesnoth-devel/Makefile
new file mode 100644
index 000000000000..b4e30682cb1c
--- /dev/null
+++ b/games/wesnoth-devel/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: wesnoth
+# Date created: 22 December 2003
+# Whom: Mezz <mezz7@cox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wesnoth
+PORTVERSION= 0.6.1
+CATEGORIES= games
+MASTER_SITES= http://www.wesnoth.org/files/
+
+MAINTAINER= mezz7@cox.net
+COMMENT= A fantasy turn-based strategy game
+
+LIB_DEPENDS= SDL_net.0:${PORTSDIR}/net/sdl_net \
+ SDL_ttf.3:${PORTSDIR}/graphics/sdl_ttf \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+USE_SDL= yes
+USE_GNOME= gnometarget
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+MAN6= wesnoth.6 wesnothd.6
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if defined(WITH_EDITOR) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-editor
+PLIST_SUB+= EDITOR:=""
+.else
+PLIST_SUB+= EDITOR:="@comment "
+.endif
+
+.if defined(WITH_SERVER) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-server
+PLIST_SUB+= SERVER:=""
+.else
+PLIST_SUB+= SERVER:="@comment "
+.endif
+
+.if defined(WITH_TOOLS) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-tools
+PLIST_SUB+= TOOLS:=""
+.else
+PLIST_SUB+= TOOLS:="@comment "
+.endif
+
+pre-everything::
+.if !defined(WITH_DEBUG) || !defined(WITH_EDITOR) || !defined(WITH_SERVER) || !defined(WITH_TOOLS)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+.endif
+
+.if !defined(WITH_DEBUG)
+ @${ECHO_MSG} "WITH_DEBUG=yes for enable debug in wesnoth."
+.endif
+
+.if !defined(WITH_EDITOR)
+ @${ECHO_MSG} "WITH_EDITOR=yes for enable compilation editor."
+.endif
+
+.if !defined(WITH_SERVER)
+ @${ECHO_MSG} "WITH_SERVER=yes for enable compilation of server."
+.endif
+
+.if !defined(WITH_TOOLS)
+ @${ECHO_MSG} "WITH_TOOLS=yes for enable compilation of translation tools."
+.endif
+
+.include <bsd.port.mk>