aboutsummaryrefslogtreecommitdiff
path: root/games/wordplay/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-08 14:14:52 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-08 14:14:52 +0000
commit1db16f8e552aad4090cd266419bd4e66edb03c7e (patch)
tree52f1d2325fbb5c7666ccbac5c24ab92b489c267e /games/wordplay/Makefile
parentad1bb388e254125ee59c69e886dc16e3d3a7d205 (diff)
downloadports-1db16f8e552aad4090cd266419bd4e66edb03c7e.tar.gz
ports-1db16f8e552aad4090cd266419bd4e66edb03c7e.zip
- Update MASTER_SITES and WWW: line
- Support NOPORTDOCS PR: 159461 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=279235
Diffstat (limited to 'games/wordplay/Makefile')
-rw-r--r--games/wordplay/Makefile31
1 files changed, 18 insertions, 13 deletions
diff --git a/games/wordplay/Makefile b/games/wordplay/Makefile
index 02482804413d..f74ee4293147 100644
--- a/games/wordplay/Makefile
+++ b/games/wordplay/Makefile
@@ -6,30 +6,35 @@
PORTNAME= wordplay
PORTVERSION= 7.22
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://hsvmovies.com/static_subpages/personal/wordplay/
+MASTER_SITES= http://hsvmovies.com/static_subpages/personal_orig/wordplay/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple program to generate anagrams
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
-
NO_WRKSUBDIR= yes
-MAKEFILE= makefile
-ALL_TARGET= wordplay
+
+PORTDOCS= readme
+PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/words721.txt
+PLIST_DIRS= %%DATADIR%%
post-patch:
- @${REINPLACE_CMD} -e \
- "s#words721.txt#${PREFIX}/share/wordplay/words721.txt#" \
- ${WRKSRC}/wordplay.c
+ @${REINPLACE_CMD} -e 's|"words721.txt"|"${DATADIR}/words721.txt"| ; \
+ s|<ctype.h>|<stdlib.h>|' ${WRKSRC}/wordplay.c
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${PORTNAME}.c -o ${PORTNAME}
do-install:
- @${MKDIR} ${PREFIX}/share/wordplay
- ${INSTALL_DATA} ${WRKSRC}/words721.txt ${WRKSRC}/readme \
- ${PREFIX}/share/wordplay
- ${INSTALL_PROGRAM} ${WRKSRC}/wordplay ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/words721.txt ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
+.endif
.include <bsd.port.mk>