aboutsummaryrefslogtreecommitdiff
path: root/games/xbill
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-20 17:56:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-20 17:56:36 +0000
commitf537e495f68473510028eb0970903c939fb1ee42 (patch)
treedb5f90a1091342de55e4948540a5803f55095cc7 /games/xbill
parent12c9856f98f14f33e68e80e56f550196f3b06d14 (diff)
downloadports-f537e495f68473510028eb0970903c939fb1ee42.tar.gz
ports-f537e495f68473510028eb0970903c939fb1ee42.zip
- Makefile cleanup
- Get rid of USE_X_PREFIX. Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=209462
Diffstat (limited to 'games/xbill')
-rw-r--r--games/xbill/Makefile38
1 files changed, 30 insertions, 8 deletions
diff --git a/games/xbill/Makefile b/games/xbill/Makefile
index 1391be429190..96c41a8e8402 100644
--- a/games/xbill/Makefile
+++ b/games/xbill/Makefile
@@ -8,7 +8,7 @@
PORTNAME= xbill
PORTVERSION= 2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://www.xbill.org/download/ \
http://www.amdmi3.ru/distfiles/
@@ -16,15 +16,37 @@ MASTER_SITES= http://www.xbill.org/download/ \
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= Save your computers from the evil clutches of Bill
+GNU_CONFIGURE= yes
+WANT_GNOME= yes
+CONFIGURE_ARGS= --localstatedir=${SCORES_DIR}
+
+MAN6= xbill.6
+
SCORES_DIR?= ${DATADIR}/scores
-USE_X_PREFIX= yes
-HAS_CONFIGURE= yes
-USE_XPM= yes
+OPTIONS= ATHENA "Build with Athena widget set" off \
+ GTK "Build with GTK widget set" on \
+ MOTIF "Build with Motif widget set" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ATHENA) && !defined(WITH_GTK) && !defined(WITH_MOTIF)
+CONFIGURE_ARGS+= --disable-gtk --disable-motif
+USE_XORG= xaw xmu xt x11 sm ice
+.elif !defined(WITH_ATHENA) && defined(WITH_GTK) && !defined(WITH_MOTIF)
+CONFIGURE_ARGS+= --disable-athena --disable-motif
USE_GNOME= gtk12
-CONFIGURE_ENV+= PREFIX=${PREFIX}
-CONFIGURE_ARGS+=--localstatedir=${SCORES_DIR}
+USE_XORG= sm ice
+.elif !defined(WITH_ATHENA) && !defined(WITH_GTK) && defined(WITH_MOTIF)
+CONFIGURE_ARGS+= --disable-athena --disable-gtk
+USE_XORG= xt x11 sm ice xpm
+USE_MOTIF= yes
+.else
+IGNORE= can't be build: please rerun 'make config' and chose exactly one widget set
+.endif
-MAN6= xbill.6
+post-patch:
+ @${REINPLACE_CMD} -e '/WIDGET_LIBS=/ s|-lXm"$$|-lXm -lXpm"|' \
+ ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>