aboutsummaryrefslogtreecommitdiff
path: root/games/xchadance
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 03:29:15 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 03:29:15 +0000
commitfb6dfb7a37133cd3272764de866920d025dffb2e (patch)
tree1f67d78ce151c27de481e8a2b380c9af4cf33e0d /games/xchadance
parenta4ebe4cba97114481308da3af4d59e547c6f1c8f (diff)
downloadports-fb6dfb7a37133cd3272764de866920d025dffb2e.tar.gz
ports-fb6dfb7a37133cd3272764de866920d025dffb2e.zip
1: Stagify.
2: fix compile with clang.
Notes
Notes: svn path=/head/; revision=356970
Diffstat (limited to 'games/xchadance')
-rw-r--r--games/xchadance/Makefile7
-rw-r--r--games/xchadance/files/patch-aa11
2 files changed, 9 insertions, 9 deletions
diff --git a/games/xchadance/Makefile b/games/xchadance/Makefile
index f2cd47cbda47..87813603480e 100644
--- a/games/xchadance/Makefile
+++ b/games/xchadance/Makefile
@@ -18,16 +18,15 @@ NO_WRKSUBDIR= yes
RESTRICTED= 'contains commercial character data'
-NO_STAGE= yes
post-patch:
@cd ${WRKSRC}; \
${PATCH} < ${WRKSRC}/xchada01.bug
post-install:
.if !defined(NOPORTOCS)
- @${MKDIR} ${PREFIX}/share/doc/xchadance
- @${INSTALL_DATA} ${WRKSRC}/README.jp ${PREFIX}/share/doc/xchadance
- @${INSTALL_DATA} ${WRKSRC}/README.eng ${PREFIX}/share/doc/xchadance
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/xchadance
+ @${INSTALL_DATA} ${WRKSRC}/README.jp ${STAGEDIR}${PREFIX}/share/doc/xchadance
+ @${INSTALL_DATA} ${WRKSRC}/README.eng ${STAGEDIR}${PREFIX}/share/doc/xchadance
.endif
.include <bsd.port.mk>
diff --git a/games/xchadance/files/patch-aa b/games/xchadance/files/patch-aa
index e1c9152e8442..6ebb43bbd619 100644
--- a/games/xchadance/files/patch-aa
+++ b/games/xchadance/files/patch-aa
@@ -1,21 +1,22 @@
---- makefile.orig Mon Mar 7 07:10:46 1994
-+++ makefile Sun Jun 20 15:11:51 1999
+--- makefile.orig 1994-03-07 21:10:46.000000000 +0800
++++ makefile 2014-06-08 11:28:02.677008487 +0800
@@ -1,6 +1,7 @@
- CC = gcc
+-CC = gcc
-CFLAGS = -Wall -O
-BINDIR = /usr/local/bin/
++#CC = gcc
+CFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -L${PREFIX}/lib -lX11
+BINDIR= ${PREFIX}/bin/
all : xchadance
-@@ -9,11 +10,11 @@
+@@ -9,11 +10,11 @@ clean :
rm *.o *~ *.bak core.* a.out
install :
- cp xchadance $(BINDIR)
-+ install -c -s xchadance $(BINDIR)
++ install -c -s xchadance $(DESTDIR)$(BINDIR)
xchadance : xchadance.o chadata.o