aboutsummaryrefslogtreecommitdiff
path: root/games/xevil
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>1995-05-05 23:42:52 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>1995-05-05 23:42:52 +0000
commit2cf78b38c38f3ecb67a466b13c2d8c8c4440368e (patch)
tree215a37e0416f66450408fecba5036920b8bfb9d2 /games/xevil
parent7f2e4959e2feacd4b2d2707c0f532c806110b4a0 (diff)
downloadports-2cf78b38c38f3ecb67a466b13c2d8c8c4440368e.tar.gz
ports-2cf78b38c38f3ecb67a466b13c2d8c8c4440368e.zip
XEvil is a side-view, fast-action, kill everything type of game.
Notes
Notes: svn path=/head/; revision=1637
Diffstat (limited to 'games/xevil')
-rw-r--r--games/xevil/Makefile17
-rw-r--r--games/xevil/distinfo1
-rw-r--r--games/xevil/files/patch-aa19
-rw-r--r--games/xevil/pkg-comment1
-rw-r--r--games/xevil/pkg-descr26
-rw-r--r--games/xevil/pkg-plist6
-rw-r--r--games/xevil/scripts/configure23
7 files changed, 93 insertions, 0 deletions
diff --git a/games/xevil/Makefile b/games/xevil/Makefile
new file mode 100644
index 000000000000..500378a12961
--- /dev/null
+++ b/games/xevil/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: xevil
+# Version required: 1.3
+# Date created: 6 May 1995
+# Whom: jmz
+#
+
+DISTNAME= xevil1.3
+PKGNAME= xevil-1.3
+CATEGORIES+= games x11
+MASTER_SITES= ftp://ftp.x.org/contrib/games/
+DISTFILES= xevil1.3.tar.Z
+
+MAINTAINER= jmz@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.mk>
diff --git a/games/xevil/distinfo b/games/xevil/distinfo
new file mode 100644
index 000000000000..0791f4736b9d
--- /dev/null
+++ b/games/xevil/distinfo
@@ -0,0 +1 @@
+MD5 (xevil1.3.tar.Z) = 72b2cd40cb72d6e46b89e4cd5e51b2d2
diff --git a/games/xevil/files/patch-aa b/games/xevil/files/patch-aa
new file mode 100644
index 000000000000..7417a7af7ca8
--- /dev/null
+++ b/games/xevil/files/patch-aa
@@ -0,0 +1,19 @@
+*** main.C~ Wed Feb 8 21:31:58 1995
+--- main.C Sat May 6 00:16:24 1995
+***************
+*** 49,55 ****
+
+
+ // Defines
+! #define MSEC_PER_CLOCK (1.0e3 / CLOCKS_PER_SEC)
+
+
+ #ifdef SELECT_NEEDS_PROTOTYPES
+--- 49,55 ----
+
+
+ // Defines
+! #define MSEC_PER_CLOCK 8 //(1.0e3 / CLOCKS_PER_SEC)
+
+
+ #ifdef SELECT_NEEDS_PROTOTYPES
diff --git a/games/xevil/pkg-comment b/games/xevil/pkg-comment
new file mode 100644
index 000000000000..d84bf69cb138
--- /dev/null
+++ b/games/xevil/pkg-comment
@@ -0,0 +1 @@
+XEvil is a side-view, fast-action, kill everything type of game. \ No newline at end of file
diff --git a/games/xevil/pkg-descr b/games/xevil/pkg-descr
new file mode 100644
index 000000000000..3ff085064b52
--- /dev/null
+++ b/games/xevil/pkg-descr
@@ -0,0 +1,26 @@
+INTRO:
+
+Death, kill, maim. XEvil is a side-view, fast-action, kill everything
+type of game. Play is against other human or computer players. XEvil
+is keyboard controlled with configurable controls.
+
+
+FEATURES:
+
+Color/Black&White/Grey Scale
+
+0, 1, or 2 player. A single player can play against machine
+players. Multiple humans can play cooperatively against machine players or
+against each other. You can watch machine players kill each other.
+
+Extreme violence.
+
+Assortment of characters, weapons, and items. E.g. ninja, alien,
+chainsaw, flame-thrower, Altar-Of-Sin, and soul-swapper.
+
+Keyboard controls can be configured with X resources or at runtime with the
+graphical interface.
+
+Game speed can be adjusted.
+
+Different styles of game play: levels, kill-kill-kill, duel, training.
diff --git a/games/xevil/pkg-plist b/games/xevil/pkg-plist
new file mode 100644
index 000000000000..fecf6e2b409c
--- /dev/null
+++ b/games/xevil/pkg-plist
@@ -0,0 +1,6 @@
+bin/xevil
+lib/app-defaults/XEvil.iris
+lib/app-defaults/XEvil.mac
+lib/app-defaults/XEvil.sun3
+lib/app-defaults/XEvil.sun4_sparc
+man/man6/xevil.6.gz
diff --git a/games/xevil/scripts/configure b/games/xevil/scripts/configure
new file mode 100644
index 000000000000..5318962b1dd9
--- /dev/null
+++ b/games/xevil/scripts/configure
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+cd $WRKSRC || exit 1
+
+cat >> Makefile << END
+
+all:
+ @\$(MAKE) CC="g++" CFLAGS="-DUSE_RANDOM -DPROTECTED_IS_PUBLIC" \
+ INCL_DIRS=-I/usr/X11R6/include LIBS_DIRS=-L/usr/X11R6/lib \
+ LIBS="-lX11 -lm" \$(TARGETS)
+
+DEBUG_OPT = -O2
+
+install:
+ cp xevil \$(PREFIX)/bin
+ mkdir -p \$(PREFIX)/lib/app-defaults
+ for f in iris mac sun3 sun4_sparc; do \
+ cp app-defaults/XEvil.\$\$f \$(PREFIX)/lib/app-defaults/; done
+ gzip -9 <xevil.6 >\$(PREFIX)/man/man6/xevil.6.gz
+
+END
+
+exit 0