aboutsummaryrefslogtreecommitdiff
path: root/games/xkoules
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-03-30 01:16:48 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-03-30 01:16:48 +0000
commit8f3c81664b18fdd8042ede48368f00234ad58973 (patch)
treea9505c7b19ae3930da9ffdb779f5334544bfb16d /games/xkoules
parent3de1607e21840fd2f3a443445364d031790c266d (diff)
downloadports-8f3c81664b18fdd8042ede48368f00234ad58973.tar.gz
ports-8f3c81664b18fdd8042ede48368f00234ad58973.zip
- Bump PORTREVISION
- Change master sites, add icon - Remove DEPRECATED, EXPIRATION_DATE - Add license (GPLv2) - Support STAGEDIR - Add Desktop entry file - Change DOCS, remove BUGS, Card and TODO - Recreate patches with make makepatch, add patch, fix bad C code - Change pkg-descr, add WWW - Change pkg-plist, remove DOCS
Notes
Notes: svn path=/head/; revision=349602
Diffstat (limited to 'games/xkoules')
-rw-r--r--games/xkoules/Makefile36
-rw-r--r--games/xkoules/distinfo2
-rw-r--r--games/xkoules/files/patch-Iconfig15
-rw-r--r--games/xkoules/files/patch-Imakefile (renamed from games/xkoules/files/patch-ac)4
-rw-r--r--games/xkoules/files/patch-aa24
-rw-r--r--games/xkoules/files/patch-koules.sndsrv.freebsd.c (renamed from games/xkoules/files/patch-ad)4
-rw-r--r--games/xkoules/files/patch-xlib__inlstring.h (renamed from games/xkoules/files/patch-xlib::inlstring.h)4
-rw-r--r--games/xkoules/files/patch-xlib__shmbitmap.c (renamed from games/xkoules/files/patch-ab)4
-rw-r--r--games/xkoules/files/patch-xlib__text.c10
-rw-r--r--games/xkoules/pkg-descr12
-rw-r--r--games/xkoules/pkg-plist9
11 files changed, 63 insertions, 61 deletions
diff --git a/games/xkoules/Makefile b/games/xkoules/Makefile
index f25b929cd63f..db12e1f7b3e0 100644
--- a/games/xkoules/Makefile
+++ b/games/xkoules/Makefile
@@ -3,38 +3,40 @@
PORTNAME= xkoules
PORTVERSION= 1.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= games/arcade/koules
-DISTNAME= ${PORTNAME:S/^x//}${PORTVERSION}
-EXTRACT_SUFX= -src.tar.gz
+MASTER_SITES= http://www.ucw.cz/~hubicka/koules/packages/ \
+ GENTOO/distfiles \
+ SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
+DISTFILES= ${PORTNAME:S/x//}${PORTVERSION}-src${EXTRACT_SUFX} \
+ ${PORTNAME:S/x//}.png:icons
+EXTRACT_ONLY= ${PORTNAME:S/x//}${PORTVERSION}-src${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast action arcade-style game for X Window
-DEPRECATED= Unmaintained since 2000
-EXPIRATION_DATE= 2014-04-11
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/${PORTNAME:S/x//}${PORTVERSION}
+
USES= imake
USE_XORG= x11 xext
-MAN6= xkoules.6
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
-
+PORTDOCS= ANNOUNCE ChangeLog Koules.FAQ README
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
+DESKTOP_ENTRIES="XKoules" "" "${PORTNAME}" \
+ "${PORTNAME} -M" "Game;ArcadeGame;" ""
post-extract:
@${CP} ${WRKSRC}/xkoules.6 ${WRKSRC}/xkoules.man
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
-.for file in ANNOUNCE BUGS Card ChangeLog Koules.FAQ TODO
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME:S/x//}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/xkoules/distinfo b/games/xkoules/distinfo
index 4f765d3ed2bd..2becbc69d73f 100644
--- a/games/xkoules/distinfo
+++ b/games/xkoules/distinfo
@@ -1,2 +1,4 @@
SHA256 (koules1.4-src.tar.gz) = c36f93feafeebd59983bf44100240e67a84a8bacabd7ee528c93046defe4a21b
SIZE (koules1.4-src.tar.gz) = 315386
+SHA256 (koules.png) = 35c61af80b724f6c0c5e67808813faae6396cce8af74055518c9aa649b967947
+SIZE (koules.png) = 626
diff --git a/games/xkoules/files/patch-Iconfig b/games/xkoules/files/patch-Iconfig
new file mode 100644
index 000000000000..bf693369aa9b
--- /dev/null
+++ b/games/xkoules/files/patch-Iconfig
@@ -0,0 +1,15 @@
+--- ./Iconfig.orig 1998-03-04 21:29:05.000000000 +0100
++++ ./Iconfig 2014-03-30 03:11:00.569385664 +0200
+@@ -34,9 +34,9 @@
+ recomended for linux*/
+ /*#define I386ASSEMBLY*/
+ /* directories*/
+-KOULESDIR =/usr/bin/X11
+-SOUNDDIR =/usr/local/lib/koules
+-MANDIR =/usr/local/man/man6
++KOULESDIR =${DESTDIR}$(PREFIX)/libexec
++SOUNDDIR =${DESTDIR}$(PREFIX)/share/xkoules
++MANSUFFIX =6
+
+ /*You need some extra libraryes for BSD sockets compatibility?*/
+ /* TOP_INCLUDES = /* Sun users with GCC need this */
diff --git a/games/xkoules/files/patch-ac b/games/xkoules/files/patch-Imakefile
index 9fc513795ce4..c95e461a9819 100644
--- a/games/xkoules/files/patch-ac
+++ b/games/xkoules/files/patch-Imakefile
@@ -1,5 +1,5 @@
---- Imakefile.orig Thu Mar 5 03:59:19 1998
-+++ Imakefile Sat Oct 14 08:58:09 2000
+--- ./Imakefile.orig 1998-03-04 19:59:19.000000000 +0100
++++ ./Imakefile 2014-03-30 03:11:00.569385664 +0200
@@ -56,7 +56,7 @@
DEFINES = -DONLYANSI -DSOUND $(JOYSTICK1) $(NET) $(MITSHM1) $(HAVEUSLEEP1) $(SYSDEFS) $(JOYSTICK) -Ixlib\
diff --git a/games/xkoules/files/patch-aa b/games/xkoules/files/patch-aa
deleted file mode 100644
index f5f665976b6e..000000000000
--- a/games/xkoules/files/patch-aa
+++ /dev/null
@@ -1,24 +0,0 @@
---- Iconfig.orig Thu Mar 5 05:29:05 1998
-+++ Iconfig Sat Oct 14 08:48:54 2000
-@@ -34,9 +34,9 @@
- recomended for linux*/
- /*#define I386ASSEMBLY*/
- /* directories*/
--KOULESDIR =/usr/bin/X11
--SOUNDDIR =/usr/local/lib/koules
--MANDIR =/usr/local/man/man6
-+KOULESDIR =$(PREFIX)/libexec
-+SOUNDDIR =$(PREFIX)/share/xkoules
-+MANSUFFIX =6
-
- /*You need some extra libraryes for BSD sockets compatibility?*/
- /* TOP_INCLUDES = /* Sun users with GCC need this */
-@@ -94,7 +94,7 @@
-
- #if defined(FreeBSDArchitecture)
- SYSDEFS =
--#if !defined(NAS_SOUND)&&!defined(RSOUND)
-+#if !defined(NAS_SOUND)&&!defined(RSOUND)
- #define SOUND
- SOUNDSERVER = koules.sndsrv.freebsd
- SOUNDOBJS = sound.o
diff --git a/games/xkoules/files/patch-ad b/games/xkoules/files/patch-koules.sndsrv.freebsd.c
index 40d26ab2a865..a5ee893517ba 100644
--- a/games/xkoules/files/patch-ad
+++ b/games/xkoules/files/patch-koules.sndsrv.freebsd.c
@@ -1,5 +1,5 @@
---- ./koules.sndsrv.freebsd.c.orig Sun Sep 8 01:03:48 2002
-+++ ./koules.sndsrv.freebsd.c Sun Sep 8 01:03:55 2002
+--- ./koules.sndsrv.freebsd.c.orig 1998-03-04 19:59:19.000000000 +0100
++++ ./koules.sndsrv.freebsd.c 2014-03-30 03:11:00.579428909 +0200
@@ -14,7 +14,7 @@
#include <unistd.h>
#include <fcntl.h>
diff --git a/games/xkoules/files/patch-xlib::inlstring.h b/games/xkoules/files/patch-xlib__inlstring.h
index db7c7a597652..13cc8c9cfb7c 100644
--- a/games/xkoules/files/patch-xlib::inlstring.h
+++ b/games/xkoules/files/patch-xlib__inlstring.h
@@ -1,5 +1,5 @@
---- xlib/inlstring.h.orig Thu Mar 5 03:59:19 1998
-+++ xlib/inlstring.h Sat Oct 25 20:52:47 2003
+--- ./xlib/inlstring.h.orig 1998-03-04 19:59:19.000000000 +0100
++++ ./xlib/inlstring.h 2014-03-30 03:11:00.579428909 +0200
@@ -238,12 +238,12 @@
static INLINE void *
__memcpy_aligndest (void *dest, const void *src, int n)
diff --git a/games/xkoules/files/patch-ab b/games/xkoules/files/patch-xlib__shmbitmap.c
index ea84438e9f75..1f9356b4d755 100644
--- a/games/xkoules/files/patch-ab
+++ b/games/xkoules/files/patch-xlib__shmbitmap.c
@@ -1,5 +1,5 @@
---- xlib/shmbitmap.c.orig Thu Mar 5 03:59:19 1998
-+++ xlib/shmbitmap.c Tue Jun 13 03:45:28 2000
+--- ./xlib/shmbitmap.c.orig 1998-03-04 19:59:19.000000000 +0100
++++ ./xlib/shmbitmap.c 2014-03-30 03:11:00.579428909 +0200
@@ -237,7 +237,7 @@
#define __clipy1 0
#undef __clipy2
diff --git a/games/xkoules/files/patch-xlib__text.c b/games/xkoules/files/patch-xlib__text.c
new file mode 100644
index 000000000000..60c1793ca8ce
--- /dev/null
+++ b/games/xkoules/files/patch-xlib__text.c
@@ -0,0 +1,10 @@
+--- ./xlib/text.c.orig 1998-03-04 19:59:19.000000000 +0100
++++ ./xlib/text.c 2014-03-30 03:12:11.082033640 +0200
+@@ -4,6 +4,7 @@
+
+ #ifdef MITSHM
+ #include <stdlib.h>
++#include <string.h>
+ #include "inlstring.h" /* include inline string operations */
+ #include "interface.h"
+
diff --git a/games/xkoules/pkg-descr b/games/xkoules/pkg-descr
index b68014c4260c..0dd4f36a7c8a 100644
--- a/games/xkoules/pkg-descr
+++ b/games/xkoules/pkg-descr
@@ -1,6 +1,8 @@
- Koules is a fast action arcade-style game for X. This version
-works in fine (up to 900x620) resolution with cool 256 color
-graphics, multiplayer mode up to 5 players, full sound and, of
-course, network support. Koules is an original idea. First
-version of Koules was developed from scratch by Jan Hubicka in
+Koules is a fast action arcade-style game for X. This version
+works in fine (up to 900x620) resolution with cool 256 color
+graphics, multiplayer mode up to 5 players, full sound and, of
+course, network support. Koules is an original idea. First
+version of Koules was developed from scratch by Jan Hubicka in
July 1995.
+
+WWW: http://www.ucw.cz/~hubicka/koules/English/koules.html
diff --git a/games/xkoules/pkg-plist b/games/xkoules/pkg-plist
index fbb220c46bf9..ecc727a8587d 100644
--- a/games/xkoules/pkg-plist
+++ b/games/xkoules/pkg-plist
@@ -1,11 +1,7 @@
bin/xkoules
-%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
-%%PORTDOCS%%%%DOCSDIR%%/BUGS
-%%PORTDOCS%%%%DOCSDIR%%/Card
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/Koules.FAQ
-%%PORTDOCS%%%%DOCSDIR%%/TODO
libexec/koules.sndsrv.freebsd
+man/man6/xkoules.6.gz
+share/pixmaps/xkoules.png
%%DATADIR%%/colize.raw
%%DATADIR%%/creator1.raw
%%DATADIR%%/creator2.raw
@@ -14,4 +10,3 @@ libexec/koules.sndsrv.freebsd
%%DATADIR%%/end.raw
%%DATADIR%%/start.raw
@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%