aboutsummaryrefslogtreecommitdiff
path: root/games/xlines/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-05-24 11:08:24 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-05-24 11:08:24 +0000
commit10e344b7a245da1718968f36c5d4783e7b1a13a6 (patch)
tree7ebc89cd2efb5dbd681ac61da326a56117883d41 /games/xlines/Makefile
parent14add4ebc53a305838766aec585738682cb217bb (diff)
downloadports-10e344b7a245da1718968f36c5d4783e7b1a13a6.tar.gz
ports-10e344b7a245da1718968f36c5d4783e7b1a13a6.zip
Add back the blackjack, pp and xlines ports, which were prematurely
deleted by will.
Notes
Notes: svn path=/head/; revision=59879
Diffstat (limited to 'games/xlines/Makefile')
-rw-r--r--games/xlines/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/games/xlines/Makefile b/games/xlines/Makefile
new file mode 100644
index 000000000000..8b7f0b387839
--- /dev/null
+++ b/games/xlines/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xlines
+# Date created: 11 February 1998
+# Whom: Andrey Zakhvatov
+#
+# $FreeBSD$
+#
+
+PORTNAME= xlines
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.trolltech.com/contrib/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_QT_VER= 1
+USE_X_PREFIX= yes
+NO_WRKSUBDIR= yes
+
+pre-patch:
+ @find ${WRKSRC} -type f | xargs ${PERL} -pi -e "s|\r\n|\n|g"
+
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/*.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xlines ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/xlines
+ ${INSTALL_DATA} ${WRKSRC}/trolltech.gif ${PREFIX}/share/xlines
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/readme.lines ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/readme.qt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>