aboutsummaryrefslogtreecommitdiff
path: root/games/xmines/files
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-08-18 19:48:20 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-08-18 19:48:20 +0000
commit013a99fe9da03bb4f0ad631cfc54af1edbc01db6 (patch)
treeded66ff4dc09d55ded7d88c9e2c07042438b9123 /games/xmines/files
parentc1099a544af87db64aaac4158d36aaf36aba8fae (diff)
downloadports-013a99fe9da03bb4f0ad631cfc54af1edbc01db6.tar.gz
ports-013a99fe9da03bb4f0ad631cfc54af1edbc01db6.zip
Imp[ort of xmines.
Xmines is yet another minesweeper-type game for the X window system. PR: 13221 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=20793
Diffstat (limited to 'games/xmines/files')
-rw-r--r--games/xmines/files/patch-aa41
-rw-r--r--games/xmines/files/patch-ab11
2 files changed, 52 insertions, 0 deletions
diff --git a/games/xmines/files/patch-aa b/games/xmines/files/patch-aa
new file mode 100644
index 000000000000..32068aeb0f3b
--- /dev/null
+++ b/games/xmines/files/patch-aa
@@ -0,0 +1,41 @@
+--- Makefile Fri Dec 3 17:22:38 1993
++++ /home/andy/tmp/wrk/Makefile Wed Aug 18 13:51:45 1999
+@@ -3,20 +3,20 @@
+ #
+ # make clean removes all temporary files.
+
+-CFLAGS = -O
+-CC = gcc
+-INCLUDE = /usr/X386/include
+-LIBRARY = /usr/X386/lib
+-BIN = /usr/X386/bin
+-SCOREFILES = /usr/X386/lib/X11/games
++#CFLAGS = -O
++CC ?= gcc
++INCLUDE = ${X11BASE}/include
++LIBRARY = ${X11BASE}/lib
++BIN = ${X11BASE}/bin
++SCOREFILES = ${X11BASE}/share/xmines
+
+ .c.o:
+ $(CC) $(CFLAGS) -I $(INCLUDE) -c $<
+
+-all: xbombs
++all: xmines
+
+-xbombs: xmines.o X11.o score.o
+- $(CC) -L $(LIBRARY) -o xbombs xmines.o score.o X11.o -lX11
++xmines: xmines.o X11.o score.o
++ $(CC) -L $(LIBRARY) -o xmines xmines.o score.o X11.o -lX11
+
+ X11.o: covered.pat flag.pat gray.pat highlight.pat marked.pat mine.pat ohno.pat shades.pat smiley.pat uncovered.pat uncoveredcolor.pat
+
+@@ -24,5 +24,6 @@
+ rm -f *.o
+
+ install:
+- install -g games -o games -m 0664 scores/scores $(SCOREFILES)/xbomb-scores
+- install -g games -o games -m 2755 xbombs $(BIN)
++ mkdir -p $(SCOREFILES)
++ install -g games -o games -m 0666 scores/scores $(SCOREFILES)/scores
++ install -g games -o games -m 0755 xmines $(BIN)
diff --git a/games/xmines/files/patch-ab b/games/xmines/files/patch-ab
new file mode 100644
index 000000000000..6661c8c59f6e
--- /dev/null
+++ b/games/xmines/files/patch-ab
@@ -0,0 +1,11 @@
+--- score.c Fri Dec 3 17:18:35 1993
++++ /home/andy/tmp/wrk/score.c Wed Aug 18 13:21:33 1999
+@@ -6,7 +6,7 @@
+
+
+ FILE *scoreFile;
+-#define SCOREfILE "/usr/X386/lib/X11/games/xbomb-scores"
++#define SCOREfILE "/usr/X11R6/share/xmines/scores"
+ #define NUMsCORES 10
+ #define NAMEsIZE 50
+ #define SCOREfORMAT "%5d %s\n"