aboutsummaryrefslogtreecommitdiff
path: root/games/xmoto/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-22 14:31:42 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-22 14:31:42 +0000
commitbde4675bef50646658bb7c920a6db2a4b0c327f1 (patch)
treef404cc00ca9222a6a03a9e89bc22d70add5aff22 /games/xmoto/Makefile
parent744e2916a23e17f1b660908867b08593bb50534a (diff)
downloadports-bde4675bef50646658bb7c920a6db2a4b0c327f1.tar.gz
ports-bde4675bef50646658bb7c920a6db2a4b0c327f1.zip
Update to 0.1.14
PR: 97509 Submitted by: Dmitry Marakasov <amdmi3@mail.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=163098
Diffstat (limited to 'games/xmoto/Makefile')
-rw-r--r--games/xmoto/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index f64ea62eabbf..a2f2be782087 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmoto
-PORTVERSION= 0.1.12
+PORTVERSION= 0.1.14
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -36,11 +36,22 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= README ChangeLog
+OPTIONS= CURL "Online high-scores and new levels download support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_CURL)
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/src/VCommon.h
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/image/tim_memory_crt.cpp
@${REINPLACE_CMD} -e 's|endian.h|sys/endian.h|' ${WRKSRC}/src/VCommon.h
@${REINPLACE_CMD} -e '/LIBS/ s|\(-lSDL_mixer\)|\1 `${SDL_CONFIG} --libs`|' ${WRKSRC}/configure
+.if !defined(WITH_CURL)
+ @${REINPLACE_CMD} -e 's|test $$ac_cv_lib_curl_curl_easy_init = yes|false|' ${WRKSRC}/configure
+.endif
.if !defined(NOPORTDOCS)
post-install:
@@ -50,4 +61,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>