aboutsummaryrefslogtreecommitdiff
path: root/games/xonotic/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-06-18 19:38:27 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-06-18 19:38:27 +0000
commit4384aa7dd60c4c0157776f1e7e0c880316d15b16 (patch)
treecb967bd245624c6ce01475fa8796d1a3e93b96d7 /games/xonotic/Makefile
parentb1650bcf681d6e49fe2eeb1ae8d4c896e7fd2c2d (diff)
downloadports-4384aa7dd60c4c0157776f1e7e0c880316d15b16.tar.gz
ports-4384aa7dd60c4c0157776f1e7e0c880316d15b16.zip
- Better separate extracting and patching
- Minor textual nit in comment
Notes
Notes: svn path=/head/; revision=215111
Diffstat (limited to 'games/xonotic/Makefile')
-rw-r--r--games/xonotic/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/xonotic/Makefile b/games/xonotic/Makefile
index e4d5e4e62d6a..5279181254a8 100644
--- a/games/xonotic/Makefile
+++ b/games/xonotic/Makefile
@@ -40,7 +40,7 @@ PLIST_SUB+= MAPPACK="@comment "
.endif
.if !(defined(WITHOUT_CLIENT) && defined(WITHOUT_SDL_CLIENT))
-# Loads libraries on run-time, thus RUN_DEPENDS
+# Loads libraries at run-time, thus RUN_DEPENDS
RUN_DEPENDS= ${LOCALBASE}/lib/libvorbis.so:${PORTSDIR}/audio/libvorbis \
${LOCALBASE}/lib/libjpeg.so:${PORTSDIR}/graphics/jpeg \
${LOCALBASE}/lib/libpng.so:${PORTSDIR}/graphics/png \
@@ -71,9 +71,11 @@ PLIST_SUB+= SERVER=""
PLIST_SUB+= SERVER="@comment "
.endif
-post-patch:
+post-extract:
@${EXTRACT_CMD} ${WRKDIR}/Nexuiz/sources/enginesource20080511.zip \
-d ${WRKDIR}/Nexuiz/sources
+
+post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},' ${WRKSRC}/${MAKEFILE}
do-build: