aboutsummaryrefslogtreecommitdiff
path: root/games/xpacman
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2014-08-10 15:02:19 +0000
committerWen Heping <wen@FreeBSD.org>2014-08-10 15:02:19 +0000
commit0dbc01a290e871a86202d2537f15634884bf997a (patch)
treef20a54c4bf9bd087f675e1ef6ff3e70578f06ca7 /games/xpacman
parent65d8f20e322c12f35313c4df5ec247d352e312d4 (diff)
downloadports-0dbc01a290e871a86202d2537f15634884bf997a.tar.gz
ports-0dbc01a290e871a86202d2537f15634884bf997a.zip
- Update to 1.002
- Stage support - Fix build with clang PR: 192546 Submitted by: Vladimir Kondratiev <wulf@cicgroup.ru>
Notes
Notes: svn path=/head/; revision=364548
Diffstat (limited to 'games/xpacman')
-rw-r--r--games/xpacman/Makefile17
-rw-r--r--games/xpacman/distinfo4
-rw-r--r--games/xpacman/files/patch-a12
-rw-r--r--games/xpacman/files/patch-board.cc11
-rw-r--r--games/xpacman/files/patch-f3
-rw-r--r--games/xpacman/files/patch-pac.cc11
-rw-r--r--games/xpacman/files/patch-sizes.h17
7 files changed, 43 insertions, 32 deletions
diff --git a/games/xpacman/Makefile b/games/xpacman/Makefile
index 72aae3a3e811..1e6828affeda 100644
--- a/games/xpacman/Makefile
+++ b/games/xpacman/Makefile
@@ -2,20 +2,23 @@
# $FreeBSD$
PORTNAME= xpacman
-PORTVERSION= 1.0
-PORTREVISION= 3
+PORTVERSION= 1.002
CATEGORIES= games
MASTER_SITES= ftp://ftp.nvg.unit.no/pub/pacman/
-DISTNAME= pacman10
+DISTNAME= pacman-1_002
MAINTAINER= ports@FreeBSD.org
COMMENT= Old action game
-NO_WRKSUBDIR= Does not unpack into subdir.
-USES= imake zip
+LICENSE= GPLv2
+
+RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/misc/9x18.pcf.gz:${PORTSDIR}/x11-fonts/font-misc-misc
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-doublesize
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USE_XORG= x11 xext
-MAN1= pacman.1
PLIST_FILES= bin/pacman
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/xpacman/distinfo b/games/xpacman/distinfo
index 2d859de6068b..b82d0c16462c 100644
--- a/games/xpacman/distinfo
+++ b/games/xpacman/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pacman10.zip) = 6614635a5fbc3455772e62f4719ea3de5daad56ae2cbcb1564d57246d58c4cfd
-SIZE (pacman10.zip) = 64523
+SHA256 (pacman-1_002.tar.gz) = c033268ab520937c867a8ff6f989a4dbe5d4bd38c23191db29ec39d8e807d622
+SIZE (pacman-1_002.tar.gz) = 86822
diff --git a/games/xpacman/files/patch-a b/games/xpacman/files/patch-a
deleted file mode 100644
index 19373827e170..000000000000
--- a/games/xpacman/files/patch-a
+++ /dev/null
@@ -1,12 +0,0 @@
---- Imakefile.orig Sun Sep 8 13:55:25 2002
-+++ Imakefile Sun Sep 8 13:55:59 2002
-@@ -23,7 +23,8 @@
- /* most X11 screens are rather large, you might wisht to use "double" mode */
- CXXEXTRA_DEFINES = -DDOUBLE
-
--NormalProgramTarget(pacman,$(OBJS),$(DEPXLIB),$(CURSES),$(XLIB))
-+NormalCplusplusProgramTarget(pacman,$(OBJS),$(DEPXLIB),$(CURSES),$(XLIB))
- InstallProgram(pacman,$(BINDIR))
- InstallManPage(pacman,$(MANDIR))
-+AllTarget(pacman)
- DependTarget()
diff --git a/games/xpacman/files/patch-board.cc b/games/xpacman/files/patch-board.cc
index 65c431e4a272..84096693f508 100644
--- a/games/xpacman/files/patch-board.cc
+++ b/games/xpacman/files/patch-board.cc
@@ -1,15 +1,6 @@
--- board.cc.orig Tue Jul 18 11:03:22 1995
+++ board.cc Mon Mar 10 20:52:04 2008
-@@ -119,7 +119,7 @@
- oldtemp=oldlist;
- while (oldtemp) { //delete elements in the now previous sprite list
- oldnext=oldtemp->next;
-- delete oldnext;
-+ delete oldtemp;
- oldtemp=oldnext;
- }
- if (zero && oldlist) { //personal thingie used for debug, not useful
-@@ -157,6 +157,7 @@
+@@ -527,6 +527,7 @@
void Board::sprite(DynamicElement *g) { //let dynamicelement be a sprite
liststruct *temp=0,*last=0; //resets to null
liststruct *ny=new liststruct; //get a new liststruct
diff --git a/games/xpacman/files/patch-f b/games/xpacman/files/patch-f
index 1a207e366f03..c45f8e72ef1d 100644
--- a/games/xpacman/files/patch-f
+++ b/games/xpacman/files/patch-f
@@ -2,9 +2,10 @@
+++ point.cc Sun Jan 9 01:51:34 2000
@@ -1,7 +1,7 @@
#include"point.h"
- Point::Point(int xx=0,int yy=0) { x=xx; y=yy; };
+-Point::Point(int xx=0,int yy=0) { x=xx; y=yy; };
-Point::val_x() { return x; };
-Point::val_y() { return y; };
++Point::Point(int xx,int yy) { x=xx; y=yy; };
+int Point::val_x() { return x; };
+int Point::val_y() { return y; };
void Point::set_x(int xx) { x=xx; };
diff --git a/games/xpacman/files/patch-pac.cc b/games/xpacman/files/patch-pac.cc
new file mode 100644
index 000000000000..cb80b334391c
--- /dev/null
+++ b/games/xpacman/files/patch-pac.cc
@@ -0,0 +1,11 @@
+--- pac.cc.orig 1995-07-20 16:59:35.000000000 +0400
++++ pac.cc 2014-08-09 11:48:00.762643451 +0400
+@@ -82,7 +82,7 @@
+ UserInterface::setlpCmdLine(lpCmdLine);
+ UserInterface::setnCmdShow(nCmdShow);
+ #else
+-main(int argc,char **argv) {
++int main(int argc,char **argv) {
+ Argument(argc, argv); // storing the command line arguments
+ #endif
+
diff --git a/games/xpacman/files/patch-sizes.h b/games/xpacman/files/patch-sizes.h
new file mode 100644
index 000000000000..6b21252f3967
--- /dev/null
+++ b/games/xpacman/files/patch-sizes.h
@@ -0,0 +1,17 @@
+--- sizes.h.orig 1995-07-13 16:14:05.000000000 +0400
++++ sizes.h 2014-08-09 11:16:01.638794330 +0400
+@@ -21,12 +21,12 @@
+ #ifndef DOUBLE
+ #define TEXTWIDTH 8
+ #define TEXTHEIGHT 8
+-#define FONT1 "5x8"
++#define FONT1 "-misc-fixed-*-r-*-*-8-*-*-*-*-*-*-*"
+ #define FONT2 "5x7"
+ #else
+ #define TEXTWIDTH 8
+ #define TEXTHEIGHT 16
+-#define FONT1 "8x16"
++#define FONT1 "-misc-fixed-*-r-*-*-18-*-*-*-*-*-*-*"
+ #define FONT2 "7x14"
+ #endif
+ //#define PFONT "clR6x8.fb"/*clR8x8" "6x10"*/