aboutsummaryrefslogtreecommitdiff
path: root/games/xpipeman
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-03 00:52:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-03 00:52:11 +0000
commitdf18b854084afe1a5d58a17048a0bb6489f6fd32 (patch)
tree84e82874c44c3e343e1d00cb6514a313fbfbcb02 /games/xpipeman
parent4f42a45eccf41cb69fc7cdd555b122478357ec74 (diff)
downloadports-df18b854084afe1a5d58a17048a0bb6489f6fd32.tar.gz
ports-df18b854084afe1a5d58a17048a0bb6489f6fd32.zip
- Fix build on amd64
- Drop MD5 PR: 154470 Submitted by: kilian <kilian.klimek@googlemail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=268565
Diffstat (limited to 'games/xpipeman')
-rw-r--r--games/xpipeman/Makefile4
-rw-r--r--games/xpipeman/distinfo1
-rw-r--r--games/xpipeman/files/patch-aa84
-rw-r--r--games/xpipeman/files/patch-ab2
-rw-r--r--games/xpipeman/files/patch-ac37
5 files changed, 71 insertions, 57 deletions
diff --git a/games/xpipeman/Makefile b/games/xpipeman/Makefile
index 22fccc5868bd..f69538073307 100644
--- a/games/xpipeman/Makefile
+++ b/games/xpipeman/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xpipeman
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/strategy
@@ -18,7 +18,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Connect the pipes to stop the leaks
# LP64 issues
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
USE_IMAKE= yes
USE_XORG= x11 xaw xext xmu xt sm ice
diff --git a/games/xpipeman/distinfo b/games/xpipeman/distinfo
index 21bdf0346114..960842151d1a 100644
--- a/games/xpipeman/distinfo
+++ b/games/xpipeman/distinfo
@@ -1,3 +1,2 @@
-MD5 (xpipeman.tar.Z) = e14febe8d74d5a20158cfe4f4cc351f0
SHA256 (xpipeman.tar.Z) = 02335906321203e30e6315bf1b8fb3691677eba58ee54105f23e5692d5fbc383
SIZE (xpipeman.tar.Z) = 81525
diff --git a/games/xpipeman/files/patch-aa b/games/xpipeman/files/patch-aa
index 0965482aea94..ddeaebecb34b 100644
--- a/games/xpipeman/files/patch-aa
+++ b/games/xpipeman/files/patch-aa
@@ -1,53 +1,31 @@
-*** score.c.orig Fri Sep 13 16:32:12 1991
---- score.c Sun Apr 12 12:33:16 1998
-***************
-*** 50,56 ****
- #include <X11/Xaw/Label.h>
- #endif
-
-! #include <X11/Xos.h> /* brings in <sys/file.h> */
- #include <stdio.h>
- #include "xpipeman.h"
-
---- 50,56 ----
- #include <X11/Xaw/Label.h>
- #endif
-
-! #include <sys/file.h>
- #include <stdio.h>
- #include "xpipeman.h"
-
-***************
-*** 64,70 ****
-
- static SCORE scores[MAXSCORES];
-
-! void show_scores(),
- new_high_score(),
- load_scores(),
- write_out_scores();
---- 64,70 ----
-
- static SCORE scores[MAXSCORES];
-
-! static void show_scores(),
- new_high_score(),
- load_scores(),
- write_out_scores();
-***************
-*** 198,204 ****
-
-
- /*ARGSUSED*/
-! static XtCallbackProc
- popdown_callback(w, closure, call_data)
- Widget w;
- caddr_t closure;
---- 198,204 ----
-
-
- /*ARGSUSED*/
-! static void
- popdown_callback(w, closure, call_data)
- Widget w;
- caddr_t closure;
+--- score.c.orig 1991-09-13 22:32:12.000000000 +0200
++++ score.c 2011-02-02 19:34:46.908945354 +0100
+@@ -50,8 +50,9 @@
+ #include <X11/Xaw/Label.h>
+ #endif
+
+-#include <X11/Xos.h> /* brings in <sys/file.h> */
++#include <sys/file.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "xpipeman.h"
+
+ /*----------------------------------------------------------------------*/
+@@ -64,7 +65,7 @@
+
+ static SCORE scores[MAXSCORES];
+
+-void show_scores(),
++static void show_scores(),
+ new_high_score(),
+ load_scores(),
+ write_out_scores();
+@@ -198,7 +199,7 @@
+
+
+ /*ARGSUSED*/
+-static XtCallbackProc
++static void
+ popdown_callback(w, closure, call_data)
+ Widget w;
+ caddr_t closure;
diff --git a/games/xpipeman/files/patch-ab b/games/xpipeman/files/patch-ab
index 330988abe512..6bf293e882fa 100644
--- a/games/xpipeman/files/patch-ab
+++ b/games/xpipeman/files/patch-ab
@@ -15,7 +15,7 @@
SYS_LIBRARIES = -lm
+ MANSUFFIX = 6
-+ INSTPGMFLAGS = -g games
++ INSTPGMFLAGS = -g games -m 2755
+
all:: xpipeman
diff --git a/games/xpipeman/files/patch-ac b/games/xpipeman/files/patch-ac
new file mode 100644
index 000000000000..9c079224368d
--- /dev/null
+++ b/games/xpipeman/files/patch-ac
@@ -0,0 +1,37 @@
+--- main.c.orig 2011-02-02 19:11:34.000000000 +0100
++++ main.c 2011-01-24 17:44:29.000000000 +0100
+@@ -146,16 +146,6 @@
+ {"-scorefile","scorefile",XrmoptionSepArg, NULL },
+ };
+
+-static XtResource application_resources[] = {
+- {"foreground", "Foreground", XtRPixel, sizeof(Pixel),
+- (Cardinal)&fg, XtRString, (caddr_t) "Black"},
+- {"background", "Background", XtRPixel, sizeof(Pixel),
+- (Cardinal)&bg, XtRString, (caddr_t) "White"},
+- {"translations","Translations", XtRTranslationTable, sizeof(XtTranslations),
+- (Cardinal)&translations, XtRString, (caddr_t)translations_str},
+- {"scorefile","Scorefile", XtRString, sizeof(String),
+- (Cardinal)&score_filename, XtRString, (caddr_t)SCORE_FILE},
+-};
+
+ /*----------------------------------------------------------------------*/
+
+@@ -168,6 +158,17 @@
+ Widget quit_command,
+ new_game_command;
+
++XtResource application_resources[] = {
++ {"foreground", "Foreground", XtRPixel, sizeof(Pixel),
++ (Cardinal)&fg, XtRString, (caddr_t) "Black"},
++ {"background", "Background", XtRPixel, sizeof(Pixel),
++ (Cardinal)&bg, XtRString, (caddr_t) "White"},
++ {"translations","Translations", XtRTranslationTable, sizeof(XtTranslations),
++ (Cardinal)&translations, XtRString, (caddr_t)translations_str},
++ {"scorefile","Scorefile", XtRString, sizeof(String),
++ (Cardinal)&score_filename, XtRString, (caddr_t)SCORE_FILE},
++};
++
+ srandom(getpid());
+ current_block = 0;
+ current_callback = NULL;