aboutsummaryrefslogtreecommitdiff
path: root/games/xrot/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 05:51:42 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 05:51:42 +0000
commitc00a15fd548af7047799b9984402dcb92ba5bcdf (patch)
treea52f3e7fbd96d237230cc3bb320ae5c1751b870d /games/xrot/Makefile
parent48b2f551aed7b6f9e56b062dbccc425656695375 (diff)
downloadports-c00a15fd548af7047799b9984402dcb92ba5bcdf.tar.gz
ports-c00a15fd548af7047799b9984402dcb92ba5bcdf.zip
Add xrot 1.3.2, a falling ball puzzle game for X.
PR: 26377 Submitted by: Mark Pulford <mark@kyne.com.au>
Notes
Notes: svn path=/head/; revision=41005
Diffstat (limited to 'games/xrot/Makefile')
-rw-r--r--games/xrot/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/xrot/Makefile b/games/xrot/Makefile
new file mode 100644
index 000000000000..3a56cafc72bc
--- /dev/null
+++ b/games/xrot/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xrot
+# Date created: Apr 2, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xrot
+PORTVERSION= 1.3.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ ftp://ftp.kobe-u.ac.jp/pub/Linux/packages/Vine/VinePlus/1.1/JG-0.9.1/sources/
+MASTER_SITE_SUBDIR= will
+
+MAINTAINER= mark@kyne.com.au
+
+WRKSRC= ${WRKDIR}/xrot
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+
+post-configure:
+ ${PERL} -pi -e "s@: xrot.man@:@g; s@xrot.man@/dev/null@g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xrot ${PREFIX}/bin
+ ${CHOWN} root.games ${PREFIX}/bin/xrot
+ ${CHMOD} g+s ${PREFIX}/bin/xrot
+ ${SH} pkg-install ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>