aboutsummaryrefslogtreecommitdiff
path: root/games/xshisen
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-17 22:48:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-17 22:48:49 +0000
commit379c9824eaf1f2087f9ff8bd67751d97eced61b1 (patch)
tree7a2d168d35a8ae9f8e5f9cd83c3ad1ec3285163f /games/xshisen
parent3b940d8a150a403400489116bdbde060e80f5fab (diff)
downloadports-379c9824eaf1f2087f9ff8bd67751d97eced61b1.tar.gz
ports-379c9824eaf1f2087f9ff8bd67751d97eced61b1.zip
- Update to 1.51
PR: ports/86269 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=143044
Diffstat (limited to 'games/xshisen')
-rw-r--r--games/xshisen/Makefile47
-rw-r--r--games/xshisen/distinfo4
-rw-r--r--games/xshisen/files/patch-aa11
-rw-r--r--games/xshisen/files/patch-ac21
-rw-r--r--games/xshisen/files/patch-ad95
-rw-r--r--games/xshisen/files/patch-ae11
-rw-r--r--games/xshisen/files/patch-af159
-rw-r--r--games/xshisen/files/patch-readxpm.C8
-rw-r--r--games/xshisen/pkg-plist114
9 files changed, 110 insertions, 360 deletions
diff --git a/games/xshisen/Makefile b/games/xshisen/Makefile
index 814b1794d0ff..07b6d2332b26 100644
--- a/games/xshisen/Makefile
+++ b/games/xshisen/Makefile
@@ -6,41 +6,50 @@
#
PORTNAME= xshisen
-PORTVERSION= 1.36
-PORTREVISION= 1
+PORTVERSION= 1.51
CATEGORIES= games
MASTER_SITES= http://www.techfirm.co.jp/~masaoki/
MAINTAINER= ports@FreeBSD.org
COMMENT= Shisen-sho puzzle game for X11
-BUILD_DEPENDS= nkf:${PORTSDIR}/japanese/nkf
-
-# runs fine on ssh connection
-#IS_INTERACTIVE= YES # Has to create an app-defaults file
USE_X_PREFIX= yes
USE_XPM= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --datadir="${X11BASE}/lib/X11" \
- --enable-japanese=euc #Japanese char set euc, jis sjis
-
-.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= --sharedstatedir="${DATADIR}"
+INSTALL_TARGET= install-prog
MANLANG= "" ja
MAN6= xshisen.6
+.if !defined(WITHOUT_MOTIF)
+USE_MOTIF= yes
+CONFIGURE_ARGS+= --with-motif
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|XSHISEN_VERSION|${PORTVERSION}|g' ${WRKSRC}/lang/XShisen.ad*
+
post-install:
@${CHOWN} root:games ${PREFIX}/bin/xshisen
@${CHMOD} 2555 ${PREFIX}/bin/xshisen
- @${CHOWN} root:games ${PREFIX}/lib/X11/xshisen/xshisen-scores
- @${CHMOD} 0660 ${PREFIX}/lib/X11/xshisen/xshisen-scores
- ${INSTALL_MAN} ${WRKSRC}/xshisen.man ${PREFIX}/man/man6/xshisen.6
- @nkf -e < ${WRKSRC}/xshisen.jman-jis \
- > ${WRKSRC}/xshisen.jman
- ${INSTALL_MAN} ${WRKSRC}/xshisen.jman ${PREFIX}/man/ja/man6/xshisen.6
- -test -d ${PREFIX}/lib/X11/ja_JP.EUC/ -a \
+ @${CHOWN} root:games ${DATADIR}/xshisen.scores
+ @${CHMOD} 0660 ${DATADIR}/xshisen.scores
+ ${INSTALL_MAN} ${WRKSRC}/man/xshisen.6 \
+ ${MAN6PREFIX}/man/man6/xshisen.6
+ ${INSTALL_MAN} ${WRKSRC}/man/xshisen.6.ja_JP.eucJP \
+ ${MAN6PREFIX}/man/ja/man6/xshisen.6
+ @${MKDIR} ${PREFIX}/lib/X11/app-defaults
+ ${INSTALL_DATA} ${WRKSRC}/lang/XShisen.ad \
+ ${PREFIX}/lib/X11/app-defaults/XShisen
+ @${MKDIR} ${PREFIX}/lib/X11/ja_JP.eucJP/app-defaults
+ ${INSTALL_DATA} ${WRKSRC}/lang/XShisen.ad.ja_JP.eucJP \
+ ${PREFIX}/lib/X11/ja_JP.eucJP/app-defaults/XShisen
+ -${TEST} -d ${PREFIX}/lib/X11/ja_JP.EUC/ -a \
-d ${PREFIX}/lib/X11/ja_JP.EUC/app-defaults && \
${LN} -s ${PREFIX}/lib/X11/ja_JP.eucJP/app-defaults/XShisen \
- ${PREFIX}/lib/X11/ja_JP.EUC/app-defaults && \
+ ${PREFIX}/lib/X11/ja_JP.EUC/app-defaults || ${TRUE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xshisen/distinfo b/games/xshisen/distinfo
index aa81f2136be3..9e5131df73e2 100644
--- a/games/xshisen/distinfo
+++ b/games/xshisen/distinfo
@@ -1,2 +1,2 @@
-MD5 (xshisen-1.36.tar.gz) = 3c3904ff99075012201a2f6a8d6a5beb
-SIZE (xshisen-1.36.tar.gz) = 62768
+MD5 (xshisen-1.51.tar.gz) = 5f0ef1d7811401876de717fd6771fe47
+SIZE (xshisen-1.51.tar.gz) = 85350
diff --git a/games/xshisen/files/patch-aa b/games/xshisen/files/patch-aa
deleted file mode 100644
index d3ed5829c04a..000000000000
--- a/games/xshisen/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue Feb 27 21:29:29 1996
-+++ configure Sun Oct 10 17:49:35 1999
-@@ -1593,7 +1593,7 @@
- CPPFLAGS="${CPPFLAGS} -DLIB_DIR=\\\"\$(XSHISENLIB)\\\""
-
- for i in ${mandir} /usr/share/man /usr/man /usr/local/man; do
-- for j in japanese japan ja ja_JP ja_JP.eucJP ja_JP.SJIS; do
-+ for j in a_JP.EUC ja_JP.SJIS ja_JP.JIS7; do
- if [ -d "$i/$j" ]; then
- JAPANESE="$j"
- break 2;
diff --git a/games/xshisen/files/patch-ac b/games/xshisen/files/patch-ac
deleted file mode 100644
index 35bc8ad44e80..000000000000
--- a/games/xshisen/files/patch-ac
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.in.orig Tue Jan 23 17:35:21 1996
-+++ Makefile.in Sat Nov 9 17:18:47 2002
-@@ -39,7 +39,7 @@
- SCF = xshisen-scores
-
- LIBS = @LIBS@
--CODECONV = ./$(exec_name) -KCONV jis
-+CODECONV = (nkf -e | sed 's/XSHISEN_VERSION/1.36/')
-
- all: $(PROGS)
-
-@@ -64,6 +64,9 @@
- $(INSTALLD) $$file $(XSHISENLIB)/`basename $$file`; \
- done
- $(INSTALLD) $(AD) $(XAD_DIR)/$(class_name)
-+ @if [ ! -f $(JXAD_DIR) ]; then \
-+ $(MKDIR) $(JXAD_DIR); \
-+ fi
- $(INSTALLD) $(ADJ) $(JXAD_DIR)/$(class_name)
-
- install.man: $(exec_name).jman $(exec_name).man
diff --git a/games/xshisen/files/patch-ad b/games/xshisen/files/patch-ad
deleted file mode 100644
index c7d1cbea043c..000000000000
--- a/games/xshisen/files/patch-ad
+++ /dev/null
@@ -1,95 +0,0 @@
-
-$FreeBSD$
-
---- main.C.orig
-+++ main.C
-@@ -44,53 +44,53 @@
-
- static XtResource gres[] = {
- { "aboutString", "AboutString", XtRString, sizeof (char *),
-- 0, XtRString, "XShisen " XSHISEN_VERSION " by Masaoki Kobayashi" },
-+ 0, XtRString, (XtPointer)"XShisen " XSHISEN_VERSION " by Masaoki Kobayashi" },
- { "tedumari", "Tedumari", XtRString, sizeof (char *),
-- offsetof(GlobRes, tedumari), XtRString, "You can get no more pieces." },
-+ offsetof(GlobRes, tedumari), XtRString, (XtPointer)"You can get no more pieces." },
- { "width", "Width", XtRInt, sizeof (int),
-- offsetof(GlobRes, Width), XtRString, "640" },
-+ offsetof(GlobRes, Width), XtRString, (XtPointer)"640" },
- { "height", "Height", XtRInt, sizeof (int),
-- offsetof(GlobRes, Height), XtRString, "400" },
-+ offsetof(GlobRes, Height), XtRString, (XtPointer)"400" },
- { "timeFormat", "TimeFormat", XtRString, sizeof (char *),
-- offsetof(GlobRes, timeFormat), XtRString, "Your time is %2.2d:%2.2d." },
-+ offsetof(GlobRes, timeFormat), XtRString, (XtPointer)"Your time is %2.2d:%2.2d." },
- { "displayFormat1", "DisplayFormat1", XtRString, sizeof (char *),
-- offsetof(GlobRes, displayFormat1), XtRString, "Rest: " },
-+ offsetof(GlobRes, displayFormat1), XtRString, (XtPointer)"Rest: " },
- { "displayFormat2", "DisplayFormat2", XtRString, sizeof (char *),
-- offsetof(GlobRes, displayFormat2), XtRString, "Time: " },
-+ offsetof(GlobRes, displayFormat2), XtRString, (XtPointer)"Time: " },
- { "scoreFile", "ScoreFile", XtRString, sizeof (char *),
-- offsetof(GlobRes, scoreFile), XtRString, "%s/xshisen-scores" },
-+ offsetof(GlobRes, scoreFile), XtRString, (XtPointer)"%s/xshisen-scores" },
- { "personalScore", "PersonalScore", XtRString, sizeof (char *),
-- offsetof(GlobRes, personalScoreFile), XtRString, ".xshisen-scores" },
-+ offsetof(GlobRes, personalScoreFile), XtRString, (XtPointer)".xshisen-scores" },
- { "scoreOnly", "ScoreOnly", XtRBoolean, sizeof (Boolean),
-- offsetof(GlobRes, scoreOnly), XtRString, "False" },
-+ offsetof(GlobRes, scoreOnly), XtRString, (XtPointer)"False" },
- { "connectLineColor", "ConnectLineColor", XtRPixel, sizeof (Pixel),
-- offsetof(GlobRes, connLineColor), XtRString, "blue" },
-+ offsetof(GlobRes, connLineColor), XtRString, (XtPointer)"blue" },
- { "connectLineTime", "ConnectLineTime", XtRInt, sizeof (int),
-- offsetof(GlobRes, connLineTime), XtRString, "1000" },
-+ offsetof(GlobRes, connLineTime), XtRString, (XtPointer)"1000" },
- { "connectLineWidth", "ConnectLineWidth", XtRInt, sizeof (int),
-- offsetof(GlobRes, connLineWidth), XtRString, "6" },
-+ offsetof(GlobRes, connLineWidth), XtRString, (XtPointer)"6" },
- { "autoDemo", "AutoDemo", XtRBoolean, sizeof (Boolean),
-- offsetof(GlobRes, autoDemo), XtRString, "False" },
-+ offsetof(GlobRes, autoDemo), XtRString, (XtPointer)"False" },
- { "libraryDirectory", "LibraryDirectory", XtRString, sizeof (char *),
-- offsetof(GlobRes, libDir), XtRString, LIB_DIR },
-+ offsetof(GlobRes, libDir), XtRString, (XtPointer)LIB_DIR },
- { "magnifyFactor", "MagnifyFactor", XtRFloat, sizeof (float),
-- offsetof(GlobRes, magFactor), XtRString, "1.0" },
-+ offsetof(GlobRes, magFactor), XtRString, (XtPointer)"1.0" },
- { "fitPixmap", "FitPixmap", XtRBoolean, sizeof (Boolean),
-- offsetof(GlobRes, fitPixmap), XtRString, "True" },
-+ offsetof(GlobRes, fitPixmap), XtRString, (XtPointer)"True" },
- { "colorCloseness", "ColorCloseness", XtRInt, sizeof (int),
-- offsetof(GlobRes, colorCloseness), XtRString, "40000" },
-+ offsetof(GlobRes, colorCloseness), XtRString, (XtPointer)"40000" },
- { "gameSize", "GameSize", XtRInt, sizeof (int),
-- offsetof(GlobRes, gameSize), XtRString, "0" },
-+ offsetof(GlobRes, gameSize), XtRString, (XtPointer)"0" },
- { "trialMode", "TrialMode", XtRBoolean, sizeof (Boolean),
-- offsetof(GlobRes, trialMode), XtRString, "False" },
-+ offsetof(GlobRes, trialMode), XtRString, (XtPointer)"False" },
- { "gravityMode", "GravityMode", XtRBoolean, sizeof (Boolean),
-- offsetof(GlobRes, gravityMode), XtRString, "False" },
-+ offsetof(GlobRes, gravityMode), XtRString, (XtPointer)"False" },
- { "idleTime", "IdleTime", XtRInt, sizeof (int),
-- offsetof(GlobRes, idleTime), XtRString, "100000" },
-+ offsetof(GlobRes, idleTime), XtRString, (XtPointer)"100000" },
- { "kanjiCode", "KanjiCode", XtRString, sizeof (char *),
-- offsetof(GlobRes, kanjiCode), XtRString, KANJICODE },
-+ offsetof(GlobRes, kanjiCode), XtRString, (XtPointer)KANJICODE },
- { "kanjiConvert", "KanjiConvert", XtRBoolean, sizeof (Boolean),
-- offsetof(GlobRes, kanjiConv), XtRString, "False" }
-+ offsetof(GlobRes, kanjiConv), XtRString, (XtPointer)"False" }
- };
- GlobRes globRes;
-
-@@ -194,9 +194,9 @@
- char buffer[100], *p;
- char *(*codeconv)(const char*);
-
-- strcpy(buffer, operation);
-+ strlcpy(buffer, operation, sizeof(buffer));
- if (strchr(buffer, '-') == NULL) {
-- strcat(buffer, "-" KANJICODE);
-+ strlcat(buffer, "-" KANJICODE, sizeof(buffer));
- }
- if (strncasecmp(buffer, "jis-euc", 7) == 0)
- codeconv = jis_to_euc;
diff --git a/games/xshisen/files/patch-ae b/games/xshisen/files/patch-ae
deleted file mode 100644
index d8ad11132833..000000000000
--- a/games/xshisen/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- body.C.orig Sun Dec 12 14:40:15 1999
-+++ body.C Sun Dec 12 14:40:55 1999
-@@ -224,7 +224,7 @@
- int max_c;
-
- max_c = xsize*ysize*(xsize*ysize/PKIND - 1)/2;
-- p = new (Point [max_c][2]);
-+ p = new Point[max_c][2];
- t = new Point[xsize*ysize/PKIND];
-
- if (hintNum == 0)
diff --git a/games/xshisen/files/patch-af b/games/xshisen/files/patch-af
deleted file mode 100644
index 5b4a63af10c3..000000000000
--- a/games/xshisen/files/patch-af
+++ /dev/null
@@ -1,159 +0,0 @@
-
-$FreeBSD$
-
---- score.C.orig
-+++ score.C
-@@ -4,31 +4,31 @@
-
- XtResource Score::resources[] = {
- { "scoreTitle", "ScoreTitle", XtRString, sizeof(char *),
-- 0*sizeof(char *), XtRString, "XShisen High Score\n\n" },
-+ 0*sizeof(char *), XtRString, (XtPointer)"XShisen High Score\n\n" },
- { "scoreFormat", "ScoreFormat", XtRString, sizeof(char *),
-- 1*sizeof(char *), XtRString, "%2d %2.2d:%2.2d:%2.2d %-28s %s %s\n" },
-+ 1*sizeof(char *), XtRString, (XtPointer)"%2d %2.2d:%2.2d:%2.2d %-28s %s %s\n" },
- { "strPeriod", "StrPeriod", XtRString, sizeof(char *),
-- 2*sizeof(char *), XtRString, "Last %d days" },
-+ 2*sizeof(char *), XtRString, (XtPointer)"Last %d days" },
- { "averagePeriod", "AveragePeriod", XtRString, sizeof(char *),
-- 3*sizeof(char *), XtRString, "14" },
-+ 3*sizeof(char *), XtRString, (XtPointer)"14" },
- { "strPlayed", "StrPlayed", XtRString, sizeof(char *),
-- 4*sizeof(char *), XtRString, "Played" },
-+ 4*sizeof(char *), XtRString, (XtPointer)"Played" },
- { "strCompleted", "StrCompleted", XtRString, sizeof(char *),
-- 5*sizeof(char *), XtRString, "Completed" },
-+ 5*sizeof(char *), XtRString, (XtPointer)"Completed" },
- { "strTedumari", "StrTedumari", XtRString, sizeof(char *),
-- 6*sizeof(char *), XtRString, "Deadlocked" },
-+ 6*sizeof(char *), XtRString, (XtPointer)"Deadlocked" },
- { "strSearched", "StrSearched", XtRString, sizeof(char *),
-- 7*sizeof(char *), XtRString, "Seach used" },
-+ 7*sizeof(char *), XtRString, (XtPointer)"Search used" },
- { "strGiveUp", "StrGiveUp", XtRString, sizeof(char *),
-- 8*sizeof(char *), XtRString, "Gaven up" },
-+ 8*sizeof(char *), XtRString, (XtPointer)"Given up" },
- { "strTotal", "StrTotal", XtRString, sizeof(char *),
-- 9*sizeof(char *), XtRString, "Total" },
-+ 9*sizeof(char *), XtRString, (XtPointer)"Total" },
- { "strAverage", "StrAverage", XtRString, sizeof(char *),
-- 10*sizeof(char *), XtRString, "Whole Average" },
-+ 10*sizeof(char *), XtRString, (XtPointer)"Whole Average" },
- { "strGames", "StrGames", XtRString, sizeof(char *),
-- 11*sizeof(char *), XtRString, "games" },
-+ 11*sizeof(char *), XtRString, (XtPointer)"games" },
- { "personalTitle", "PersonalTitle", XtRString, sizeof(char *),
-- 12*sizeof(char *), XtRString, "Personal Statistics for %s" }
-+ 12*sizeof(char *), XtRString, (XtPointer)"Personal Statistics for %s" }
- };
-
- void
-@@ -73,6 +73,12 @@
- date[8] = '\0';
- strncpy(time, &buffer[53], 8);
- time[8] = '\0';
-+ if (date[0] == '1') {
-+ for(int i=1; i<8; i++) {
-+ date[i-1] = date[i];
-+ }
-+ date[7] = date[6] == '0' ? '1' : '0';
-+ }
- }
-
- void
-@@ -371,10 +377,10 @@
- s1 = scoreToRegister / 1000;
- ms_to_hms(scoreToRegister, h, m, s);
- pw = getpwuid(getuid());
-- strcpy(gecos, pw->pw_gecos);
-+ strlcpy(gecos, pw->pw_gecos, sizeof(gecos));
- if ((po = strchr(gecos, ',')) != NULL)
- *po = 0;
-- sprintf(namebuf, "%-8.8s (%s)", pw->pw_name, gecos);
-+ snprintf(namebuf, sizeof(namebuf), "%-8.8s (%s)", pw->pw_name, gecos);
- sprintf(myname, "%-28.28s", namebuf);
- // Always read the latest high score
- readfile();
-@@ -414,7 +420,7 @@
- strcpy(rec[inspos].name, myname);
- time(&t);
- tp = localtime(&t);
-- sprintf(rec[i].date, "%2.2d-%2.2d-%2.2d", tp->tm_year, tp->tm_mon+1, tp->tm_mday);
-+ sprintf(rec[i].date, "%2.2d-%2.2d-%2.2d", tp->tm_year%100, tp->tm_mon+1, tp->tm_mday);
- sprintf(rec[i].time, "%2.2d:%2.2d:%2.2d", tp->tm_hour, tp->tm_min, tp->tm_sec);
- if (writefile() == 0)
- DisplayScore(game);
-@@ -434,12 +440,12 @@
- return; /* Just do not record, no notifying */
- time(&t);
- tp = localtime(&t);
-- check_digit = flag*3 + gamesize + level*7 + tp->tm_year*3 + rest*7
-+ check_digit = flag*3 + gamesize + level*7 + (tp->tm_year%100)*3 + rest*7
- + tp->tm_mon*7 + tp->tm_mday*3 + tp->tm_hour*7 + tp->tm_min*3 + tp->tm_sec;
- check_digit %= 857;
- fprintf(stream, "%2.2d%2.2d%8.8d%2.2d%1.1d%2.2d%4.4d%2.2d%3.3d%3.3d%2.2d%2.2d\n",
- flag,
-- tp->tm_sec, result, tp->tm_min, gamesize, tp->tm_year, level, tp->tm_mon,
-+ tp->tm_sec, result, tp->tm_min, gamesize, tp->tm_year%100, level, tp->tm_mon,
- check_digit, rest, tp->tm_mday, tp->tm_hour);
- fclose(stream);
- }
-@@ -492,7 +498,24 @@
- rest = -1;
- c2 = f*3 + g + l*7 + year*3 + month*7 + day*3 + hour*7 + min*3 + sec;
- break;
-- case 34:
-+ case 32:
-+ // Just for compatibility with xshisen 1.10, Y2K
-+ f = atoiSubstring(buf + 0, 2);
-+ sec = atoiSubstring(buf + 2, 2);
-+ t = atoiSubstring(buf + 4, 8);
-+ min = atoiSubstring(buf + 12, 2);
-+ g = atoiSubstring(buf + 14, 1);
-+ year = atoiSubstring(buf + 15, 3) - 100;
-+ l = atoiSubstring(buf + 18, 4);
-+ month = atoiSubstring(buf + 22, 2);
-+ c1 = atoiSubstring(buf + 24, 3);
-+ day = atoiSubstring(buf + 27, 2);
-+ hour = atoiSubstring(buf + 29, 2);
-+ rest = -1;
-+ c2 = f*3 + g + l*7 + (year+100)*3 + month*7 + day*3 + hour*7 + min*3 + sec
-+;
-+ break;
-+ case 34:
- // This is usual format
- f = atoiSubstring(buf + 0, 2);
- sec = atoiSubstring(buf + 2, 2);
-@@ -509,6 +532,23 @@
- c2 = f*3 + g + l*7 + year*3 + month*7 + day*3 + hour*7 + min*3
- + sec + rest*7;
- break;
-+ case 35:
-+ // This is usual format, Y2K
-+ f = atoiSubstring(buf + 0, 2);
-+ sec = atoiSubstring(buf + 2, 2);
-+ t = atoiSubstring(buf + 4, 8);
-+ min = atoiSubstring(buf + 12, 2);
-+ g = atoiSubstring(buf + 14, 1);
-+ year = atoiSubstring(buf + 15, 3) - 100;
-+ l = atoiSubstring(buf + 18, 4);
-+ month = atoiSubstring(buf + 22, 2);
-+ c1 = atoiSubstring(buf + 24, 3);
-+ rest = atoiSubstring(buf + 27, 3);
-+ day = atoiSubstring(buf + 30, 2);
-+ hour = atoiSubstring(buf + 32, 2);
-+ c2 = f*3 + g + l*7 + (year+100)*3 + month*7 + day*3 + hour*7 + min*3
-+ + sec + rest*7;
-+ break;
- default:
- // Someone edited this file?
- continue;
-@@ -537,7 +577,7 @@
- tb.tm_hour = hour;
- tb.tm_mday = day;
- tb.tm_mon = month;
-- tb.tm_year = year;
-+ tb.tm_year = year > 69 ? year : year + 100;
- tm1 = mktime(&tb); // Time of the score
- w1[0][f] += t;
- w2[0][f]++;
diff --git a/games/xshisen/files/patch-readxpm.C b/games/xshisen/files/patch-readxpm.C
index 44bb429475d5..d1ac1540fe1b 100644
--- a/games/xshisen/files/patch-readxpm.C
+++ b/games/xshisen/files/patch-readxpm.C
@@ -1,14 +1,14 @@
$FreeBSD$
---- readxpm.C.orig
-+++ readxpm.C
+--- readxpm.C.orig Sun Jul 7 01:34:47 2002
++++ readxpm.C Thu Sep 15 13:56:38 2005
@@ -12,7 +12,7 @@
char buffer[1024];
for(int i=0; i<PKIND; i++) {
-- sprintf(buffer, "%s/%s.xpm", directory, files[i]);
-+ snprintf(buffer, sizeof(buffer), "%s/%s.xpm", directory, files[i]);
+- sprintf(buffer, "%s/%s/%s.xpm", directory, subdir, files[i]);
++ snprintf(buffer, sizeof(buffer), "%s/%s/%s.xpm", directory, subdir, files[i]);
Mp[i].ReadFile(w, buffer, i, globRes.colorCloseness);
}
}
diff --git a/games/xshisen/pkg-plist b/games/xshisen/pkg-plist
index f9c3c41b1905..87a5589e81a3 100644
--- a/games/xshisen/pkg-plist
+++ b/games/xshisen/pkg-plist
@@ -1,45 +1,83 @@
bin/xshisen
-lib/X11/xshisen/xshisen-scores
-lib/X11/xshisen/chun.xpm
-lib/X11/xshisen/haku.xpm
-lib/X11/xshisen/hana.xpm
-lib/X11/xshisen/hatsu.xpm
-lib/X11/xshisen/hishi.xpm
-lib/X11/xshisen/m1.xpm
-lib/X11/xshisen/m2.xpm
-lib/X11/xshisen/m3.xpm
-lib/X11/xshisen/m4.xpm
-lib/X11/xshisen/m5.xpm
-lib/X11/xshisen/m6.xpm
-lib/X11/xshisen/m7.xpm
-lib/X11/xshisen/m8.xpm
-lib/X11/xshisen/m9.xpm
-lib/X11/xshisen/nan.xpm
-lib/X11/xshisen/p1.xpm
-lib/X11/xshisen/p2.xpm
-lib/X11/xshisen/p3.xpm
-lib/X11/xshisen/p4.xpm
-lib/X11/xshisen/p5.xpm
-lib/X11/xshisen/p6.xpm
-lib/X11/xshisen/p7.xpm
-lib/X11/xshisen/p8.xpm
-lib/X11/xshisen/p9.xpm
-lib/X11/xshisen/pei.xpm
-lib/X11/xshisen/s1.xpm
-lib/X11/xshisen/s2.xpm
-lib/X11/xshisen/s3.xpm
-lib/X11/xshisen/s4.xpm
-lib/X11/xshisen/s5.xpm
-lib/X11/xshisen/s6.xpm
-lib/X11/xshisen/s7.xpm
-lib/X11/xshisen/s8.xpm
-lib/X11/xshisen/s9.xpm
-lib/X11/xshisen/sha.xpm
-lib/X11/xshisen/ton.xpm
lib/X11/app-defaults/XShisen
lib/X11/ja_JP.eucJP/app-defaults/XShisen
+%%DATADIR%%/s1/chun.xpm
+%%DATADIR%%/s1/haku.xpm
+%%DATADIR%%/s1/hana.xpm
+%%DATADIR%%/s1/hatsu.xpm
+%%DATADIR%%/s1/hishi.xpm
+%%DATADIR%%/s1/m1.xpm
+%%DATADIR%%/s1/m2.xpm
+%%DATADIR%%/s1/m3.xpm
+%%DATADIR%%/s1/m4.xpm
+%%DATADIR%%/s1/m5.xpm
+%%DATADIR%%/s1/m6.xpm
+%%DATADIR%%/s1/m7.xpm
+%%DATADIR%%/s1/m8.xpm
+%%DATADIR%%/s1/m9.xpm
+%%DATADIR%%/s1/nan.xpm
+%%DATADIR%%/s1/p1.xpm
+%%DATADIR%%/s1/p2.xpm
+%%DATADIR%%/s1/p3.xpm
+%%DATADIR%%/s1/p4.xpm
+%%DATADIR%%/s1/p5.xpm
+%%DATADIR%%/s1/p6.xpm
+%%DATADIR%%/s1/p7.xpm
+%%DATADIR%%/s1/p8.xpm
+%%DATADIR%%/s1/p9.xpm
+%%DATADIR%%/s1/pei.xpm
+%%DATADIR%%/s1/s1.xpm
+%%DATADIR%%/s1/s2.xpm
+%%DATADIR%%/s1/s3.xpm
+%%DATADIR%%/s1/s4.xpm
+%%DATADIR%%/s1/s5.xpm
+%%DATADIR%%/s1/s6.xpm
+%%DATADIR%%/s1/s7.xpm
+%%DATADIR%%/s1/s8.xpm
+%%DATADIR%%/s1/s9.xpm
+%%DATADIR%%/s1/sha.xpm
+%%DATADIR%%/s1/ton.xpm
+%%DATADIR%%/s2/chun.xpm
+%%DATADIR%%/s2/haku.xpm
+%%DATADIR%%/s2/hana.xpm
+%%DATADIR%%/s2/hatsu.xpm
+%%DATADIR%%/s2/hishi.xpm
+%%DATADIR%%/s2/m1.xpm
+%%DATADIR%%/s2/m2.xpm
+%%DATADIR%%/s2/m3.xpm
+%%DATADIR%%/s2/m4.xpm
+%%DATADIR%%/s2/m5.xpm
+%%DATADIR%%/s2/m6.xpm
+%%DATADIR%%/s2/m7.xpm
+%%DATADIR%%/s2/m8.xpm
+%%DATADIR%%/s2/m9.xpm
+%%DATADIR%%/s2/nan.xpm
+%%DATADIR%%/s2/p1.xpm
+%%DATADIR%%/s2/p2.xpm
+%%DATADIR%%/s2/p3.xpm
+%%DATADIR%%/s2/p4.xpm
+%%DATADIR%%/s2/p5.xpm
+%%DATADIR%%/s2/p6.xpm
+%%DATADIR%%/s2/p7.xpm
+%%DATADIR%%/s2/p8.xpm
+%%DATADIR%%/s2/p9.xpm
+%%DATADIR%%/s2/pei.xpm
+%%DATADIR%%/s2/s1.xpm
+%%DATADIR%%/s2/s2.xpm
+%%DATADIR%%/s2/s3.xpm
+%%DATADIR%%/s2/s4.xpm
+%%DATADIR%%/s2/s5.xpm
+%%DATADIR%%/s2/s6.xpm
+%%DATADIR%%/s2/s7.xpm
+%%DATADIR%%/s2/s8.xpm
+%%DATADIR%%/s2/s9.xpm
+%%DATADIR%%/s2/sha.xpm
+%%DATADIR%%/s2/ton.xpm
+%%DATADIR%%/xshisen.scores
+@dirrm %%DATADIR%%/s2
+@dirrm %%DATADIR%%/s1
+@dirrm %%DATADIR%%
@unexec rmdir %D/lib/X11/ja_JP.eucJP/app-defaults 2>/dev/null || true
@unexec rmdir %D/lib/X11/ja_JP.eucJP 2>/dev/null || true
-@dirrm lib/X11/xshisen
@exec [ -d %D/lib/X11/ja_JP.EUC/ -a -d %D/lib/X11/ja_JP.EUC/app-defaults ] && ln -s %D/lib/X11/ja_JP.eucJP/app-defaults/XShisen %D/lib/X11/ja_JP.EUC/app-defaults || true
@unexec rm %D/lib/X11/ja_JP.EUC/app-defaults/XShisen 2>/dev/null || true