aboutsummaryrefslogtreecommitdiff
path: root/games/xshogi
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-01-03 09:27:10 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-01-03 09:27:10 +0000
commit375eda1c7726bed5eeaa6d0f98dce4a2d3259a00 (patch)
treeddaa4281ab30ab9b96a2af86454e3f09f5d6b5ff /games/xshogi
parent0ec8f04dcf4463720aed99319bca519cdbbb8854 (diff)
downloadports-375eda1c7726bed5eeaa6d0f98dce4a2d3259a00.tar.gz
ports-375eda1c7726bed5eeaa6d0f98dce4a2d3259a00.zip
Have manpage go into man6 as the manpage says.
Remove hardcodings of /usr/local and /usr/X11R6
Notes
Notes: svn path=/head/; revision=5185
Diffstat (limited to 'games/xshogi')
-rw-r--r--games/xshogi/Makefile12
-rw-r--r--games/xshogi/files/patch-aa126
-rw-r--r--games/xshogi/pkg-plist2
3 files changed, 56 insertions, 84 deletions
diff --git a/games/xshogi/Makefile b/games/xshogi/Makefile
index 89f1e2b88b19..6fb70c045187 100644
--- a/games/xshogi/Makefile
+++ b/games/xshogi/Makefile
@@ -3,7 +3,7 @@
# Date created: 20 October 1996
# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1996/11/17 11:53:34 asami Exp $
#
DISTNAME= xshogi-1.2p03
@@ -17,12 +17,16 @@ RUN_DEPENDS= ${LOCALBASE}/libexec/gnushogix:${PORTSDIR}/games/gnushogi
USE_X11= yes
MAKEFILE= Makefile.custom
-MAN1= xshogi.1
+MAN6= xshogi.6
+
+post-configure:
+ @echo "DISTDIR=${WRKDIR}" >> ${WRKSRC}/${MAKEFILE}
+ @echo "LOCALBASE=${LOCALBASE}" >> ${WRKSRC}/${MAKEFILE}
post-install:
@strip ${PREFIX}/bin/xshogi
@chmod 755 ${PREFIX}/bin/xshogi
- @chown bin.bin ${PREFIX}/bin/xshogi
- ${INSTALL_MAN} ${WRKSRC}/xshogi.man ${PREFIX}/man/man1/xshogi.1
+ @/usr/sbin/chown ${BINOWN}.${BINGRP} ${PREFIX}/bin/xshogi
+ ${INSTALL_MAN} ${WRKSRC}/xshogi.man ${PREFIX}/man/man6/xshogi.6
.include <bsd.port.mk>
diff --git a/games/xshogi/files/patch-aa b/games/xshogi/files/patch-aa
index d0316e6fbb4e..2d4445f3eac6 100644
--- a/games/xshogi/files/patch-aa
+++ b/games/xshogi/files/patch-aa
@@ -1,79 +1,47 @@
-*** Makefile.custom.orig Wed May 24 14:12:05 1995
---- Makefile.custom Fri Oct 25 06:38:10 1996
-***************
-*** 28,45 ****
- VERS = 1.2p03
-
- # Installation directory
-! prefix=/usr/local
- #prefix=/public/projects/shogi
-
- # Change these to something less transitory, like /usr/games, and then
- # compile.
- # Where the binaries live (especially gnushogix).
-! BINDIR= $(prefix)/games
- #BINDIR=/public/projects/shogi/bin
-
--
- # Distribution directory
-! DISTDIR=/public/projects/shogi
-
- # Compress program
- COMPRESS = gzip
---- 28,44 ----
- VERS = 1.2p03
-
- # Installation directory
-! prefix=/usr/X11R6
- #prefix=/public/projects/shogi
-
- # Change these to something less transitory, like /usr/games, and then
- # compile.
- # Where the binaries live (especially gnushogix).
-! BINDIR= $(prefix)/bin
- #BINDIR=/public/projects/shogi/bin
-
- # Distribution directory
-! DISTDIR=/usr/ports/games/xshogi/work
-
- # Compress program
- COMPRESS = gzip
-***************
-*** 73,80 ****
- #CCOPTIONS= -g
- #LDOPTIONS= -lXaw -lXmu -lXt -lXext -lX11
- # This is for cc on SunOS with debug
-! CCOPTIONS= -g -I/usr/include
-! LDOPTIONS= -L/usr/lib -lXaw -lXmu -lXt -lXext -lX11
-
- # Options for xshogi
- # Use -DSENDTIME with at least gnushogix 1.2 patchlevel 3
---- 72,80 ----
- #CCOPTIONS= -g
- #LDOPTIONS= -lXaw -lXmu -lXt -lXext -lX11
- # This is for cc on SunOS with debug
-! CCOPTIONS= -g -O2 -m486 -pipe -fno-strength-reduce \
-! -I/usr/include -I/usr/X11R6/include
-! LDOPTIONS= -L/usr/lib -L/usr/X11R6/lib -lXaw -lXmu -lXt -lXext -lX11
-
- # Options for xshogi
- # Use -DSENDTIME with at least gnushogix 1.2 patchlevel 3
-***************
-*** 88,95 ****
- # The option -DISS compiles xshogi for supporting the Internet Shogi Server.
- OPT = -DHAS_GETTIMEOFDAY -DSENDTIME -DISS -DTOP_PART_BITMAPS # -DBOTH_BITMAPS -DWESTERN_BITMAPS
-
-! FIRST_PROGRAM = -DFIRST_CHESS_PROGRAM=\"$(BINDIR)/gnushogix\"
-! SECOND_PROGRAM = -DSECOND_CHESS_PROGRAM=\"$(BINDIR)/gnushogix\"
- FIRST_HOST = -DFIRST_HOST=\"localhost\"
- SECOND_HOST = -DSECOND_HOST=\"localhost\"
-
---- 88,95 ----
- # The option -DISS compiles xshogi for supporting the Internet Shogi Server.
- OPT = -DHAS_GETTIMEOFDAY -DSENDTIME -DISS -DTOP_PART_BITMAPS # -DBOTH_BITMAPS -DWESTERN_BITMAPS
-
-! FIRST_PROGRAM = -DFIRST_CHESS_PROGRAM=\"/usr/local/libexec/gnushogix\"
-! SECOND_PROGRAM = -DSECOND_CHESS_PROGRAM=\"/usr/local/libexec/gnushogix\"
- FIRST_HOST = -DFIRST_HOST=\"localhost\"
- SECOND_HOST = -DSECOND_HOST=\"localhost\"
-
+--- Makefile.custom.orig Wed May 24 07:12:05 1995
++++ Makefile.custom Fri Jan 3 00:46:15 1997
+@@ -28,18 +28,18 @@
+ VERS = 1.2p03
+
+ # Installation directory
+-prefix=/usr/local
++prefix=$(PREFIX)
+ #prefix=/public/projects/shogi
+
+ # Change these to something less transitory, like /usr/games, and then
+ # compile.
+ # Where the binaries live (especially gnushogix).
+-BINDIR= $(prefix)/games
++BINDIR= $(prefix)/bin
+ #BINDIR=/public/projects/shogi/bin
+
+
+ # Distribution directory
+-DISTDIR=/public/projects/shogi
++#DISTDIR=/public/projects/shogi
+
+ # Compress program
+ COMPRESS = gzip
+@@ -73,8 +73,9 @@
+ #CCOPTIONS= -g
+ #LDOPTIONS= -lXaw -lXmu -lXt -lXext -lX11
+ # This is for cc on SunOS with debug
+-CCOPTIONS= -g -I/usr/include
+-LDOPTIONS= -L/usr/lib -lXaw -lXmu -lXt -lXext -lX11
++CCOPTIONS= -g -O2 -m486 -pipe -fno-strength-reduce \
++ -I/usr/include -I$(PREFIX)/include
++LDOPTIONS= -L/usr/lib -L$(PREFIX)/lib -lXaw -lXmu -lXt -lXext -lX11
+
+ # Options for xshogi
+ # Use -DSENDTIME with at least gnushogix 1.2 patchlevel 3
+@@ -88,8 +89,8 @@
+ # The option -DISS compiles xshogi for supporting the Internet Shogi Server.
+ OPT = -DHAS_GETTIMEOFDAY -DSENDTIME -DISS -DTOP_PART_BITMAPS # -DBOTH_BITMAPS -DWESTERN_BITMAPS
+
+-FIRST_PROGRAM = -DFIRST_CHESS_PROGRAM=\"$(BINDIR)/gnushogix\"
+-SECOND_PROGRAM = -DSECOND_CHESS_PROGRAM=\"$(BINDIR)/gnushogix\"
++FIRST_PROGRAM = -DFIRST_CHESS_PROGRAM=\"$(LOCALBASE)/libexec/gnushogix\"
++SECOND_PROGRAM = -DSECOND_CHESS_PROGRAM=\"$(LOCALBASE)/libexec/gnushogix\"
+ FIRST_HOST = -DFIRST_HOST=\"localhost\"
+ SECOND_HOST = -DSECOND_HOST=\"localhost\"
+
diff --git a/games/xshogi/pkg-plist b/games/xshogi/pkg-plist
index aefd66e72044..b1295daa2375 100644
--- a/games/xshogi/pkg-plist
+++ b/games/xshogi/pkg-plist
@@ -1,2 +1,2 @@
bin/xshogi
-man/man1/xshogi.1.gz
+man/man6/xshogi.6.gz