aboutsummaryrefslogtreecommitdiff
path: root/games/xtron
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2000-04-02 01:00:24 +0000
committerMichael Haro <mharo@FreeBSD.org>2000-04-02 01:00:24 +0000
commit4aed6f1e6536c2d3be11d0ac7596e10b27791cb5 (patch)
tree021f61372fc74d69c6dbb086d15d03b8a2cae67e /games/xtron
parent77140e508e938432f22e37e787489915e2d78661 (diff)
downloadports-4aed6f1e6536c2d3be11d0ac7596e10b27791cb5.tar.gz
ports-4aed6f1e6536c2d3be11d0ac7596e10b27791cb5.zip
***
games/affenspiel - Support CC properly *** games/battalion - Support PREFIX properly *** games/block - Support CC/CFLAGS properly *** games/blue - Support CC/CFLAGS properly - Add WWW: line into pkg/DESCR New file: patches/patch-aa *** games/bs - Add WWW: line into pkg/DESCR *** games/columns - Support CXXFLAGS properly - Support sdl-config *** games/empire - Exclude GPL doc from package - Add WWW: line into pkg/DESCR *** games/freesweep to 0.87 - Update to version 0.87 *** games/galaxis - Support CC properly - Add WWW: line into pkg/DESCR *** games/garith - Support CC/CFLAGS properly - Support GTK_CONFIG *** games/gemdropx to 0.7 - Update to version 0.7 *** games/gtkballs - Exclude GPL doc from package - Support GTK_CONFIG *** games/icbm3d - Update WWW: line of pkg/DESCR *** games/mirrormagic - Support CC/X11BASE properly *** games/phalanx to 22 - Update to version 22 - Add WWW: line into pkg/DESCR *** games/spellcast - Update MASTER_SITES and WWW: line of pkg/DESCR - Support CFLAGS properly - Exclude GPL doc from package *** games/starlanes - Support CC properly - Exclude GPL doc from package *** games/xdigger to 1.0.10 - Update to version 1.0.10 New file: patches/patch-ad patches/patch-ae *** games/xtron - Support PREFIX properly - Exclude GPL doc from package *** games/xtruco - Support CC/CFLAGS/X11BASE properly *** games/xvier - Support X11BASE properly *** PR: 17741 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=27261
Diffstat (limited to 'games/xtron')
-rw-r--r--games/xtron/Makefile34
-rw-r--r--games/xtron/files/patch-aa19
-rw-r--r--games/xtron/files/patch-ab12
-rw-r--r--games/xtron/files/patch-ac6
-rw-r--r--games/xtron/pkg-plist3
5 files changed, 40 insertions, 34 deletions
diff --git a/games/xtron/Makefile b/games/xtron/Makefile
index 447dfd1ae1c1..f5875cbfcdb8 100644
--- a/games/xtron/Makefile
+++ b/games/xtron/Makefile
@@ -6,30 +6,30 @@
# $FreeBSD$
#
-DISTNAME= xtron-1.1a
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+DISTNAME= xtron-1.1a
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/arcade
-EXTRACT_SUFX= .tgz
+EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
-USE_X_PREFIX= yes
+USE_X_PREFIX= yes
-do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/xtron ${PREFIX}/bin
- @ ${MKDIR} ${PREFIX}/share/xtron
- @ ${INSTALL_DATA} ${WRKSRC}/pixmaps/* ${PREFIX}/share/xtron
- @ ${INSTALL_DATA} ${WRKSRC}/xtronrc ${PREFIX}/lib/X11/app-defaults/Tron
- @ ${MKDIR} ${PREFIX}/share/doc/xtron
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/xtronrc
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xtron ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/xtron
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/* ${PREFIX}/share/xtron
+ ${INSTALL_DATA} ${WRKSRC}/xtronrc ${PREFIX}/lib/X11/app-defaults/Tron
.if !defined(NOPORTDOCS)
-post-install:
-.for file in CHANGES COPYING README
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/xtron
-.endfor
+ @${MKDIR} ${PREFIX}/share/doc/xtron
+ ${INSTALL_DATA} ${WRKSRC}/CHANGES ${PREFIX}/share/doc/xtron
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xtron
.endif
.include <bsd.port.mk>
diff --git a/games/xtron/files/patch-aa b/games/xtron/files/patch-aa
index 98a0da60f8b6..d86897fc09cd 100644
--- a/games/xtron/files/patch-aa
+++ b/games/xtron/files/patch-aa
@@ -1,13 +1,18 @@
---- Makefile Sun Apr 16 13:26:00 1995
-+++ /home/andy/tmp/wrk/Makefile Sun Mar 29 23:08:24 1998
-@@ -20,8 +20,8 @@
+--- Makefile.orig Sun Apr 16 22:26:00 1995
++++ Makefile Fri Mar 31 22:59:19 2000
+@@ -18,10 +18,11 @@
#
- CC= gcc
- CFLAGS= -O4 -Wall
+ # Last Modified: 16/4/95
+ #
+-CC= gcc
+-CFLAGS= -O4 -Wall
-INCLUDES= -I/usr/X386/include/X11 -I/usr/include
-LIBS= -L/usr/X386/lib
-+INCLUDES= -I/usr/X11R6/include -I/usr/X11R6/include/X11
-+LIBS= -L/usr/X11R6/lib
++CC?= gcc
++CFLAGS?= -O4 -Wall
++DEFINES= -DPREFIX=\"${PREFIX}\"
++INCLUDES= -I${X11BASE}/include -I${X11BASE}/include/X11
++LIBS= -L${X11BASE}/lib
LDLIBS= -lXpm -lX11
DEPEND= makedepend
OBJS= wintype.o xtron.o main.o xpm2pixmap.o resource.o
diff --git a/games/xtron/files/patch-ab b/games/xtron/files/patch-ab
index 8e1a62beba1a..ce4873e8b973 100644
--- a/games/xtron/files/patch-ab
+++ b/games/xtron/files/patch-ab
@@ -1,11 +1,13 @@
---- resource.c Sun Apr 23 22:39:03 1995
-+++ /home/andy/tmp/wrk/resource.c Sun Mar 29 23:05:40 1998
-@@ -101,7 +101,7 @@
+--- resource.c.orig Mon Apr 24 07:39:03 1995
++++ resource.c Fri Mar 31 23:09:37 2000
+@@ -101,8 +101,8 @@
if ((XTRONresources = XrmGetFileDatabase("./.xtronrc")) == NULL) {
if ((XTRONresources = XrmGetFileDatabase("$HOME/xtronrc")) == NULL) {
if ((XTRONresources = XrmGetFileDatabase("$HOME/.xtronrc")) == NULL) {
- if ((XTRONresources = XrmGetFileDatabase("/usr/X11/lib/X11/app-defaults/xtronrc")) == NULL) {
-+ if ((XTRONresources = XrmGetFileDatabase("/usr/X11R6/lib/X11/app-defaults/Tron")) == NULL) {
- if ((XTRONresources = XrmGetFileDatabase("/usr/X11/lib/X11/app-defaults/.xtronrc")) == NULL) {
+- if ((XTRONresources = XrmGetFileDatabase("/usr/X11/lib/X11/app-defaults/.xtronrc")) == NULL) {
++ if ((XTRONresources = XrmGetFileDatabase(PREFIX "/lib/X11/app-defaults/Tron")) == NULL) {
++ if ((XTRONresources = XrmGetFileDatabase(PREFIX "/share/xtron/xtronrc")) == NULL) {
fprintf(stderr,"error: unable to open/read resource file xtronrc\n");
return(0);
+ }
diff --git a/games/xtron/files/patch-ac b/games/xtron/files/patch-ac
index 90a09bf15c97..d188ebe12a0f 100644
--- a/games/xtron/files/patch-ac
+++ b/games/xtron/files/patch-ac
@@ -1,11 +1,11 @@
---- xtronrc Sun Apr 23 22:53:22 1995
-+++ /home/andy/tmp/wrk/xtronrc Sun Mar 29 23:27:25 1998
+--- xtronrc.orig Mon Apr 24 07:53:22 1995
++++ xtronrc Fri Mar 31 05:16:36 2000
@@ -3,7 +3,7 @@
# in the user's home directory or in /usr/X11/lib/X11/app-defaults.
# you can also rename it .xtronrc if you prefer it to be hidden
# make sure that the pixmaps directory has a trailing / at the end
-xtron.PixmapsDIR: ./pixmaps/
-+xtron.PixmapsDIR: /usr/X11R6/share/xtron/
++xtron.PixmapsDIR: %%PREFIX%%/share/xtron/
# change these key settings for player 1 [RED]
xtron.player1UP: w
diff --git a/games/xtron/pkg-plist b/games/xtron/pkg-plist
index 6524b8a2f179..dc2711997a11 100644
--- a/games/xtron/pkg-plist
+++ b/games/xtron/pkg-plist
@@ -1,7 +1,6 @@
bin/xtron
lib/X11/app-defaults/Tron
share/doc/xtron/CHANGES
-share/doc/xtron/COPYING
share/doc/xtron/README
share/xtron/Xtron_icon.xpm
share/xtron/again.xpm
@@ -20,5 +19,5 @@ share/xtron/quit.xpm
share/xtron/quitr.xpm
share/xtron/score.xpm
share/xtron/scorer.xpm
-@dirrm share/doc/xtron
@dirrm share/xtron
+@dirrm share/doc/xtron