aboutsummaryrefslogtreecommitdiff
path: root/games/zaz
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-26 00:00:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-26 00:00:14 +0000
commit87c54c1da8cf36cf5198a6758b58969174d8550f (patch)
treec0b668e0ce9919267db87ef24294d066eac76b83 /games/zaz
parent2ce3dd5783c6532a867f1cedd0ac4b3f204b0a6f (diff)
downloadports-87c54c1da8cf36cf5198a6758b58969174d8550f.tar.gz
ports-87c54c1da8cf36cf5198a6758b58969174d8550f.zip
Zaz ain't Z*** is a puzzle game where the player has to arrange
balls in triplets. WWW: http://sourceforge.net/projects/zaz/
Notes
Notes: svn path=/head/; revision=240328
Diffstat (limited to 'games/zaz')
-rw-r--r--games/zaz/Makefile39
-rw-r--r--games/zaz/distinfo3
-rw-r--r--games/zaz/files/patch-src-common.h17
-rw-r--r--games/zaz/pkg-descr4
-rw-r--r--games/zaz/pkg-plist70
5 files changed, 133 insertions, 0 deletions
diff --git a/games/zaz/Makefile b/games/zaz/Makefile
new file mode 100644
index 000000000000..fbdfd44aba6a
--- /dev/null
+++ b/games/zaz/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: zaz
+# Date created: 25 Aug 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zaz
+PORTVERSION= 0.2.8
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= A puzzle game where the player has to arrange balls in triplets
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
+ theora.0:${PORTSDIR}/multimedia/libtheora \
+ vorbis.4:${PORTSDIR}/audio/libvorbis \
+ ftgl.2:${PORTSDIR}/graphics/ftgl
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl image
+USE_GL= gl glu
+MAKE_JOBS_SAFE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^zazdocdir =/ s|$${prefix}/doc|$${prefix}/share/doc|' \
+ ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-zazdocDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/zaz/distinfo b/games/zaz/distinfo
new file mode 100644
index 000000000000..fc36b9ac1aab
--- /dev/null
+++ b/games/zaz/distinfo
@@ -0,0 +1,3 @@
+MD5 (zaz-0.2.8.tar.gz) = 7509cf2b777ffedf92e801c5d4c5fff0
+SHA256 (zaz-0.2.8.tar.gz) = a527a152145c27a5013e509c93c066e0d3d364829c2b4d5cc045d037f2f895dc
+SIZE (zaz-0.2.8.tar.gz) = 30865105
diff --git a/games/zaz/files/patch-src-common.h b/games/zaz/files/patch-src-common.h
new file mode 100644
index 000000000000..705620aeaf4e
--- /dev/null
+++ b/games/zaz/files/patch-src-common.h
@@ -0,0 +1,17 @@
+--- src/common.h.orig 2009-08-21 02:53:16.000000000 +0400
++++ src/common.h 2009-08-25 19:01:52.000000000 +0400
+@@ -26,11 +26,12 @@
+ #ifdef WIN32
+ #include <windows.h>
+ #include <direct.h>
+-typedef unsigned int uint;
+-typedef unsigned long ulong;
+ #pragma warning(disable:4996)
+ #endif
+
++typedef unsigned int uint;
++typedef unsigned long ulong;
++
+ #include <cmath>
+ #include <cstdio>
+ #include <cstdlib>
diff --git a/games/zaz/pkg-descr b/games/zaz/pkg-descr
new file mode 100644
index 000000000000..cd245dfdc12a
--- /dev/null
+++ b/games/zaz/pkg-descr
@@ -0,0 +1,4 @@
+Zaz ain't Z*** is a puzzle game where the player has to arrange
+balls in triplets.
+
+WWW: http://sourceforge.net/projects/zaz/
diff --git a/games/zaz/pkg-plist b/games/zaz/pkg-plist
new file mode 100644
index 000000000000..7fd5cecbdb08
--- /dev/null
+++ b/games/zaz/pkg-plist
@@ -0,0 +1,70 @@
+bin/zaz
+share/applications/zaz.desktop
+share/pixmaps/zaz.xpm
+%%DATADIR%%/FreeMonoBold.ttf
+%%DATADIR%%/FreeSans.ttf
+%%DATADIR%%/balls1.png
+%%DATADIR%%/balls2.png
+%%DATADIR%%/balls3.png
+%%DATADIR%%/balls4.png
+%%DATADIR%%/balls5.png
+%%DATADIR%%/balls6.png
+%%DATADIR%%/balls7.png
+%%DATADIR%%/balls8.png
+%%DATADIR%%/bonus.ogg
+%%DATADIR%%/bonus1.png
+%%DATADIR%%/bonus2.png
+%%DATADIR%%/bonus3.png
+%%DATADIR%%/bonus4.png
+%%DATADIR%%/bonus5.png
+%%DATADIR%%/combo.ogg
+%%DATADIR%%/eliminate.ogg
+%%DATADIR%%/explosion.png
+%%DATADIR%%/extraball.ogg
+%%DATADIR%%/extralife.ogg
+%%DATADIR%%/font1.ttf
+%%DATADIR%%/gpl3.png
+%%DATADIR%%/level1.lvl
+%%DATADIR%%/level1.png
+%%DATADIR%%/level10.lvl
+%%DATADIR%%/level10.png
+%%DATADIR%%/level10_thumb.png
+%%DATADIR%%/level1_thumb.png
+%%DATADIR%%/level2.lvl
+%%DATADIR%%/level2.png
+%%DATADIR%%/level2_thumb.png
+%%DATADIR%%/level3.lvl
+%%DATADIR%%/level3.png
+%%DATADIR%%/level3_thumb.png
+%%DATADIR%%/level4.lvl
+%%DATADIR%%/level4.png
+%%DATADIR%%/level4_thumb.png
+%%DATADIR%%/level5.lvl
+%%DATADIR%%/level5.png
+%%DATADIR%%/level5_thumb.png
+%%DATADIR%%/level6.lvl
+%%DATADIR%%/level6.png
+%%DATADIR%%/level6_thumb.png
+%%DATADIR%%/level7.lvl
+%%DATADIR%%/level7.png
+%%DATADIR%%/level7_thumb.png
+%%DATADIR%%/level8.lvl
+%%DATADIR%%/level8.png
+%%DATADIR%%/level8_thumb.png
+%%DATADIR%%/level9.lvl
+%%DATADIR%%/level9.png
+%%DATADIR%%/level9_thumb.png
+%%DATADIR%%/logo.png
+%%DATADIR%%/menu.lvl
+%%DATADIR%%/mus1.ogg
+%%DATADIR%%/mus2.ogg
+%%DATADIR%%/mus3.ogg
+%%DATADIR%%/mus4.ogg
+%%DATADIR%%/ouch.ogg
+%%DATADIR%%/player.png
+%%DATADIR%%/pull.ogg
+%%DATADIR%%/push.ogg
+%%DATADIR%%/roll.ogg
+%%DATADIR%%/timebonus.wav
+@dirrm %%DATADIR%%
+@dirrmtry share/applications