aboutsummaryrefslogtreecommitdiff
path: root/games/znibbles
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-09-15 18:10:26 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-09-15 18:10:26 +0000
commit4a30b77282e1bfbcac04d0b1421467cb2e62ee89 (patch)
tree1c50a20a5840378409e418e443123785f253a6b5 /games/znibbles
parentf113f11f458146aed3db371f2e91f3b9f114644e (diff)
downloadports-4a30b77282e1bfbcac04d0b1421467cb2e62ee89.tar.gz
ports-4a30b77282e1bfbcac04d0b1421467cb2e62ee89.zip
- Fix build on 64-bits platforms
- UNBREAK on amd64, GCC4.2 Approved by: portmgr (erwin)
Notes
Notes: svn path=/head/; revision=220384
Diffstat (limited to 'games/znibbles')
-rw-r--r--games/znibbles/Makefile8
-rw-r--r--games/znibbles/files/patch-src::GTK::Menus.C11
2 files changed, 12 insertions, 7 deletions
diff --git a/games/znibbles/Makefile b/games/znibbles/Makefile
index 348be34d86db..c9c9c70efa8b 100644
--- a/games/znibbles/Makefile
+++ b/games/znibbles/Makefile
@@ -22,10 +22,4 @@ CONFIGURE_ARGS= --without-motif \
MAN6= nibbles.6 znibbles.6 gznibbles.6 znibblesX.6
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042 && ${ARCH} == amd64
-BROKEN= does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/znibbles/files/patch-src::GTK::Menus.C b/games/znibbles/files/patch-src::GTK::Menus.C
new file mode 100644
index 000000000000..3ea74f6315f0
--- /dev/null
+++ b/games/znibbles/files/patch-src::GTK::Menus.C
@@ -0,0 +1,11 @@
+--- src/GTK/Menus.C.orig 2008-09-15 17:23:52.000000000 +0000
++++ src/GTK/Menus.C 2008-09-15 17:25:14.000000000 +0000
+@@ -61,7 +61,7 @@
+ // Obligatory basic callback
+ void Menus::menu_callback_static(gpointer data, gpointer action, GtkWidget *w) {
+
+- switch((gint) action) {
++ switch((gulong)action) {
+ case ItemFileOther:
+ Menus::_interface->activate_other_player();
+ gtk_widget_set_sensitive(w, FALSE);