aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-19 13:59:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-19 13:59:25 +0000
commitaab9b0ca570fb6fc9ab17d314fbcbc844186083b (patch)
tree0fe6fe3d22e51c56353cffa9376af9a7f16fcc8b /games
parentaabea6324763b04502f6b582c9ef34b21aa99af9 (diff)
downloadports-aab9b0ca570fb6fc9ab17d314fbcbc844186083b.tar.gz
ports-aab9b0ca570fb6fc9ab17d314fbcbc844186083b.zip
FlightGear Launch Control is a graphical frontend for running
FlightGear flight simulator, <http://www.flightgear.org/>. WWW: http://sourceforge.net/projects/fgrun/ PR: ports/128200 Submitted by: buganini at gmail.com
Notes
Notes: svn path=/head/; revision=221776
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/fgrun/Makefile29
-rw-r--r--games/fgrun/distinfo3
-rw-r--r--games/fgrun/files/patch-src-Makefile.in11
-rw-r--r--games/fgrun/files/patch-src-fgrun_pty.cxx12
-rw-r--r--games/fgrun/files/patch-src-run_posix.cxx11
-rw-r--r--games/fgrun/pkg-descr4
-rw-r--r--games/fgrun/pkg-plist19
8 files changed, 90 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 50be0ad51353..778e6c0c4450 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -223,6 +223,7 @@
SUBDIR += fargoal
SUBDIR += fgfs-base
SUBDIR += fgkicker
+ SUBDIR += fgrun
SUBDIR += fgsd
SUBDIR += fillets-ng
SUBDIR += filters
diff --git a/games/fgrun/Makefile b/games/fgrun/Makefile
new file mode 100644
index 000000000000..e2f905ae3c9d
--- /dev/null
+++ b/games/fgrun/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: fgrun
+# Date created: 18 Oct 2008
+# Whom: buganini@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= fgrun
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= buganini@gmail.com
+COMMENT= A graphical frontend to run FlightGear Flight Simulator
+
+BUILD_DEPENDS= fltk-threads>=1.1.0:${PORTSDIR}/x11-toolkits/fltk-threads \
+ plib>=1.8.4:${PORTSDIR}/x11-toolkits/plib \
+ SimGear>=0.3.10:${PORTSDIR}/devel/simgear
+RUN_DEPENDS= fltk-threads>=1.1.0:${PORTSDIR}/x11-toolkits/fltk-threads \
+ plib>=1.8.4:${PORTSDIR}/x11-toolkits/plib \
+ SimGear>=0.3.10:${PORTSDIR}/devel/simgear \
+ fgfs:${PORTSDIR}/games/flightgear
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GL= gl
+USE_GETTEXT= yes
+
+.include <bsd.port.mk>
diff --git a/games/fgrun/distinfo b/games/fgrun/distinfo
new file mode 100644
index 000000000000..b209746f3278
--- /dev/null
+++ b/games/fgrun/distinfo
@@ -0,0 +1,3 @@
+MD5 (fgrun-1.0.1.tar.gz) = 1e3fd8e99d2afed13ad152301345fd8f
+SHA256 (fgrun-1.0.1.tar.gz) = 6e0b55935699de5d8a6386a9f273a2640a04d3e2dce6774520c8e4bad3603303
+SIZE (fgrun-1.0.1.tar.gz) = 341124
diff --git a/games/fgrun/files/patch-src-Makefile.in b/games/fgrun/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..899b344d2177
--- /dev/null
+++ b/games/fgrun/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2008-10-18 17:55:34.000000000 +0800
++++ src/Makefile.in 2008-10-18 17:55:44.000000000 +0800
+@@ -127,7 +127,7 @@
+ LIBICONV = @LIBICONV@
+ LIBINTL = @LIBINTL@
+ LIBOBJS = @LIBOBJS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ -lintl -lfltk
+ LN_S = @LN_S@
+ LTLIBICONV = @LTLIBICONV@
+ LTLIBINTL = @LTLIBINTL@
diff --git a/games/fgrun/files/patch-src-fgrun_pty.cxx b/games/fgrun/files/patch-src-fgrun_pty.cxx
new file mode 100644
index 000000000000..fbfdccda0aed
--- /dev/null
+++ b/games/fgrun/files/patch-src-fgrun_pty.cxx
@@ -0,0 +1,12 @@
+--- src/fgrun_pty.cxx.orig 2008-10-18 17:32:33.000000000 +0800
++++ src/fgrun_pty.cxx 2008-10-18 17:33:12.000000000 +0800
+@@ -28,6 +28,9 @@
+ # include <pty.h>
+ #endif
+
++#include <sys/types.h>
++#include <libutil.h>
++
+ #if defined(HAVE_UTMP_H)
+ # include <utmp.h>
+ #endif
diff --git a/games/fgrun/files/patch-src-run_posix.cxx b/games/fgrun/files/patch-src-run_posix.cxx
new file mode 100644
index 000000000000..180f2479c8e9
--- /dev/null
+++ b/games/fgrun/files/patch-src-run_posix.cxx
@@ -0,0 +1,11 @@
+--- src/run_posix.cxx.orig 2008-04-23 04:51:01.000000000 +0800
++++ src/run_posix.cxx 2008-10-18 17:28:27.000000000 +0800
+@@ -58,7 +58,7 @@
+ #if defined(HAVE_TERMIOS_H)
+ struct termios term;
+ tcgetattr( STDOUT_FILENO, &term );
+- term.c_oflag &= ~( OLCUC | ONLCR );
++ term.c_oflag &= ~ONLCR;
+
+ pid = pty_fork( &master, 0, &term, 0 );
+ #else
diff --git a/games/fgrun/pkg-descr b/games/fgrun/pkg-descr
new file mode 100644
index 000000000000..bebab25662c1
--- /dev/null
+++ b/games/fgrun/pkg-descr
@@ -0,0 +1,4 @@
+FlightGear Launch Control is a graphical frontend for running
+FlightGear flight simulator, <http://www.flightgear.org/>.
+
+WWW: http://sourceforge.net/projects/fgrun/
diff --git a/games/fgrun/pkg-plist b/games/fgrun/pkg-plist
new file mode 100644
index 000000000000..2df830676c80
--- /dev/null
+++ b/games/fgrun/pkg-plist
@@ -0,0 +1,19 @@
+bin/fgrun
+share/locale/de/LC_MESSAGES/fgrun.mo
+share/locale/fr/LC_MESSAGES/fgrun.mo
+share/locale/it/LC_MESSAGES/fgrun.mo
+share/locale/nl/LC_MESSAGES/fgrun.mo
+share/locale/pl/LC_MESSAGES/fgrun.mo
+share/locale/pt/LC_MESSAGES/fgrun.mo
+@dirrmtry share/locale/de/LC_MESSAGES
+@dirrmtry share/locale/fr/LC_MESSAGES
+@dirrmtry share/locale/it/LC_MESSAGES
+@dirrmtry share/locale/nl/LC_MESSAGES
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/de
+@dirrmtry share/locale/fr
+@dirrmtry share/locale/it
+@dirrmtry share/locale/nl
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/pt