aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-02 13:59:11 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-02 13:59:11 +0000
commitf7e6363f7aa82319e24659d9bcabe212d8fec7b6 (patch)
tree8e1f5a30c553b908238dee7ec26afcb50e740db3 /games
parentf54bfd09e4bdbe4dd15008b0d3ce0bdc5252fc69 (diff)
downloadports-f7e6363f7aa82319e24659d9bcabe212d8fec7b6.tar.gz
ports-f7e6363f7aa82319e24659d9bcabe212d8fec7b6.zip
- Add stage support
- Add DOCS options
Notes
Notes: svn path=/head/; revision=332484
Diffstat (limited to 'games')
-rw-r--r--games/jzip/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/games/jzip/Makefile b/games/jzip/Makefile
index ccb9ab26ab8e..3f5074c01658 100644
--- a/games/jzip/Makefile
+++ b/games/jzip/Makefile
@@ -16,12 +16,10 @@ USE_ZIP= yes
CPPFLAGS+= -DPOSIX -DHAVE_GETOPT
-MAN1= jzip.1
PORTDOCS= Jzip.doc
-PLIST_FILES= bin/jzip
+PLIST_FILES= bin/jzip man/man1/jzip.1.gz
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e \
@@ -34,11 +32,9 @@ post-patch:
's|^void main|int main|' ${WRKSRC}/jzexe.c
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} jzip ${PREFIX}/bin)
- (cd ${WRKSRC} && ${INSTALL_DATA} jzip.1 ${MANPREFIX}/man/man1)
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} Jzip.doc ${DOCSDIR})
-.endif
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} jzip ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_DATA} jzip.1 ${STAGEDIR}${MANPREFIX}/man/man1)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} Jzip.doc ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>