aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /games
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadports-0f583d87000061087521fb77c44c9055d122d787.tar.gz
ports-0f583d87000061087521fb77c44c9055d122d787.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Notes
Notes: svn path=/head/; revision=420774
Diffstat (limited to 'games')
-rw-r--r--games/blinken/Makefile4
-rw-r--r--games/bomber/Makefile4
-rw-r--r--games/bovo/Makefile4
-rw-r--r--games/granatier/Makefile4
-rw-r--r--games/kajongg/Makefile4
-rw-r--r--games/kanagram/Makefile4
-rw-r--r--games/kapman/Makefile4
-rw-r--r--games/katomic/Makefile4
-rw-r--r--games/kblackbox/Makefile4
-rw-r--r--games/kblocks/Makefile4
-rw-r--r--games/kbounce/Makefile4
-rw-r--r--games/kbreakout/Makefile4
-rw-r--r--games/kdegames4/Makefile5
-rw-r--r--games/kdegames4/Makefile.common2
-rw-r--r--games/kdiamond/Makefile4
-rw-r--r--games/kfourinline/Makefile4
-rw-r--r--games/kgoldrunner/Makefile4
-rw-r--r--games/khangman/Makefile4
-rw-r--r--games/kigo/Makefile4
-rw-r--r--games/killbots/Makefile4
-rw-r--r--games/kiriki/Makefile4
-rw-r--r--games/kjumpingcube/Makefile4
-rw-r--r--games/klickety/Makefile4
-rw-r--r--games/klines/Makefile4
-rw-r--r--games/kmahjongg/Makefile4
-rw-r--r--games/kmines/Makefile4
-rw-r--r--games/knavalbattle/Makefile4
-rw-r--r--games/knetwalk/Makefile4
-rw-r--r--games/knights-kde4/Makefile4
-rw-r--r--games/kolf/Makefile4
-rw-r--r--games/kollision/Makefile4
-rw-r--r--games/konquest/Makefile4
-rw-r--r--games/kpat/Makefile4
-rw-r--r--games/kreversi/Makefile4
-rw-r--r--games/kshisen/Makefile4
-rw-r--r--games/ksirk/Makefile4
-rw-r--r--games/ksnakeduel/Makefile4
-rw-r--r--games/kspaceduel/Makefile4
-rw-r--r--games/ksquares/Makefile4
-rw-r--r--games/ksudoku/Makefile4
-rw-r--r--games/ktuberling/Makefile4
-rw-r--r--games/kubrick/Makefile4
-rw-r--r--games/libkdegames/Makefile4
-rw-r--r--games/libkmahjongg/Makefile4
-rw-r--r--games/lskat/Makefile4
-rw-r--r--games/pairs/Makefile4
-rw-r--r--games/palapeli/Makefile4
-rw-r--r--games/picmi/Makefile4
48 files changed, 95 insertions, 96 deletions
diff --git a/games/blinken/Makefile b/games/blinken/Makefile
index beadb6049262..529149e2527d 100644
--- a/games/blinken/Makefile
+++ b/games/blinken/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Memory enhancement game for KDE 4
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/games/bomber/Makefile b/games/bomber/Makefile
index 6ab29e0f5249..babbe5bb4555 100644
--- a/games/bomber/Makefile
+++ b/games/bomber/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/bovo/Makefile b/games/bovo/Makefile
index 770223df0367..ccec6e08496b 100644
--- a/games/bovo/Makefile
+++ b/games/bovo/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/granatier/Makefile b/games/granatier/Makefile
index fba1c120c4e7..09b516b91aee 100644
--- a/games/granatier/Makefile
+++ b/games/granatier/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui xml \
moc_build qmake_build rcc_build uic_build
diff --git a/games/kajongg/Makefile b/games/kajongg/Makefile
index f6e1c03bc835..6eb7c106b656 100644
--- a/games/kajongg/Makefile
+++ b/games/kajongg/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource python tar:xz twisted:run sqlite
-USE_KDE4= kdelibs pykde4 automoc4
+USES= cmake:outsource kde:4 python tar:xz twisted:run sqlite
+USE_KDE= kdelibs pykde4 automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
CMAKE_ARGS= -DINSTALL_KAJONGG:BOOL=TRUE
diff --git a/games/kanagram/Makefile b/games/kanagram/Makefile
index 6e206ed8b738..9401a755ee40 100644
--- a/games/kanagram/Makefile
+++ b/games/kanagram/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Letter order game for KDE 4
-USE_KDE4= kdelibs libkdeedu automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdeedu automoc4
USE_QT4= xml corelib declarative gui opengl script xml \
moc_build qmake_build rcc_build uic_build
diff --git a/games/kapman/Makefile b/games/kapman/Makefile
index 7d0c663656dd..82087d646833 100644
--- a/games/kapman/Makefile
+++ b/games/kapman/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui xml \
moc_build qmake_build rcc_build uic_build
diff --git a/games/katomic/Makefile b/games/katomic/Makefile
index a863e310623d..182531b12c1f 100644
--- a/games/katomic/Makefile
+++ b/games/katomic/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource shebangfix tar:xz
+USES= cmake:outsource kde:4 shebangfix tar:xz
+USE_KDE= kdelibs libkdegames automoc4
SHEBANG_FILES= katomic-levelset-upd.pl
USE_QT4= moc_build qmake_build rcc_build uic_build
diff --git a/games/kblackbox/Makefile b/games/kblackbox/Makefile
index 143ebf3958e8..9a3fa67d3653 100644
--- a/games/kblackbox/Makefile
+++ b/games/kblackbox/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui xml \
moc_build qmake_build rcc_build uic_build
diff --git a/games/kblocks/Makefile b/games/kblocks/Makefile
index b33b60245325..14a656a03374 100644
--- a/games/kblocks/Makefile
+++ b/games/kblocks/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui network \
moc_build qmake_build rcc_build uic_build
diff --git a/games/kbounce/Makefile b/games/kbounce/Makefile
index 9faf753ec2cf..30fbc30fab8a 100644
--- a/games/kbounce/Makefile
+++ b/games/kbounce/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kbreakout/Makefile b/games/kbreakout/Makefile
index 2676695d31b8..4e78ceca01d0 100644
--- a/games/kbreakout/Makefile
+++ b/games/kbreakout/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui xml \
moc_build qmake_build rcc_build uic_build
diff --git a/games/kdegames4/Makefile b/games/kdegames4/Makefile
index e8284c64a802..5a8c3d463fcc 100644
--- a/games/kdegames4/Makefile
+++ b/games/kdegames4/Makefile
@@ -7,8 +7,7 @@ CATEGORIES= games kde
MAINTAINER= kde@FreeBSD.org
COMMENT= Games for KDE 4 (meta port)
-USE_KDE4= # blank, needed to get KDE4_VERSION
-USES= metaport
+USES= kde:4 metaport
OPTIONS_DEFINE= ALL ${KDE4_GAMES_ALL}
OPTIONS_DEFAULT= ALL
@@ -18,7 +17,7 @@ OPTIONS_DEFAULT= ALL
.for game in ${KDE4_GAMES_ALL}
# _PORT, _DETECT, and _DESC are defined in Makefile.common
${game}_PORT?= games/${game}
-${game}_DETECT?= ${KDE4_PREFIX}/bin/${game}
+${game}_DETECT?= ${KDE_PREFIX}/bin/${game}
${game}_DESC?= Please fix a typo in option name/desc!
${game}_RUN_DEPENDS= ${${game}_DETECT}:${${game}_PORT}
ALL_RUN_DEPENDS+= ${${game}_RUN_DEPENDS}
diff --git a/games/kdegames4/Makefile.common b/games/kdegames4/Makefile.common
index b5839bbc5232..7c540abe9362 100644
--- a/games/kdegames4/Makefile.common
+++ b/games/kdegames4/Makefile.common
@@ -42,7 +42,7 @@ KDE4_GAMES_ALL= bomber \
palapeli \
picmi
-ksnakeduel_DETECT= ${KDE4_PREFIX}/bin/ktron
+ksnakeduel_DETECT= ${KDE_PREFIX}/bin/ktron
bomber_DESC= Arcade Bombing game
bovo_DESC= Five-in-a-row Board game
diff --git a/games/kdiamond/Makefile b/games/kdiamond/Makefile
index e650eeba46bc..95b2fcbbbdcc 100644
--- a/games/kdiamond/Makefile
+++ b/games/kdiamond/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kfourinline/Makefile b/games/kfourinline/Makefile
index b1e128721e16..d575aa16d2c8 100644
--- a/games/kfourinline/Makefile
+++ b/games/kfourinline/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kgoldrunner/Makefile b/games/kgoldrunner/Makefile
index 5abb076411b1..0ccd8fe4fe19 100644
--- a/games/kgoldrunner/Makefile
+++ b/games/kgoldrunner/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/khangman/Makefile b/games/khangman/Makefile
index cdd7c9d22825..def91cc87ddb 100644
--- a/games/khangman/Makefile
+++ b/games/khangman/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Hangman game for KDE 4
-USE_KDE4= kdelibs libkdeedu automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdeedu automoc4
USE_QT4= corelib declarative gui opengl script xml \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/games/kigo/Makefile b/games/kigo/Makefile
index 9e7ffe8de9ef..9b3209463f18 100644
--- a/games/kigo/Makefile
+++ b/games/kigo/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/killbots/Makefile b/games/killbots/Makefile
index 1b2eaf3afbf4..d379cc4a63a3 100644
--- a/games/killbots/Makefile
+++ b/games/killbots/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui qtestlib xml \
moc_build qmake_build rcc_build uic_build
diff --git a/games/kiriki/Makefile b/games/kiriki/Makefile
index 3013fa81ced0..a2b20a4392c8 100644
--- a/games/kiriki/Makefile
+++ b/games/kiriki/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kjumpingcube/Makefile b/games/kjumpingcube/Makefile
index 7223add36cd8..c92162990cdb 100644
--- a/games/kjumpingcube/Makefile
+++ b/games/kjumpingcube/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/klickety/Makefile b/games/klickety/Makefile
index 08e46cc6d0e0..6a6c1b58f2c5 100644
--- a/games/klickety/Makefile
+++ b/games/klickety/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource shebangfix tar:xz
+USES= cmake:outsource kde:4 shebangfix tar:xz
+USE_KDE= kdelibs libkdegames automoc4
SHEBANG_FILES= klickety-2.0-inherit-ksame-highscore.pl
USE_QT4= corelib gui xml \
moc_build qmake_build rcc_build uic_build
diff --git a/games/klines/Makefile b/games/klines/Makefile
index c0ba1dfcfbb7..3e8d8a47dc95 100644
--- a/games/klines/Makefile
+++ b/games/klines/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kmahjongg/Makefile b/games/kmahjongg/Makefile
index 8bd0c8dce454..0d3b63d3aa5b 100644
--- a/games/kmahjongg/Makefile
+++ b/games/kmahjongg/Makefile
@@ -11,8 +11,8 @@ COMMENT= ${${PORTNAME}_DESC}
LIB_DEPENDS= libkmahjongglib.so:games/libkmahjongg
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kmines/Makefile b/games/kmines/Makefile
index 87ff1eb4589f..d28a88a01145 100644
--- a/games/kmines/Makefile
+++ b/games/kmines/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/knavalbattle/Makefile b/games/knavalbattle/Makefile
index 497b3019b270..2bc857c25fa9 100644
--- a/games/knavalbattle/Makefile
+++ b/games/knavalbattle/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui network xml \
moc_build qmake_build rcc_build uic_build
diff --git a/games/knetwalk/Makefile b/games/knetwalk/Makefile
index 3236bf1e537b..527bbc76bece 100644
--- a/games/knetwalk/Makefile
+++ b/games/knetwalk/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/knights-kde4/Makefile b/games/knights-kde4/Makefile
index 5ce17cd3c487..fc9e0f60b78c 100644
--- a/games/knights-kde4/Makefile
+++ b/games/knights-kde4/Makefile
@@ -14,8 +14,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/gnuchess:games/gnuchess
LICENSE= GPLv2
-USES= cmake:outsource tar:bzip2
-USE_KDE4= kdelibs automoc4 workspace libkdegames
+USES= cmake:outsource kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4 workspace libkdegames
USE_QT4= qmake_build moc_build rcc_build uic_build
OPTIONS_DEFINE= DOCS NLS
diff --git a/games/kolf/Makefile b/games/kolf/Makefile
index 0bbb876ce94c..244b75abc766 100644
--- a/games/kolf/Makefile
+++ b/games/kolf/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/games/kollision/Makefile b/games/kollision/Makefile
index 5068e055cf48..e454c1baf58d 100644
--- a/games/kollision/Makefile
+++ b/games/kollision/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/konquest/Makefile b/games/konquest/Makefile
index b2d3953740a7..2819afa46bb1 100644
--- a/games/konquest/Makefile
+++ b/games/konquest/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kpat/Makefile b/games/kpat/Makefile
index a659c3c09a5e..ba4357c7e3c8 100644
--- a/games/kpat/Makefile
+++ b/games/kpat/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource shared-mime-info tar:xz
+USES= cmake:outsource kde:4 shared-mime-info tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
post-patch:
diff --git a/games/kreversi/Makefile b/games/kreversi/Makefile
index 9c0a5bc95262..56a9283a0c79 100644
--- a/games/kreversi/Makefile
+++ b/games/kreversi/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kshisen/Makefile b/games/kshisen/Makefile
index dc4ae094d1a0..2f7296983ea9 100644
--- a/games/kshisen/Makefile
+++ b/games/kshisen/Makefile
@@ -11,8 +11,8 @@ COMMENT= ${${PORTNAME}_DESC}
LIB_DEPENDS= libkmahjongglib.so:games/libkmahjongg
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/ksirk/Makefile b/games/ksirk/Makefile
index 6c11a01b9edb..33cd9dafe072 100644
--- a/games/ksirk/Makefile
+++ b/games/ksirk/Makefile
@@ -11,8 +11,8 @@ COMMENT= ${${PORTNAME}_DESC}
LIB_DEPENDS= libqca.so:devel/qca
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui corelib gui network qt3support svg xml \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/games/ksnakeduel/Makefile b/games/ksnakeduel/Makefile
index ef590b4a6cd1..1e7f20b93a59 100644
--- a/games/ksnakeduel/Makefile
+++ b/games/ksnakeduel/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kspaceduel/Makefile b/games/kspaceduel/Makefile
index d964a6a06dc8..a7994fed0f00 100644
--- a/games/kspaceduel/Makefile
+++ b/games/kspaceduel/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/ksquares/Makefile b/games/ksquares/Makefile
index 1d72cc6d91fa..b47ebfd4b21e 100644
--- a/games/ksquares/Makefile
+++ b/games/ksquares/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/ksudoku/Makefile b/games/ksudoku/Makefile
index ad7d32a0546e..66d0471f4639 100644
--- a/games/ksudoku/Makefile
+++ b/games/ksudoku/Makefile
@@ -9,9 +9,9 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
+USES= cmake:outsource kde:4 tar:xz
USE_GL= glu
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui corelib gui opengl \
moc_build qmake_build rcc_build uic_build
diff --git a/games/ktuberling/Makefile b/games/ktuberling/Makefile
index 5b84ce731aa9..c2ffa58bb87f 100644
--- a/games/ktuberling/Makefile
+++ b/games/ktuberling/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <${.CURDIR}/../kdegames4/Makefile.common>
diff --git a/games/kubrick/Makefile b/games/kubrick/Makefile
index 8c28b5bb66a4..1fa833e0837c 100644
--- a/games/kubrick/Makefile
+++ b/games/kubrick/Makefile
@@ -9,9 +9,9 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
+USES= cmake:outsource kde:4 tar:xz
USE_GL= glu
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui opengl \
moc_build qmake_build rcc_build uic_build
diff --git a/games/libkdegames/Makefile b/games/libkdegames/Makefile
index 5f5351aca1e7..fa492e13efc2 100644
--- a/games/libkdegames/Makefile
+++ b/games/libkdegames/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Libraries used by KDE 4 games
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= network phonon xml moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/games/libkmahjongg/Makefile b/games/libkmahjongg/Makefile
index 4c0551b72433..057cc682b5a7 100644
--- a/games/libkmahjongg/Makefile
+++ b/games/libkmahjongg/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Library for the Mahjongg Solitaire for KDE 4
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/games/lskat/Makefile b/games/lskat/Makefile
index 91a2fe483e79..794cf7d333e2 100644
--- a/games/lskat/Makefile
+++ b/games/lskat/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui gui svg \
moc_build qmake_build rcc_build uic_build
diff --git a/games/pairs/Makefile b/games/pairs/Makefile
index cc7bf8a46f50..de56a0492226 100644
--- a/games/pairs/Makefile
+++ b/games/pairs/Makefile
@@ -12,8 +12,8 @@ COMMENT= Memory and pairs game for KDE
LICENSE= GPLv2
-USES= cmake:outsource tar:xz
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= declarative opengl phonon xmlpatterns \
moc_build qmake_build rcc_build uic_build
diff --git a/games/palapeli/Makefile b/games/palapeli/Makefile
index dfe0b2f36a4c..b0bbdeb27562 100644
--- a/games/palapeli/Makefile
+++ b/games/palapeli/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USE_KDE4= kdelibs libkdegames automoc4
-USES= cmake:outsource shared-mime-info tar:xz
+USES= cmake:outsource kde:4 shared-mime-info tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= corelib gui gui \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/games/picmi/Makefile b/games/picmi/Makefile
index e33b9220294a..a5181cba6135 100644
--- a/games/picmi/Makefile
+++ b/games/picmi/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource tar:xz
-USE_KDE4= kdelibs libkdegames automoc4
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build \
svg xml