aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-12-27 07:36:05 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-12-27 07:36:05 +0000
commitf02e9b1855dc11dfa3de0a0a24519c758caea34a (patch)
tree5e3dc4da12378e6f79cbb4cdbdaa0c572de9f795 /games
parentd9880127362955fca78c4127c39fa0fb7c92f66c (diff)
downloadports-f02e9b1855dc11dfa3de0a0a24519c758caea34a.tar.gz
ports-f02e9b1855dc11dfa3de0a0a24519c758caea34a.zip
Disable the extra flag "-march=native" on arm to fix builds.
Approved by: portmgr (tier-2 blanket) Obtained from: lonesome.com -exp run
Notes
Notes: svn path=/head/; revision=457351
Diffstat (limited to 'games')
-rw-r--r--games/trigger-rally/Makefile8
-rw-r--r--games/trigger-rally/files/patch-GNUmakefile9
2 files changed, 13 insertions, 4 deletions
diff --git a/games/trigger-rally/Makefile b/games/trigger-rally/Makefile
index b1e5179894c2..edd650bb94e2 100644
--- a/games/trigger-rally/Makefile
+++ b/games/trigger-rally/Makefile
@@ -15,10 +15,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libphysfs.so:devel/physfs
LIB_DEPENDS+= libalut.so:audio/freealut
-BROKEN_aarch64= fails to compile: error: the clang compiler does not support -march=native
-BROKEN_armv6= fails to compile: error: the clang compiler does not support -march=native
-BROKEN_armv7= fails to compile: error: the clang compiler does not support -march=native
-BROKEN_powerpc64= fails to compile: error: the clang compiler does not support -march=native
+#BROKEN_aarch64= fails to compile: error: the clang compiler does not support -march=native
+#BROKEN_armv6= fails to compile: error: the clang compiler does not support -march=native
+#BROKEN_armv7= fails to compile: error: the clang compiler does not support -march=native
+#BROKEN_powerpc64= fails to compile: error: the clang compiler does not support -march=native
WRKSRC_SUBDIR= src
USES= gmake openal:al,alut
diff --git a/games/trigger-rally/files/patch-GNUmakefile b/games/trigger-rally/files/patch-GNUmakefile
index db931b65efca..2d94210c4e44 100644
--- a/games/trigger-rally/files/patch-GNUmakefile
+++ b/games/trigger-rally/files/patch-GNUmakefile
@@ -1,5 +1,14 @@
--- GNUmakefile.orig 2016-11-05 17:27:10 UTC
+++ GNUmakefile
+@@ -21,7 +21,7 @@ SRCFILES := $(shell find $(PROJDI
+ OBJFILES := $(patsubst %.cpp, %.o, $(SRCFILES))
+ DEPFILES := $(patsubst %.cpp, %.d, $(SRCFILES))
+ WARNINGS ?= -Wall -Wextra -pedantic
+-OPTIMS ?= -march=native -mtune=native -Ofast
++OPTIMS ?= -mtune=native -Ofast
+ DMACROS := -DNDEBUG -DUNIX -DPACKAGE_VERSION=\"$(DISTVER)\"
+ INCDIRS := -I'./include'
+ CXXFLAGS += -std=c++11 $(WARNINGS) $(OPTIMS)
@@ -125,7 +125,7 @@ $(TR_EXEFILE): $(OBJFILES)
printf "\t%s\n" $$file; \
done;