aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-26 05:33:51 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-26 05:33:51 +0000
commita4fc6158f566f3061d1acce1ef519be9cd17a69a (patch)
treeeb22256c13100460a384a64ae5d3fbefbaab9ab7 /games
parentf720ee1568631cec981d47b6deaf26f18bc44159 (diff)
downloadports-a4fc6158f566f3061d1acce1ef519be9cd17a69a.tar.gz
ports-a4fc6158f566f3061d1acce1ef519be9cd17a69a.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Notes
Notes: svn path=/head/; revision=323680
Diffstat (limited to 'games')
-rw-r--r--games/3dc/Makefile3
-rw-r--r--games/p5-Games-Bingo/Makefile8
-rw-r--r--games/pengpong/Makefile12
-rw-r--r--games/ttraffic/Makefile15
-rw-r--r--games/zangband/Makefile15
5 files changed, 21 insertions, 32 deletions
diff --git a/games/3dc/Makefile b/games/3dc/Makefile
index f9d0790949ef..095e16faf548 100644
--- a/games/3dc/Makefile
+++ b/games/3dc/Makefile
@@ -22,7 +22,8 @@ WRKSRC= ${WRKDIR}/3Dc/src
post-patch:
.for file in init.c main.c piece.c stack.c xif.c
- @${PERL} -pi -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -i '' -e 's|malloc.h|stdlib.h|' \
+ ${WRKSRC}/${file}
.endfor
do-install:
diff --git a/games/p5-Games-Bingo/Makefile b/games/p5-Games-Bingo/Makefile
index 165a47e69968..8d4347c33413 100644
--- a/games/p5-Games-Bingo/Makefile
+++ b/games/p5-Games-Bingo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Games-Bingo
-# Date created: 14. August 2003
-# Whom: Lars Thegler <lars@thegler.dk>
-#
+# Created by: Lars Thegler <lars@thegler.dk>
# $FreeBSD$
-#
PORTNAME= Games-Bingo
PORTVERSION= 0.15
@@ -26,6 +22,6 @@ MAN3= Games::Bingo.3 \
.include <bsd.port.pre.mk>
post-patch:
- @${PERL} -pi -e '$$_="" if m|Test::|' ${WRKSRC}/Build.PL
+ @${REINPLACE_CMD} -i '' '/Test::/d' ${WRKSRC}/Build.PL
.include <bsd.port.post.mk>
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
index 2844fb42db5a..5808c5bf042d 100644
--- a/games/pengpong/Makefile
+++ b/games/pengpong/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pengpong
-# Date created: Fri Aug 24 18:21:25 EDT 2001
-# Whom: Patrick Li <pat@databits.net>
-#
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
-#
PORTNAME= pengpong
PORTVERSION= 0.3
@@ -22,11 +18,9 @@ DATAFILES= 24P_Copperplate_Blue.png ball.tga logo.jpg \
paddle.tga red.png
pre-patch:
- @${PERL} -pi.orig -e \
- 's|/usr/local/share/games/pengpong|${DATADIR}|' \
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/share/games/pengpong|${DATADIR}|' \
${WRKSRC}/files.h
- @${PERL} -pi.orig -e 's|0.2|${PORTVERSION}|' \
- ${WRKSRC}/pengpong.cpp
+ @${REINPLACE_CMD} -i '' -e 's|V 0.2|V ${PORTVERSION}|' ${WRKSRC}/pengpong.cpp
do-install:
.ifndef(NOPORTDOCS)
diff --git a/games/ttraffic/Makefile b/games/ttraffic/Makefile
index a73656558e67..dcb9b0b93253 100644
--- a/games/ttraffic/Makefile
+++ b/games/ttraffic/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: games/ttraffic
-# Date created: 14 November 2001
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ttraffic
PORTVERSION= 0.8
@@ -20,11 +16,16 @@ RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
NO_BUILD= yes
USE_PERL5_BUILD=yes
+USES= shebangfix
+SHEBANG_FILES= ttraffic.tcl
+SHEBANG_LANG= wish
+wish_OLD_CMD= /usr/bin/wish
+wish_CMD= ${LOCALBASE}/bin/wish8.4
post-patch:
- ${PERL} -pi -e 's|/usr/local/share/ttraffic/|${DATADIR}/|g;' \
- -e 's|#!/usr/bin/wish|#!${LOCALBASE}/bin/wish8.4|g' \
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/share/ttraffic/|${DATADIR}/|' \
${WRKSRC}/ttraffic.tcl
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/ttraffic.tcl ${PREFIX}/bin/ttraffic
${MKDIR} ${DATADIR}
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index 42b703292f04..9192507e030e 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zangband
-# Date created: 29 May 2000
-# Whom: Makoto YAMAKURA <makoto@pinpott.spnet.ne.jp>
-#
+# Created by: Makoto YAMAKURA <makoto@pinpott.spnet.ne.jp>
# $FreeBSD$
-#
PORTNAME= zangband
PORTVERSION= 2.6.2
@@ -38,10 +34,11 @@ ANGBANDLIB?= lib/${PORTNAME}
ANGBANDBIN?= bin/${PORTNAME}
pre-patch:
- @${PERL} -pi.orig -e 's|^aclocal|${ACLOCAL}|; \
- s|^autoheader|${AUTOHEADER}|; \
- s|^automake|${AUTOMAKE}|; s|^autoconf|${AUTOCONF}|' \
- ${WRKSRC}/bootstrap
+ @${REINPLACE_CMD} -i '' -e 's|^aclocal|${ACLOCAL}|' \
+ -e 's|^autoheader|${AUTOHEADER}|' \
+ -e 's|^automake|${AUTOMAKE}|' \
+ -e 's|^autoconf|${AUTOCONF}|' \
+ ${WRKSRC}/bootstrap
pre-configure:
(cd ${WRKSRC} ; ${SH} bootstrap)