aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-20 11:28:18 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-20 11:28:18 +0000
commita50b79ffe4ad53b98f12fb0459367b788c6c0da9 (patch)
treeb7c1dacb4f39a206f739908f6b8316fd3f592248 /games
parentf93a811dcf3422b83bf82051439815e2aced4e6f (diff)
downloadports-a50b79ffe4ad53b98f12fb0459367b788c6c0da9.tar.gz
ports-a50b79ffe4ad53b98f12fb0459367b788c6c0da9.zip
Move more of my ports which use one or more SDL libraries towards USE_SDL.
Submitted by: edwin@mavetju.org
Notes
Notes: svn path=/head/; revision=98642
Diffstat (limited to 'games')
-rw-r--r--games/bomberclone/Makefile8
-rw-r--r--games/circuslinux/Makefile8
-rw-r--r--games/sopwith/Makefile4
-rw-r--r--games/xpired/Makefile6
4 files changed, 5 insertions, 21 deletions
diff --git a/games/bomberclone/Makefile b/games/bomberclone/Makefile
index e7b7a4c2657b..1ef603d7b905 100644
--- a/games/bomberclone/Makefile
+++ b/games/bomberclone/Makefile
@@ -14,17 +14,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= edwin@mavetju.org
COMMENT= Reimplementation of Atomic Bomber Man
-LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
+USE_SDL= image mixer sdl
GNU_CONFIGURE= yes
USE_XLIB= yes
-USE_SDL= yes
USE_GMAKE= yes
USE_BZIP2= yes
CONFIGURE_ARGS= --target=""
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CXXFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include"
.include <bsd.port.mk>
diff --git a/games/circuslinux/Makefile b/games/circuslinux/Makefile
index 8a2e9cb83aa8..f5ab50418b97 100644
--- a/games/circuslinux/Makefile
+++ b/games/circuslinux/Makefile
@@ -13,15 +13,9 @@ MASTER_SITES= http://www.nbswebfx.com/downloads/
MAINTAINER= edwin@mavetju.org
COMMENT= "Circus Linux!" is a clone of the Atari 2600 game "Circus Atari"
-BUILD_DEPENDS= sdl11-config:${PORTSDIR}/devel/sdl12
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
+USE_SDL= image mixer sdl
GNU_CONFIGURE= yes
USE_XLIB= yes
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
CONFIGURE_ARGS= --target=""
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
.include <bsd.port.mk>
diff --git a/games/sopwith/Makefile b/games/sopwith/Makefile
index 409290ee09c8..2fcc9ec6bc22 100644
--- a/games/sopwith/Makefile
+++ b/games/sopwith/Makefile
@@ -15,12 +15,10 @@ DISTNAME= sdl_${PORTNAME}-${PORTVERSION}
MAINTAINER= edwin@mavetju.org
COMMENT= A classic WW1 biplane game
-BUILD_DEPENDS= ${LOCALBASE}/bin/sdl11-config:${PORTSDIR}/devel/sdl12
-
+USE_SDL= sdl
USE_GMAKE= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CONFIGURE_ENV= SDL_CONFIG=${LOCALBASE}/bin/sdl11-config
MAN6= sopwith.6
diff --git a/games/xpired/Makefile b/games/xpired/Makefile
index 3236154c59b6..b33d080f115d 100644
--- a/games/xpired/Makefile
+++ b/games/xpired/Makefile
@@ -16,11 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-linux_source
MAINTAINER= edwin@mavetju.org
COMMENT= An action-puzzle maze escape game (SDL)
-LIB_DEPENDS= SDL_gfx.10:${PORTSDIR}/graphics/sdl_gfx \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image \
- SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
+USE_SDL= gfx image mixer sdl
WRKSRC= ${WRKDIR}/src
do-install: