aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
commitdbba8af6447e625aae93ec45e619acbecb4ab189 (patch)
treed696a8c2d3e835a743132aa1f6a5cc0557d1c435 /games
parent683eaaa4ff765b627c52f147501abfaec4449cce (diff)
downloadports-dbba8af6447e625aae93ec45e619acbecb4ab189.tar.gz
ports-dbba8af6447e625aae93ec45e619acbecb4ab189.zip
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Notes
Notes: svn path=/head/; revision=40792
Diffstat (limited to 'games')
-rw-r--r--games/blackjack/Makefile2
-rw-r--r--games/kbubbles/Makefile4
-rw-r--r--games/kdegames2/Makefile14
-rw-r--r--games/kdegames2/distinfo2
-rw-r--r--games/kdegames3/Makefile14
-rw-r--r--games/kdegames3/distinfo2
-rw-r--r--games/kdegames4/Makefile14
-rw-r--r--games/kdegames4/distinfo2
-rw-r--r--games/krogue/Makefile4
-rw-r--r--games/krubik/Makefile3
-rw-r--r--games/ktamaga/Makefile4
-rw-r--r--games/nethack-qt/Makefile2
-rw-r--r--games/nethack33-qt/Makefile2
-rw-r--r--games/nethack34-qt/Makefile2
-rw-r--r--games/pp/Makefile2
-rw-r--r--games/xlines/Makefile2
16 files changed, 19 insertions, 56 deletions
diff --git a/games/blackjack/Makefile b/games/blackjack/Makefile
index 56dbc39bd396..e4f584e83dc6 100644
--- a/games/blackjack/Makefile
+++ b/games/blackjack/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_QT= yes
+USE_QT_VER= 1
MAN1= blackjack.1
diff --git a/games/kbubbles/Makefile b/games/kbubbles/Makefile
index 25a27687996f..097a4961e9d9 100644
--- a/games/kbubbles/Makefile
+++ b/games/kbubbles/Makefile
@@ -13,10 +13,8 @@ MASTER_SITES= http://hem.passagen.se/tonybj/kbubbles/
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext
-LIB_DEPENDS= QwSpriteField.7:${PORTSDIR}/converters/kdesupport11 \
- kdecore.3:${PORTSDIR}/x11/kdelibs11
+USE_KDELIBS_VER=1
USE_LIBTOOL= yes
-USE_QT= yes
.include <bsd.port.mk>
diff --git a/games/kdegames2/Makefile b/games/kdegames2/Makefile
index 2f10e12bb138..84cce965cc68 100644
--- a/games/kdegames2/Makefile
+++ b/games/kdegames2/Makefile
@@ -6,26 +6,16 @@
#
PORTNAME= kdegames
-PORTVERSION= 2.1
+PORTVERSION= 2.1.1
CATEGORIES= games kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2
-
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_BZIP2= yes
-USE_NEWGCC= yes
USE_AUTOCONF= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H"
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/games/kdegames2/distinfo b/games/kdegames2/distinfo
index e86d731eca29..07ebe258a73d 100644
--- a/games/kdegames2/distinfo
+++ b/games/kdegames2/distinfo
@@ -1 +1 @@
-MD5 (kdegames-2.1.tar.bz2) = 62a7597b32e0dfec36f88ffd81a633f7
+MD5 (kdegames-2.1.1.tar.bz2) = decb4b934a30bd3d52fe68b5b058bbc9
diff --git a/games/kdegames3/Makefile b/games/kdegames3/Makefile
index 2f10e12bb138..84cce965cc68 100644
--- a/games/kdegames3/Makefile
+++ b/games/kdegames3/Makefile
@@ -6,26 +6,16 @@
#
PORTNAME= kdegames
-PORTVERSION= 2.1
+PORTVERSION= 2.1.1
CATEGORIES= games kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2
-
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_BZIP2= yes
-USE_NEWGCC= yes
USE_AUTOCONF= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H"
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/games/kdegames3/distinfo b/games/kdegames3/distinfo
index e86d731eca29..07ebe258a73d 100644
--- a/games/kdegames3/distinfo
+++ b/games/kdegames3/distinfo
@@ -1 +1 @@
-MD5 (kdegames-2.1.tar.bz2) = 62a7597b32e0dfec36f88ffd81a633f7
+MD5 (kdegames-2.1.1.tar.bz2) = decb4b934a30bd3d52fe68b5b058bbc9
diff --git a/games/kdegames4/Makefile b/games/kdegames4/Makefile
index 2f10e12bb138..84cce965cc68 100644
--- a/games/kdegames4/Makefile
+++ b/games/kdegames4/Makefile
@@ -6,26 +6,16 @@
#
PORTNAME= kdegames
-PORTVERSION= 2.1
+PORTVERSION= 2.1.1
CATEGORIES= games kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2
-
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_BZIP2= yes
-USE_NEWGCC= yes
USE_AUTOCONF= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H"
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/games/kdegames4/distinfo b/games/kdegames4/distinfo
index e86d731eca29..07ebe258a73d 100644
--- a/games/kdegames4/distinfo
+++ b/games/kdegames4/distinfo
@@ -1 +1 @@
-MD5 (kdegames-2.1.tar.bz2) = 62a7597b32e0dfec36f88ffd81a633f7
+MD5 (kdegames-2.1.1.tar.bz2) = decb4b934a30bd3d52fe68b5b058bbc9
diff --git a/games/krogue/Makefile b/games/krogue/Makefile
index 0754886b6942..53469cf796d7 100644
--- a/games/krogue/Makefile
+++ b/games/krogue/Makefile
@@ -15,12 +15,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
-LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
-USE_QT= yes
+USE_KDELIBS_VER=1
USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= QTDIR="${X11BASE}" KDEDIR="${LOCALBASE}"
-CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/X11/qt
.include <bsd.port.mk>
diff --git a/games/krubik/Makefile b/games/krubik/Makefile
index f5c03ed60cb1..c6fa50d6a7b6 100644
--- a/games/krubik/Makefile
+++ b/games/krubik/Makefile
@@ -13,9 +13,8 @@ MASTER_SITES= http://www.phys.uu.nl/~eendebak/kde/
MAINTAINER= jedgar@fxp.org
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
-LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
+USE_KDELIBS_VER=1
GNU_CONFIGURE= yes
-USE_QT= yes
.include <bsd.port.mk>
diff --git a/games/ktamaga/Makefile b/games/ktamaga/Makefile
index 7a8065ca32db..1c300b3aeb9d 100644
--- a/games/ktamaga/Makefile
+++ b/games/ktamaga/Makefile
@@ -13,10 +13,8 @@ MASTER_SITES= ftp://ftp.net.lut.ac.uk/kde/unstable/apps/games/ \
MAINTAINER= se@freebsd.org
-LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
+USE_KDELIBS_VER=1
MAKE_ENV= DEBUG_FL="$(CFLAGS)"
-
-USE_QT= yes
WRKSRC= ${WRKDIR}/tamaga-0.2
.include <bsd.port.mk>
diff --git a/games/nethack-qt/Makefile b/games/nethack-qt/Makefile
index c6c5f6ebed9b..bd00c19924c3 100644
--- a/games/nethack-qt/Makefile
+++ b/games/nethack-qt/Makefile
@@ -25,7 +25,7 @@ QT_PATCH= qnethack-3.2.2.1.0.1.src.tar.gz
QT_SOUND= nhs.tar.gz
EXTRACT_ONLY= nethack-3.2.2.tar.gz
-USE_QT= yes
+USE_QT_VER= 1
USE_XPM= yes
USE_GMAKE= yes
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
diff --git a/games/nethack33-qt/Makefile b/games/nethack33-qt/Makefile
index c6c5f6ebed9b..bd00c19924c3 100644
--- a/games/nethack33-qt/Makefile
+++ b/games/nethack33-qt/Makefile
@@ -25,7 +25,7 @@ QT_PATCH= qnethack-3.2.2.1.0.1.src.tar.gz
QT_SOUND= nhs.tar.gz
EXTRACT_ONLY= nethack-3.2.2.tar.gz
-USE_QT= yes
+USE_QT_VER= 1
USE_XPM= yes
USE_GMAKE= yes
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
diff --git a/games/nethack34-qt/Makefile b/games/nethack34-qt/Makefile
index c6c5f6ebed9b..bd00c19924c3 100644
--- a/games/nethack34-qt/Makefile
+++ b/games/nethack34-qt/Makefile
@@ -25,7 +25,7 @@ QT_PATCH= qnethack-3.2.2.1.0.1.src.tar.gz
QT_SOUND= nhs.tar.gz
EXTRACT_ONLY= nethack-3.2.2.tar.gz
-USE_QT= yes
+USE_QT_VER= 1
USE_XPM= yes
USE_GMAKE= yes
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
diff --git a/games/pp/Makefile b/games/pp/Makefile
index a67f7dcbf18c..e7a48d6860d9 100644
--- a/games/pp/Makefile
+++ b/games/pp/Makefile
@@ -14,7 +14,7 @@ DISTFILES= ppinst-0.01.tar.gz ppsrc-0.01.tar.gz
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/ppsrc
-USE_QT= yes
+USE_QT_VER= 1
USE_X_PREFIX= yes
do-install:
diff --git a/games/xlines/Makefile b/games/xlines/Makefile
index 32e110f05634..4513faeefcf8 100644
--- a/games/xlines/Makefile
+++ b/games/xlines/Makefile
@@ -13,7 +13,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-USE_QT= yes
+USE_QT_VER= 1
USE_X_PREFIX= yes
NO_WRKSUBDIR= yes