aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-20 09:56:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-20 09:56:52 +0000
commit9fc1c4fe89616480338adc0d98d5b1f0e4175302 (patch)
treea1c4a73130cdd2f28d9877c9ed4e5fc54d9c25ae /games
parent59ffb51d2c9fc8f60995b11aee6533f8bdb126c2 (diff)
downloadports-9fc1c4fe89616480338adc0d98d5b1f0e4175302.tar.gz
ports-9fc1c4fe89616480338adc0d98d5b1f0e4175302.zip
- Remove USE_GETOPT_LONG which is a no-op since March 2007
Notes
Notes: svn path=/head/; revision=209420
Diffstat (limited to 'games')
-rw-r--r--games/afternoonstalker/Makefile1
-rw-r--r--games/an/Makefile1
-rw-r--r--games/asc/Makefile1
-rw-r--r--games/barrage/Makefile1
-rw-r--r--games/burgerspace/Makefile1
-rw-r--r--games/foobillard/Makefile1
-rw-r--r--games/freesweep/Makefile1
-rw-r--r--games/ggz-client-libs/Makefile1
-rw-r--r--games/ggz-gtk-client/Makefile1
-rw-r--r--games/ggz-gtk-games/Makefile1
-rw-r--r--games/ggz-sdl-games/Makefile1
-rw-r--r--games/ggz-txt-client/Makefile1
-rw-r--r--games/gnubg/Makefile1
-rw-r--r--games/heroes/Makefile1
-rw-r--r--games/mt_dolphin_ia/Makefile1
-rw-r--r--games/nethack33/Makefile1
-rw-r--r--games/nethack34/Makefile1
-rw-r--r--games/phalanx/Makefile1
-rw-r--r--games/poker-eval/Makefile1
-rw-r--r--games/rtb/Makefile1
-rw-r--r--games/sarien/Makefile1
-rw-r--r--games/tmw/Makefile1
-rw-r--r--games/trackballs/Makefile1
-rw-r--r--games/wmpuzzle/Makefile1
-rw-r--r--games/xqf/Makefile1
25 files changed, 0 insertions, 25 deletions
diff --git a/games/afternoonstalker/Makefile b/games/afternoonstalker/Makefile
index 52d61d523059..0bbc988d35cd 100644
--- a/games/afternoonstalker/Makefile
+++ b/games/afternoonstalker/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= gengameng.4:${PORTSDIR}/devel/gengameng \
flatzebra-0.1.2:${PORTSDIR}/devel/flatzebra
USE_SDL= mixer sdl
-USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/games/an/Makefile b/games/an/Makefile
index 448ba7daf660..246ac6a9a5e4 100644
--- a/games/an/Makefile
+++ b/games/an/Makefile
@@ -17,7 +17,6 @@ COMMENT= Fast anagram generator
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GETOPT_LONG= yes
MAN6= an.6
post-patch:
diff --git a/games/asc/Makefile b/games/asc/Makefile
index 5e0aa8cc1af6..9d255375815c 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -27,7 +27,6 @@ USE_GMAKE= yes
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
USE_GCC= 3.4+
-USE_GETOPT_LONG= yes
CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
CXXFLAGS="-D_UNICODE_BROKEN_" \
LIBS="`${SDL_CONFIG} --libs` -lm"
diff --git a/games/barrage/Makefile b/games/barrage/Makefile
index 29c3a6bdce05..2b21d108a428 100644
--- a/games/barrage/Makefile
+++ b/games/barrage/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= az@FreeBSD.org
COMMENT= Destroy as many targets as possible
USE_GMAKE= yes
-USE_GETOPT_LONG=yes
USE_SDL= sdl mixer
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-profile-path=/var/games
diff --git a/games/burgerspace/Makefile b/games/burgerspace/Makefile
index e0ca85fefbe0..dfd824a3ff80 100644
--- a/games/burgerspace/Makefile
+++ b/games/burgerspace/Makefile
@@ -17,7 +17,6 @@ COMMENT= A BurgerTime clone
LIB_DEPENDS= gengameng.4:${PORTSDIR}/devel/gengameng \
flatzebra-0.1.2:${PORTSDIR}/devel/flatzebra
-USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
CPPFLAGS= -I${X11BASE}/include -I${LOCALBASE}/include
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index e8c3c824e066..58551913180d 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -24,7 +24,6 @@ OPTIONS= SDL "Use SDL instead of glut" off \
FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
-USE_GETOPT_LONG=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/freesweep/Makefile b/games/freesweep/Makefile
index c7f91a474acb..00f73085472f 100644
--- a/games/freesweep/Makefile
+++ b/games/freesweep/Makefile
@@ -19,7 +19,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-prefsdir=${DATADIR} \
--with-scoresdir=${DATADIR}\
--disable-debug-log
-USE_GETOPT_LONG= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/games/ggz-client-libs/Makefile b/games/ggz-client-libs/Makefile
index 45251b7763d6..0c4ae41897b0 100644
--- a/games/ggz-client-libs/Makefile
+++ b/games/ggz-client-libs/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnometarget
-USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug --with-libggz-dir="${LOCALBASE}"
diff --git a/games/ggz-gtk-client/Makefile b/games/ggz-gtk-client/Makefile
index 547e83784cbd..a9d5fb030663 100644
--- a/games/ggz-gtk-client/Makefile
+++ b/games/ggz-gtk-client/Makefile
@@ -15,7 +15,6 @@ COMMENT= The GGZ Gaming Zone - GTK+ Frontend
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnometarget gtk20
-USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
diff --git a/games/ggz-gtk-games/Makefile b/games/ggz-gtk-games/Makefile
index 49e41e065051..1aec434751c0 100644
--- a/games/ggz-gtk-games/Makefile
+++ b/games/ggz-gtk-games/Makefile
@@ -16,7 +16,6 @@ COMMENT= The GGZ Gaming Zone - GTK+ Games
RUN_DEPENDS= ${LOCALBASE}/bin/ggz-gtk:${PORTSDIR}/games/ggz-gtk-client
USE_GNOME= gnometarget gtk20
-USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
diff --git a/games/ggz-sdl-games/Makefile b/games/ggz-sdl-games/Makefile
index 81573f5e16fc..91a569bc3273 100644
--- a/games/ggz-sdl-games/Makefile
+++ b/games/ggz-sdl-games/Makefile
@@ -13,7 +13,6 @@ CATEGORIES= games
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= The GGZ Gaming Zone - SDL-based games
-USE_GETOPT_LONG= yes
USE_GL= yes
USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
diff --git a/games/ggz-txt-client/Makefile b/games/ggz-txt-client/Makefile
index 02ef018a3b70..324081eb8267 100644
--- a/games/ggz-txt-client/Makefile
+++ b/games/ggz-txt-client/Makefile
@@ -14,7 +14,6 @@ MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= The GGZ Gaming Zone - Console (Text) Frontend
USE_GNOME= gnometarget
-USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index cd891e79aafe..41e791727c2b 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -35,7 +35,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
ac_cv_path_ARTSC_CONFIG=no ac_cv_path_LIBART_CONFIG=no
USE_GNOME= gnomehack gnometarget libxml2
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
USE_PYTHON= 2.0+
USE_AUTOTOOLS= libtool:15 automake:19
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index bc2bbd61dbb3..6ae003970193 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -32,7 +32,6 @@ MUSICSRC= ${WRKDIR}/${MUSICDISTNAME}
USE_X_PREFIX= yes
USE_SDL= mixer sdl
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_GETTEXT= yes
diff --git a/games/mt_dolphin_ia/Makefile b/games/mt_dolphin_ia/Makefile
index c7ea7d2d7d25..8ffc8ecb441e 100644
--- a/games/mt_dolphin_ia/Makefile
+++ b/games/mt_dolphin_ia/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= mt_client.0:${PORTSDIR}/games/libmt_client
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= glib20 libxml2
-USE_GETOPT_LONG= yes
CONFIGURE_ARGS= --with-libmt_client=${LOCALBASE} \
--with-libmaitretarot=${LOCALBASE}
diff --git a/games/nethack33/Makefile b/games/nethack33/Makefile
index 354fa4525a20..7000f5f8dce1 100644
--- a/games/nethack33/Makefile
+++ b/games/nethack33/Makefile
@@ -43,7 +43,6 @@ GRAPHICS= X11_GRAPHICS
.else
.if ${PKGNAMESUFFIX} == "-gnome"
CATEGORIES= games gnome
-USE_GETOPT_LONG=yes
USE_GNOME= gnomelibs
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GRAPHICS= GNOME_GRAPHICS
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index 75faaf5a2db5..4d366199cc32 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -38,7 +38,6 @@ GRAPHICS= X11_GRAPHICS
.else
.if ${PKGNAMESUFFIX} == "-gnome"
CATEGORIES= games gnome
-USE_GETOPT_LONG= yes
USE_GNOME= gnomelibs
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GRAPHICS= GNOME_GRAPHICS
diff --git a/games/phalanx/Makefile b/games/phalanx/Makefile
index 4a9d27cc2356..11f0559df818 100644
--- a/games/phalanx/Makefile
+++ b/games/phalanx/Makefile
@@ -17,7 +17,6 @@ COMMENT= Xboard-compatible chess playing program
WRKSRC= ${WRKDIR}/Phalanx-XXII
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} ${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= # empty
diff --git a/games/poker-eval/Makefile b/games/poker-eval/Makefile
index 71442f1dc6ab..405e3c11e406 100644
--- a/games/poker-eval/Makefile
+++ b/games/poker-eval/Makefile
@@ -15,7 +15,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:E}.0
MAINTAINER= ijliao@FreeBSD.org
COMMENT= A C library to evaluate poker hands
-USE_GETOPT_LONG= yes
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= MD5SUM=${MD5}
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index f6f1a41f4b73..f64aa1870b39 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -23,7 +23,6 @@ USE_X_PREFIX= yes
USE_GNOME= gnometarget gtk20
USE_GCC= 3.4+
USE_PERL5= yes
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/games/sarien/Makefile b/games/sarien/Makefile
index 9e2896166739..846b58937ca4 100644
--- a/games/sarien/Makefile
+++ b/games/sarien/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Sierra AGI games interpreter
GNU_CONFIGURE= yes
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
USE_XLIB= yes
diff --git a/games/tmw/Makefile b/games/tmw/Makefile
index 8eb6ae217692..18b4f97bfc3f 100644
--- a/games/tmw/Makefile
+++ b/games/tmw/Makefile
@@ -27,7 +27,6 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_SDL= sdl image mixer net
USE_GCC= 3.2+
-USE_GETOPT_LONG=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `${SDL_CONFIG} --cflags` -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
diff --git a/games/trackballs/Makefile b/games/trackballs/Makefile
index 26075672d08a..e18a0c9ccfab 100644
--- a/games/trackballs/Makefile
+++ b/games/trackballs/Makefile
@@ -22,7 +22,6 @@ USE_X_PREFIX= yes
USE_GL= yes
USE_SDL= image mixer sdl ttf
USE_GETTEXT= yes
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/games/wmpuzzle/Makefile b/games/wmpuzzle/Makefile
index ba9fbbd46961..6aeac4b9f526 100644
--- a/games/wmpuzzle/Makefile
+++ b/games/wmpuzzle/Makefile
@@ -18,7 +18,6 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_X_PREFIX= yes
USE_XPM= yes
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/games/xqf/Makefile b/games/xqf/Makefile
index 3c43151af3bf..3b6aa207c2ca 100644
--- a/games/xqf/Makefile
+++ b/games/xqf/Makefile
@@ -19,7 +19,6 @@ RUN_DEPENDS= qstat:${PORTSDIR}/games/qstat
USE_XLIB= yes
USE_GNOME= intlhack
-USE_GETOPT_LONG= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes