aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-03 08:45:51 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-03 08:45:51 +0000
commit99ad9127356be7e975c6ea48d00fa2aba29468d7 (patch)
treebea626d8d7aaa3973f00760684b26d2ddcce74eb /games
parentce05caaae21cd6b880cf5567917d6bde1c9144fa (diff)
downloadports-99ad9127356be7e975c6ea48d00fa2aba29468d7.tar.gz
ports-99ad9127356be7e975c6ea48d00fa2aba29468d7.zip
- Convert to new perl framework
- Trim Makefile header
Notes
Notes: svn path=/head/; revision=324181
Diffstat (limited to 'games')
-rw-r--r--games/crossfire-server/Makefile2
-rw-r--r--games/rtb/Makefile8
-rw-r--r--games/scorched3d/Makefile9
-rw-r--r--games/tuxmath/Makefile3
-rw-r--r--games/tuxtype/Makefile9
-rw-r--r--games/xscorch/Makefile8
6 files changed, 10 insertions, 29 deletions
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index e317535c98fb..831b21006780 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -20,9 +20,9 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+USES= perl5
USE_XORG= ice sm x11 xaw xext xmu xpm xt
USE_SQLITE= 3
-USE_PERL5= yes
USE_PYTHON= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 9c25a0bf1099..7f371390ea23 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: RealTimeBattle
-# Date created: 30 June 2000
-# Whom: Dishanker Rajakulendren <draj@oceanfree.net>
-#
+# Created by: Dishanker Rajakulendren <draj@oceanfree.net>
# $FreeBSD$
-#
PORTNAME= RealTimeBattle
PORTVERSION= 1.0.8
@@ -17,9 +13,9 @@ COMMENT= Robot programming game for UNIX
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
+USES= perl5
USE_BZIP2= yes
USE_GNOME= gtk20
-USE_PERL5= yes
USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 00915fc5479f..54a9b9f0ef40 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -1,8 +1,4 @@
-#
-# Ports collection makefile for: scorched3d
-# Date created: Jan 5, 2003
-# Whom: mdodd
-#
+# Created by: mdodd
# $FreeBSD$
PORTNAME= scorched3d
@@ -34,8 +30,7 @@ USE_OPENAL= al alut
USE_SDL= mixer net sdl
USE_WX= 2.4+
WX_CONF_ARGS= absolute
-USE_PERL5= yes
-USES= iconv
+USES= iconv perl5
USE_GMAKE= yes
USE_AUTOTOOLS= aclocal automake autoconf
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
diff --git a/games/tuxmath/Makefile b/games/tuxmath/Makefile
index c0a0495f1a47..3f34fe46676f 100644
--- a/games/tuxmath/Makefile
+++ b/games/tuxmath/Makefile
@@ -23,8 +23,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_w_fonts-${PORTVERSION}
USE_GNOME= libxml2
USE_SDL= image mixer net pango sdl
-USE_PERL5= yes
-USES= iconv gmake
+USES= iconv gmake perl5
GNU_CONFIGURE= yes
CONFIGURE_ENV= T4K_COMMON_CFLAGS="-I${T4K_WRKSRC}/src" \
T4K_COMMON_LIBS="${T4K_WRKSRC}/src/.libs/libt4k_common.a" \
diff --git a/games/tuxtype/Makefile b/games/tuxtype/Makefile
index c4178274bb7a..9e1fbe387328 100644
--- a/games/tuxtype/Makefile
+++ b/games/tuxtype/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tuxtype
-# Date created: Mon Aug 6 21:53:03 EDT 2001
-# Whom: Patrick Li <pat@databits.net>
-#
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
-#
PORTNAME= tuxtype
PORTVERSION= 1.8.1
@@ -28,8 +24,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_w_fonts-${PORTVERSION}
USE_GNOME= libxml2
USE_SDL= image mixer net pango sdl
-USE_PERL5= yes
-USES= iconv
+USES= iconv perl5
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= T4K_COMMON_CFLAGS="-I${T4K_WRKSRC}/src" \
diff --git a/games/xscorch/Makefile b/games/xscorch/Makefile
index d87a85ac7554..4d21377d7d0a 100644
--- a/games/xscorch/Makefile
+++ b/games/xscorch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xscorch
-# Date created: 19 Apr 2000
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= xscorch
PORTVERSION= 0.2.1
@@ -20,8 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS_DEFINE= MIKMOD
OPTIONS_DEFAULT= MIKMOD
+USES= perl5
USE_GNOME= gtk20
-USE_PERL5= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes