aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-11-23 21:29:10 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-11-23 21:29:10 +0000
commit057bdccad34e63ae5e411ac6c2da98b6c87cb343 (patch)
treec9d86b4475afcdb76cfcecb2c5a8179effacf393 /games
parentbdc94e559ac4d4f91555c61b931444437c11a54f (diff)
downloadports-057bdccad34e63ae5e411ac6c2da98b6c87cb343.tar.gz
ports-057bdccad34e63ae5e411ac6c2da98b6c87cb343.zip
- Update to 0.9.8
- Remove master sites, use GitHub=yes - Take maintainership - Change comment - Use pkg-plist instead of PLIST_FILES - Change DOCS, changed by Upstream - Simplify ICONS installation handling - Fix symlink for the icon, which is needed that PySpaceWar works - Change pkg-descr
Notes
Notes: svn path=/head/; revision=373175
Diffstat (limited to 'games')
-rw-r--r--games/pyspacewar/Makefile45
-rw-r--r--games/pyspacewar/distinfo4
-rw-r--r--games/pyspacewar/pkg-descr13
-rw-r--r--games/pyspacewar/pkg-plist9
4 files changed, 38 insertions, 33 deletions
diff --git a/games/pyspacewar/Makefile b/games/pyspacewar/Makefile
index 9ffca64b7ce1..387e6b4dbd4c 100644
--- a/games/pyspacewar/Makefile
+++ b/games/pyspacewar/Makefile
@@ -2,53 +2,48 @@
# $FreeBSD$
PORTNAME= pyspacewar
-PORTVERSION= 0.9.7
-PORTREVISION= 4
+PORTVERSION= 0.9.8
CATEGORIES= games python
-MASTER_SITES= http://mg.pov.lt/${PORTNAME}/\
- LOCAL/beech
DIST_SUBDIR= python
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Two ships duel in a gravity field
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Game loosely based on the original Spacewar!
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GPL.txt
RUN_DEPENDS= ${PYGAME}
+USE_GITHUB= yes
+GH_ACCOUNT= mgedmin
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 2d058b1
+
USES= python
USE_PYTHON= distutils autoplist
-PLIST_FILES= share/icons/hicolor/16x16/apps/pyspacewar.png \
- share/icons/hicolor/22x22/apps/pyspacewar.png \
- share/icons/hicolor/32x32/apps/pyspacewar.png \
- share/icons/hicolor/48x48/apps/pyspacewar.png \
- share/pixmaps/${PORTNAME}.png
-
-PORTDOCS= NEWS.txt README.txt performance-notes.txt
+PORTDOCS= *.rst
OPTIONS_DEFINE= DOCS
INSTALLS_ICONS= yes
-ICON_SIZES= 16x16 22x22 32x32 48x48
DESKTOP_ENTRIES="PySpaceWar" "" ${PORTNAME} \
"${PORTNAME}" "Game;ArcadeGame;" ""
-post-patch:
-.for s in 16 22 32 48
- @cd ${WRKSRC}/src/pyspacewar/icons && \
- ${MV} ${PORTNAME}${s}.png ${PORTNAME}_${s}x${s}.png
-.endfor
-
post-install:
-.for s in ${ICON_SIZES}
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
- ${INSTALL_DATA} ${WRKSRC}/src/pyspacewar/icons/${PORTNAME}_${s}.png \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.for i in 16 22 32 48
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps
+ ${INSTALL_DATA} ${WRKSRC}/src/pyspacewar/icons/${PORTNAME}${i}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps/${PORTNAME}.png
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+ ${INSTALL_DATA} ${WRKSRC}/src/pyspacewar/icons/${PORTNAME}${i}.svg \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}${i}.svg
.endfor
+# Symlink icon which is needed that PySpaceWar works
+ @${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/icons
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/icons/${PORTNAME}48.png
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/games/pyspacewar/distinfo b/games/pyspacewar/distinfo
index 10ce47d7417a..4d9b77243609 100644
--- a/games/pyspacewar/distinfo
+++ b/games/pyspacewar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/pyspacewar-0.9.7.tar.gz) = 964d59ff8d42a6ba235ea1f616c576757ba3c232e349af78869e024b963c8b15
-SIZE (python/pyspacewar-0.9.7.tar.gz) = 229319
+SHA256 (python/pyspacewar-0.9.8.tar.gz) = 4d95e7101d14d7278183106e64160c2c314cbdb1eb4b86908b7c74dd3b9cc0f8
+SIZE (python/pyspacewar-0.9.8.tar.gz) = 226320
diff --git a/games/pyspacewar/pkg-descr b/games/pyspacewar/pkg-descr
index 451f930f5b4a..a8d9653a479c 100644
--- a/games/pyspacewar/pkg-descr
+++ b/games/pyspacewar/pkg-descr
@@ -1,11 +1,12 @@
PySpaceWar
-Two ships duel in a gravity field. Gravity doesn't affect the ships
-themselves (which have spanking new anti-gravity devices), but it affects
-missiles launced by the ships.
+Two ships duel in a gravity field. Gravity doesn't affect
+the ships themselves (which have spanking new anti-gravity
+devices), but it affects missiles launced by the ships.
-You can play against the computer, or two players can play with one keyboard.
-There is also a Gravity Wars mode, where the two ships do not move, and the
-players repeatedly specify the direction and velocity of their missiles.
+You can play against the computer, or two players can play
+with one keyboard. There is also a Gravity Wars mode, where
+the two ships do not move, and the players repeatedly
+specify the direction and velocity of their missiles.
WWW: http://mg.pov.lt/pyspacewar/
diff --git a/games/pyspacewar/pkg-plist b/games/pyspacewar/pkg-plist
new file mode 100644
index 000000000000..67d5892327ee
--- /dev/null
+++ b/games/pyspacewar/pkg-plist
@@ -0,0 +1,9 @@
+%%PYTHON_SITELIBDIR%%/pyspacewar/icons/pyspacewar48.png
+share/icons/hicolor/16x16/apps/pyspacewar.png
+share/icons/hicolor/22x22/apps/pyspacewar.png
+share/icons/hicolor/32x32/apps/pyspacewar.png
+share/icons/hicolor/48x48/apps/pyspacewar.png
+share/icons/hicolor/scalable/apps/pyspacewar16.svg
+share/icons/hicolor/scalable/apps/pyspacewar22.svg
+share/icons/hicolor/scalable/apps/pyspacewar32.svg
+share/icons/hicolor/scalable/apps/pyspacewar48.svg