aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2016-06-17 08:21:16 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2016-06-17 08:21:16 +0000
commit29eac2606ee2a3eb2245a8fb079491ed6ae5b0e5 (patch)
tree2bebfb087e290bb1a99bcee797e18c02677931d0 /games
parent9b7a7743459d797f02833b62f165eaa21439d457 (diff)
downloadports-29eac2606ee2a3eb2245a8fb079491ed6ae5b0e5.tar.gz
ports-29eac2606ee2a3eb2245a8fb079491ed6ae5b0e5.zip
games/imaze: unbreak and modernize port
This includes: - Bump PORTREVISION - Unbreak fetch - Remove TUCOWS from MASTER_SITES - Add ATHENA option and set it by default, instead of XVIEW - Convert GUI's options from RADIO to SINGLE - Switch to options helpers - Add MOTIFLIB define with proper value to fix linkage - Add xmu to USE_XORG - Regenerate patches PR: 210081 Submitted by: lightside <lightside@gmx.com> Approved by: junovitch (mentor)
Notes
Notes: svn path=/head/; revision=417000
Diffstat (limited to 'games')
-rw-r--r--games/imaze/Makefile49
-rw-r--r--games/imaze/files/patch-source_Makefile.in8
-rw-r--r--games/imaze/files/patch-source_configure6
-rw-r--r--games/imaze/files/patch-source_fbsd_joystick.c4
-rw-r--r--games/imaze/files/patch-source_voxware_audio.c4
5 files changed, 26 insertions, 45 deletions
diff --git a/games/imaze/Makefile b/games/imaze/Makefile
index 342cbff157ac..b5e0db74e14c 100644
--- a/games/imaze/Makefile
+++ b/games/imaze/Makefile
@@ -3,10 +3,9 @@
PORTNAME= imaze
PORTVERSION= 1.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
-MASTER_SITES= TUCOWS/x11/entertain/ \
- http://www.sourcefiles.org/Games/Arcade/
+MASTER_SITES= http://www.sourcefiles.org/Games/Arcade/
PKGNAMESUFFIX= -${TOOLKIT}
MAINTAINER= ports@FreeBSD.org
@@ -15,49 +14,31 @@ COMMENT= Multi-player network action game for TCP/IP with 3D graphics
LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/Copyright
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
OPTIONS_DEFINE= AUDIO JOYSTICK
-OPTIONS_RADIO= GUI
-OPTIONS_RADIO_GUI= XVIEW MOTIF
-OPTIONS_DEFAULT= AUDIO JOYSTICK XVIEW
+OPTIONS_SINGLE= GUI
+OPTIONS_SINGLE_GUI= ATHENA MOTIF XVIEW
+OPTIONS_DEFAULT= ATHENA AUDIO JOYSTICK
+
+ATHENA_DESC= Athena widget library support
+ATHENA_VARS= TOOLKIT=athena
AUDIO_DESC= Audio support
+AUDIO_CONFIGURE_OFF= noaudio
JOYSTICK_DESC= Joystick support
+JOYSTICK_CONFIGURE_OFF= nojoystick
+MOTIF_USES= motif
+MOTIF_VARS= MOTIFLIB="-L${LOCALBASE}/lib -lXm -lXt" TOOLKIT=motif
XVIEW_DESC= XView widget library support
+XVIEW_LIB_DEPENDS= libxview.so:x11-toolkits/xview
+XVIEW_VARS= TOOLKIT=xview
CONFIGURE_WRKSRC=${WRKSRC}/source
BUILD_WRKSRC= ${WRKSRC}/source
-USE_XORG= x11 xaw xt
+USE_XORG= x11 xaw xmu xt
HAS_CONFIGURE= yes
CONFIGURE_ARGS= ${TOOLKIT} X11Dir="${LOCALBASE}" CFlags="${CFLAGS}"
MAKE_ENV= SOUNDDIR="${DATADIR}/sounds"
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MAUDIO)
-CONFIGURE_ARGS+=noaudio
-.endif
-
-.if empty(PORT_OPTIONS:MJOYSTICK)
-CONFIGURE_ARGS+=nojoystick
-.endif
-
-.if empty(PORT_OPTIONS:MMOTIF) && empty(PORT_OPTIONS:MXVIEW)
-TOOLKIT= athena
-.endif
-
-.if ${PORT_OPTIONS:MMOTIF}
-USES+= motif
-TOOLKIT= motif
-.endif
-
-.if ${PORT_OPTIONS:MXVIEW}
-LIB_DEPENDS+= libxview.so:x11-toolkits/xview
-TOOLKIT= xview
-.endif
-
do-install:
.for i in genlab imaze imazesrv imazestat ninja xlabed
(cd ${WRKSRC}/source && ${INSTALL_PROGRAM} ${i} ${STAGEDIR}${PREFIX}/bin)
diff --git a/games/imaze/files/patch-source_Makefile.in b/games/imaze/files/patch-source_Makefile.in
index 32ae78816f9e..5af44a9f1a15 100644
--- a/games/imaze/files/patch-source_Makefile.in
+++ b/games/imaze/files/patch-source_Makefile.in
@@ -1,6 +1,6 @@
---- source/Makefile.in.orig Thu Dec 13 10:50:40 2001
-+++ source/Makefile.in Thu Dec 13 10:56:34 2001
-@@ -43,7 +43,7 @@
+--- source/Makefile.in.orig 2001-12-10 00:47:32 UTC
++++ source/Makefile.in
+@@ -43,7 +43,7 @@ Unconfigured:
@echo "run ./configure first, don't use this makefile"
#END configure output
@@ -9,7 +9,7 @@
#
# possible values:
#
-@@ -66,7 +66,7 @@
+@@ -66,7 +66,7 @@ INSTALL=install -s -m 755
X11Libs=-lX11
#AthenaLibs=-lXaw -lXt
AthenaLibs=-lXaw -lXt -lXmu
diff --git a/games/imaze/files/patch-source_configure b/games/imaze/files/patch-source_configure
index bc703800f073..336e8729e422 100644
--- a/games/imaze/files/patch-source_configure
+++ b/games/imaze/files/patch-source_configure
@@ -1,6 +1,6 @@
---- source/configure.orig Thu Jul 24 22:06:46 2003
-+++ source/configure Thu Jul 24 22:10:31 2003
-@@ -54,7 +54,7 @@
+--- source/configure.orig 2001-12-10 00:47:37 UTC
++++ source/configure
+@@ -54,7 +54,7 @@ LibpathTmpl=-L@
MakefileIn=Makefile.in
MakefileOut=Makefile
diff --git a/games/imaze/files/patch-source_fbsd_joystick.c b/games/imaze/files/patch-source_fbsd_joystick.c
index 8d1d16c38b7e..bf1d0fc9f75a 100644
--- a/games/imaze/files/patch-source_fbsd_joystick.c
+++ b/games/imaze/files/patch-source_fbsd_joystick.c
@@ -1,5 +1,5 @@
---- source/fbsd_joystick.c.orig Sat Jun 28 15:55:30 2003
-+++ source/fbsd_joystick.c Sat Jun 28 15:56:01 2003
+--- source/fbsd_joystick.c.orig 2001-12-10 00:47:38 UTC
++++ source/fbsd_joystick.c
@@ -44,7 +44,7 @@
#include <errno.h>
#include <fcntl.h>
diff --git a/games/imaze/files/patch-source_voxware_audio.c b/games/imaze/files/patch-source_voxware_audio.c
index 950aa60e85e4..832c4398dbff 100644
--- a/games/imaze/files/patch-source_voxware_audio.c
+++ b/games/imaze/files/patch-source_voxware_audio.c
@@ -1,5 +1,5 @@
---- source/voxware_audio.c.orig Sat Jun 28 15:55:41 2003
-+++ source/voxware_audio.c Sat Jun 28 15:56:08 2003
+--- source/voxware_audio.c.orig 2001-12-10 00:47:46 UTC
++++ source/voxware_audio.c
@@ -50,7 +50,7 @@
#ifdef linux
#include <linux/soundcard.h>