aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-01 02:10:10 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-01 02:10:10 +0000
commit38829c360249ca644d10110d424caaac5b835148 (patch)
treea4e69a8404929f769a67a70678b9310e345c4982 /games
parentf4947960cd616490494607cb5038faa53812b38e (diff)
downloadports-38829c360249ca644d10110d424caaac5b835148.tar.gz
ports-38829c360249ca644d10110d424caaac5b835148.zip
- New ports: games/ufoai games/ufoai-data
UFO ALIEN INVASION is a strategy game featuring tactical combat against hostile alien forces which are about to infiltrate earth at this very moment. You are in command of a small special unit which has been founded to face the alien strike force. To be successful on the long run, you will also have to have a research team study the aliens and their technologies in order to learn as much as possible about their technology, their goals and the aliens themselves. WWW: http://ufo.myexp.de/
Notes
Notes: svn path=/head/; revision=174210
Diffstat (limited to 'games')
-rw-r--r--games/Makefile2
-rw-r--r--games/ufoai-data/Makefile52
-rw-r--r--games/ufoai-data/distinfo3
-rw-r--r--games/ufoai-data/pkg-descr3
-rw-r--r--games/ufoai/Makefile111
-rw-r--r--games/ufoai/distinfo3
-rw-r--r--games/ufoai/files/patch-Makefile29
-rw-r--r--games/ufoai/files/run.sh.in4
-rw-r--r--games/ufoai/pkg-descr8
-rw-r--r--games/ufoai/pkg-plist64
10 files changed, 279 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 58832ea3aba2..5930258f3cec 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -715,6 +715,8 @@
SUBDIR += twitch
SUBDIR += typespeed
SUBDIR += tyrquake
+ SUBDIR += ufoai
+ SUBDIR += ufoai-data
SUBDIR += uhexen
SUBDIR += umark
SUBDIR += untahris
diff --git a/games/ufoai-data/Makefile b/games/ufoai-data/Makefile
new file mode 100644
index 000000000000..723314fac27f
--- /dev/null
+++ b/games/ufoai-data/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ufoai-data
+# Date created: 2006-09-03
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= data
+DISTVERSION= 2.0rc5
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX:S/-//}
+PKGNAMEPREFIX= ufoai-
+DISTNAME= ${PKGNAMEPREFIX}${DISTVERSION:S/r/-r/}-linux
+EXTRACT_SUFX= .run
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= UFO alien invasion data files
+
+NO_PACKAGE= Package will be 160MB, set FORCE_PACKAGE if you really want it
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST= ${WRKDIR}/pkg-plist
+DATADIR= share/${PKGNAMEPREFIX:S/-//}
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && \
+ ${TAIL} -c +9390 ${_DISTDIR}/${DISTFILES} | ${TAR} xf -
+ @cd ${WRKSRC} && \
+ ${TAR} -xjf ${PORTNAME}.tar.bz2
+
+post-patch:
+ @cd ${WRKSRC}/base && \
+ ${RM} -rf i18n game.so
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKDIR}/base && \
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${DATADIR}
+ cd ${WRKDIR}/base && \
+ ${FIND} * -type d -exec ${MKDIR} "${PREFIX}/${DATADIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${PREFIX}/${DATADIR}/{}" \;
+
+.include <bsd.port.mk>
diff --git a/games/ufoai-data/distinfo b/games/ufoai-data/distinfo
new file mode 100644
index 000000000000..afc5fbdd6164
--- /dev/null
+++ b/games/ufoai-data/distinfo
@@ -0,0 +1,3 @@
+MD5 (ufoai/ufoai-2.0-rc5-linux.run) = 694921d1643a7ddddbcce8bbf6281938
+SHA256 (ufoai/ufoai-2.0-rc5-linux.run) = 40b1c39cefabbd85b8ed7997f1b60285a364e9cee56631b7ada482c59fdb8c84
+SIZE (ufoai/ufoai-2.0-rc5-linux.run) = 170587309
diff --git a/games/ufoai-data/pkg-descr b/games/ufoai-data/pkg-descr
new file mode 100644
index 000000000000..a2c77b8d0789
--- /dev/null
+++ b/games/ufoai-data/pkg-descr
@@ -0,0 +1,3 @@
+UFO ALIEN INVASION data files.
+
+WWW: http://ufo.myexp.de/
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
new file mode 100644
index 000000000000..4e983b030162
--- /dev/null
+++ b/games/ufoai/Makefile
@@ -0,0 +1,111 @@
+# New ports collection makefile for: ufoai
+# Date created: 2006-09-03
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ufoai
+DISTVERSION= 2.0RC5
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME:S/$/-/}${DISTVERSION:S/R/-R/}-source
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= A strategy game featuring tactical combat
+
+LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/default.cfg:${PORTSDIR}/games/ufoai-data
+
+USE_BZIP2= yes
+USE_GL= yes
+USE_SDL= sdl ttf
+USE_GETTEXT= yes
+USE_GMAKE= yes
+
+DATADIR= share/${PORTNAME}
+UFO_DIR= ${PREFIX}/lib/${PORTNAME}
+UFO_LIBS= ref_glx ref_sdl snd_sdl ref_glx snd_oss game
+UFO_FILES= ufo
+
+OPTIONS= SERVER "Install dedicated server" on \
+ UFO2MAP "Install UFO tools" on \
+ ARTS "Support for arts sound system" off \
+ IPV6 "Support for ipv6" off
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not build on FreeBSD 4.x
+.endif
+
+.if !defined(WITHOUT_SERVER)
+HAVE_SERVER= true
+MAKE_ENV+= BUILD_DEDICATED="YES"
+UFO_FILES+= ufoded
+PLIST_SUB+= SERVER=""
+.else
+MAKE_ENV+= BUILD_DEDICATED="NO"
+PLIST_SUB+= SERVER="@comment "
+.endif
+
+.if !defined(WITHOUT_UFO2MAP)
+HAVE_UFO2MAP= true
+MAKE_ENV+= BUILD_COMPILETOOLS="YES"
+UFO_FILES+= ufo2map
+PLIST_SUB+= UFO2MAP=""
+.else
+MAKE_ENV+= BUILD_COMPILETOOLS="NO"
+PLIST_SUB+= UFO2MAP="@comment "
+.endif
+
+.if defined(WITH_ARTS)
+HAVE_ARTS= true
+LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
+MAKE_ENV+= BUILD_ARTS="YES"
+.else
+MAKE_ENV+= BUILD_ARTS="NO"
+.endif
+
+.if defined(WITH_IPV6)
+HAVE_IPV6= true
+MAKE_ENV+= HAVE_IPV6="YES"
+.else
+MAKE_ENV+= HAVE_IPV6="NO"
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|^BUILD_ARTS=|BUILD_ARTS?=|g" -e \
+ "s|^BUILD_DEDICATED=|BUILD_DEDICATED?=|g" -e \
+ "s|^BUILD_COMPILETOOLS=|BUILD_COMPILETOOLS?=|g" -e \
+ "s|^HAVE_IPV6=|HAVE_IPV6?=|g" ${WRKSRC}/Makefile
+
+pre-install:
+. for FILE in ${UFO_FILES}
+ @${ECHO} "#!/bin/sh" > ${WRKDIR}/${FILE}
+ @${ECHO} "cd ${PREFIX}/${DATADIR} || exit 1 " >> ${WRKDIR}/${FILE}
+ @${ECHO} "exec ${PREFIX}/${DATADIR}/${FILE} \"$$@\"" >> ${WRKDIR}/${FILE}
+. endfor
+
+do-install:
+ @${MKDIR} ${UFO_DIR}/base/i18n
+. for FILE in ${UFO_FILES}
+ @${SED} \
+ -e 's|@UFODIR@|${UFO_DIR}|' \
+ -e 's|@APP@|${FILE}|' \
+ ${FILESDIR}/run.sh.in > ${WRKDIR}/${FILE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/release${ARCH}/${FILE} ${UFO_DIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${FILE} ${PREFIX}/bin
+. endfor
+. for FILE in ${UFO_LIBS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/release${ARCH}/${FILE}.so ${UFO_DIR}
+. endfor
+
+ @cd ${WRKSRC}/base/i18n && \
+ ${FIND} * -type d -exec ${MKDIR} "${UFO_DIR}/base/i18n/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${UFO_DIR}/base/i18n/{}" \;
+ ${LN} -s ${PREFIX}/${DATADIR}/* ${UFO_DIR}/base
+
+.include <bsd.port.post.mk>
diff --git a/games/ufoai/distinfo b/games/ufoai/distinfo
new file mode 100644
index 000000000000..5adfd025e748
--- /dev/null
+++ b/games/ufoai/distinfo
@@ -0,0 +1,3 @@
+MD5 (ufoai/ufoai-2.0-RC5-source.tar.bz2) = ac5642370d419d73af0076ad7172c363
+SHA256 (ufoai/ufoai-2.0-RC5-source.tar.bz2) = bf7b74bfec193183f4a2b03d2f22eefd27a7ba243c840c8003c83a34e8ad9361
+SIZE (ufoai/ufoai-2.0-RC5-source.tar.bz2) = 3163820
diff --git a/games/ufoai/files/patch-Makefile b/games/ufoai/files/patch-Makefile
new file mode 100644
index 000000000000..18b837d7eb6a
--- /dev/null
+++ b/games/ufoai/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile Sat Sep 30 13:30:44 2006
++++ Makefile Sat Sep 30 20:44:26 2006
+@@ -346,6 +346,15 @@
+ endif
+ endif # ARCH i386
+
++ifeq ($(ARCH),amd64)
++ ifeq ($(strip $(BUILD_GLX)),YES)
++ TARGETS += $(BUILDDIR)/ref_glx.$(SHLIBEXT)
++ endif
++ ifeq ($(strip $(BUILD_SDLUFO)),YES)
++ TARGETS += $(BUILDDIR)/ref_sdl.$(SHLIBEXT)
++ endif
++endif # ARCH FreeBSD/amd64
++
+ ifeq ($(strip $(BUILD_COMPILETOOLS)),YES)
+ TARGETS += $(BUILDDIR)/ufo2map
+ endif
+@@ -1326,8 +1335,8 @@
+ for po in $$pofiles; do \
+ po=`basename $$po`; \
+ dir=`echo $$po | sed -e 's,\.po,,'`; \
+- mkdir -p ../base/i18n/$$dir/LC_MESSAGES; \
+- msgfmt -v -o ../base/i18n/$$dir/LC_MESSAGES/ufoai.mo po/$$po; \
++ mkdir -p base/i18n/$$dir/LC_MESSAGES; \
++ msgfmt -v -o base/i18n/$$dir/LC_MESSAGES/ufoai.mo po/$$po; \
+ done
+
+ docs:
diff --git a/games/ufoai/files/run.sh.in b/games/ufoai/files/run.sh.in
new file mode 100644
index 000000000000..ff18dab0ed1c
--- /dev/null
+++ b/games/ufoai/files/run.sh.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd @UFODIR@ || exit 1
+exec @UFODIR@/@APP@ "$@"
diff --git a/games/ufoai/pkg-descr b/games/ufoai/pkg-descr
new file mode 100644
index 000000000000..0708d72fae27
--- /dev/null
+++ b/games/ufoai/pkg-descr
@@ -0,0 +1,8 @@
+UFO ALIEN INVASION is a strategy game featuring tactical combat against hostile
+alien forces which are about to infiltrate earth at this very moment. You are
+in command of a small special unit which has been founded to face the alien
+strike force. To be successful on the long run, you will also have to have a
+research team study the aliens and their technologies in order to learn as much
+as possible about their technology, their goals and the aliens themselves.
+
+WWW: http://ufo.myexp.de/
diff --git a/games/ufoai/pkg-plist b/games/ufoai/pkg-plist
new file mode 100644
index 000000000000..9f42f57a0a44
--- /dev/null
+++ b/games/ufoai/pkg-plist
@@ -0,0 +1,64 @@
+bin/ufo
+%%SERVER%%bin/ufoded
+%%UFO2MAP%%bin/ufo2map
+lib/ufoai/base/autoexec.cfg
+lib/ufoai/base/dedicated.cfg
+lib/ufoai/base/default.cfg
+lib/ufoai/base/keys.cfg
+lib/ufoai/base/maps
+lib/ufoai/base/mapshots.cfg
+lib/ufoai/base/media
+lib/ufoai/base/models
+lib/ufoai/base/music
+lib/ufoai/base/pics
+lib/ufoai/base/shaders
+lib/ufoai/base/sound
+lib/ufoai/base/textures
+lib/ufoai/base/ufos
+lib/ufoai/base/i18n/cs/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/da/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/de/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/en/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/es/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/est/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/fr/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/it/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/pl/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/pt_BR/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/ru/LC_MESSAGES/ufoai.mo
+lib/ufoai/base/i18n/slo/LC_MESSAGES/ufoai.mo
+lib/ufoai/ufo
+%%SERVER%%lib/ufoai/ufoded
+%%UFO2MAP%%lib/ufoai/ufo2map
+lib/ufoai/ref_glx.so
+lib/ufoai/ref_sdl.so
+lib/ufoai/snd_sdl.so
+lib/ufoai/snd_oss.so
+lib/ufoai/game.so
+@dirrm lib/ufoai/base/i18n/slo/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/slo
+@dirrm lib/ufoai/base/i18n/ru/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/ru
+@dirrm lib/ufoai/base/i18n/pt_BR/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/pt_BR
+@dirrm lib/ufoai/base/i18n/pl/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/pl
+@dirrm lib/ufoai/base/i18n/it/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/it
+@dirrm lib/ufoai/base/i18n/fr/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/fr
+@dirrm lib/ufoai/base/i18n/est/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/est
+@dirrm lib/ufoai/base/i18n/es/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/es
+@dirrm lib/ufoai/base/i18n/en/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/en
+@dirrm lib/ufoai/base/i18n/de/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/de
+@dirrm lib/ufoai/base/i18n/da/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/da
+@dirrm lib/ufoai/base/i18n/cs/LC_MESSAGES
+@dirrm lib/ufoai/base/i18n/cs
+@dirrm lib/ufoai/base/i18n
+@dirrm lib/ufoai/base
+@dirrm lib/ufoai