aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:19:34 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:19:34 +0000
commit849f4a2e3c2546397ce3d49348d2f6bd35c99382 (patch)
treea42c491e321c8d4b5d6a255023b1bd604014453b /games
parent60df7f192397be3104d79569b1fc46d4562ffa8c (diff)
downloadports-849f4a2e3c2546397ce3d49348d2f6bd35c99382.tar.gz
ports-849f4a2e3c2546397ce3d49348d2f6bd35c99382.zip
Tycho is a program to gather data on Core War warriors. Tycho takes a list of
warriors and fights each against the other. Execution logs of each instruction executed are recorded for all fights. It prints a report in HTML format. WWW: http://redcoder.sourceforge.net/?p=tycho
Notes
Notes: svn path=/head/; revision=206428
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/tycho/Makefile29
-rw-r--r--games/tycho/distinfo3
-rw-r--r--games/tycho/files/patch-Makefile12
-rw-r--r--games/tycho/pkg-descr5
5 files changed, 50 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index d2083df5b79c..dc766e596fc7 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -787,6 +787,7 @@
SUBDIR += tuxtype
SUBDIR += tvp
SUBDIR += twitch
+ SUBDIR += tycho
SUBDIR += typespeed
SUBDIR += tyrquake
SUBDIR += ufoai
diff --git a/games/tycho/Makefile b/games/tycho/Makefile
new file mode 100644
index 000000000000..c880e6719d34
--- /dev/null
+++ b/games/tycho/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: tycho
+# Date created: 2008-01-16
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= tycho
+PORTVERSION= 0.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= alepulver
+DISTNAME= redcoder
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Program to gather data (statistics) on Core War warriors
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/tycho \
+ bin/tycho-exstat
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/exstat ${PREFIX}/bin/${PORTNAME}-exstat
+
+.include <bsd.port.mk>
diff --git a/games/tycho/distinfo b/games/tycho/distinfo
new file mode 100644
index 000000000000..89a9e6c3ec9f
--- /dev/null
+++ b/games/tycho/distinfo
@@ -0,0 +1,3 @@
+MD5 (redcoder.tar.bz2) = a3a083413ba8d614f0615e4f4fa2797f
+SHA256 (redcoder.tar.bz2) = d1cbae5ff55e5e9f7ed31b1eea0644ee1a008db5c0c0cf090fcaca30be7528a1
+SIZE (redcoder.tar.bz2) = 153446
diff --git a/games/tycho/files/patch-Makefile b/games/tycho/files/patch-Makefile
new file mode 100644
index 000000000000..ca9defdd35d0
--- /dev/null
+++ b/games/tycho/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- ./Makefile.orig Thu Sep 4 12:44:24 2003
++++ ./Makefile Wed Jan 16 19:36:13 2008
+@@ -1,7 +1,7 @@
+ # $Id: Makefile,v 1.3 2003/09/04 15:44:24 varfar Exp $
+
+-CC = gcc
+-CFLAGS = ${OPT} ${DBG} -DSIM_STRIP_FLAGS=1
++CC ?= gcc
++CFLAGS += ${OPT} ${DBG} -DSIM_STRIP_FLAGS=1
+ OPT = -O4 -fomit-frame-pointer
+ #DBG = -g -DDEBUG=2
+
diff --git a/games/tycho/pkg-descr b/games/tycho/pkg-descr
new file mode 100644
index 000000000000..b268a6ddceb8
--- /dev/null
+++ b/games/tycho/pkg-descr
@@ -0,0 +1,5 @@
+Tycho is a program to gather data on Core War warriors. Tycho takes a list of
+warriors and fights each against the other. Execution logs of each instruction
+executed are recorded for all fights. It prints a report in HTML format.
+
+WWW: http://redcoder.sourceforge.net/?p=tycho