aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2016-06-27 20:02:47 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2016-06-27 20:02:47 +0000
commitccd155e5398e97f861d26324b88797181bf21243 (patch)
treeff53bc700c55171c95a30c7a90c90e14452b60b8 /games
parent5af876fe2f48b2c6b8272ce39fe3e5c338f7ef33 (diff)
downloadports-ccd155e5398e97f861d26324b88797181bf21243.tar.gz
ports-ccd155e5398e97f861d26324b88797181bf21243.zip
games/tuxpuck: unbreak fetch
Additional changes: - Bump PORTREVISION - Add audio/libogg to library dependency - Regenerate patches PR: 210082 Approved by: junovitch (mentor)
Notes
Notes: svn path=/head/; revision=417682
Diffstat (limited to 'games')
-rw-r--r--games/tuxpuck/Makefile6
-rw-r--r--games/tuxpuck/files/patch-Makefile6
-rw-r--r--games/tuxpuck/files/patch-tuxpuck.c6
3 files changed, 8 insertions, 10 deletions
diff --git a/games/tuxpuck/Makefile b/games/tuxpuck/Makefile
index 234a10d6654c..fb23f8753d3f 100644
--- a/games/tuxpuck/Makefile
+++ b/games/tuxpuck/Makefile
@@ -3,19 +3,17 @@
PORTNAME= tuxpuck
PORTVERSION= 0.8.2
-PORTREVISION= 22
+PORTREVISION= 23
CATEGORIES= games
MASTER_SITES= http://www.sourcefiles.org/Games/Sports/Miscellaneous/
MAINTAINER= ports@FreeBSD.org
COMMENT= Shufflepuck Cafe Clone
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png \
+ libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \
libfreetype.so:print/freetype2
diff --git a/games/tuxpuck/files/patch-Makefile b/games/tuxpuck/files/patch-Makefile
index eb55122f1751..298911491ce2 100644
--- a/games/tuxpuck/files/patch-Makefile
+++ b/games/tuxpuck/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2002-11-08 19:50:29.000000000 +0900
-+++ Makefile 2011-08-24 01:44:15.000000000 +0900
+--- Makefile.orig 2002-11-08 10:50:29 UTC
++++ Makefile
@@ -1,8 +1,8 @@
# Makefile for TuxPuck , Copyright Jacob Kroon 2001-2002
NAME = tuxpuck
@@ -11,7 +11,7 @@
CSOURCES = tuxpuck.c video.c audio.c menu.c sprite.c font.c timer.c \
board.c entity.c glass.c scoreboard.c player.c zoom.c png.c \
jpg.c intro.c tux.c arcana.c
-@@ -17,11 +17,11 @@
+@@ -17,11 +17,11 @@ ifdef COMSPEC
endif
%.o : %.c
diff --git a/games/tuxpuck/files/patch-tuxpuck.c b/games/tuxpuck/files/patch-tuxpuck.c
index ca26c8ca23b0..c5873a85bff6 100644
--- a/games/tuxpuck/files/patch-tuxpuck.c
+++ b/games/tuxpuck/files/patch-tuxpuck.c
@@ -1,6 +1,6 @@
---- tuxpuck.c.orig Thu Apr 25 23:24:18 2002
-+++ tuxpuck.c Thu Apr 25 23:24:39 2002
-@@ -40,7 +40,7 @@
+--- tuxpuck.c.orig 2002-11-08 10:50:29 UTC
++++ tuxpuck.c
+@@ -17,7 +17,7 @@
#endif
/* externals */