aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-05-04 16:26:51 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-05-04 16:26:51 +0000
commitaed3d79a30560b8dab14fe105fa9a067605e8fbc (patch)
tree160efbeb58f9455927c4acfb3d0d00a97c483b37 /games
parent9b7aa656043df1aa1e626e1bd95d0c30636e3527 (diff)
downloadports-aed3d79a30560b8dab14fe105fa9a067605e8fbc.tar.gz
ports-aed3d79a30560b8dab14fe105fa9a067605e8fbc.zip
PR: ports/11482
Submitted by: andy@icc.surw.chel.su simple biorythm calculation program
Notes
Notes: svn path=/head/; revision=18469
Diffstat (limited to 'games')
-rw-r--r--games/biorythm/Makefile36
-rw-r--r--games/biorythm/distinfo1
-rw-r--r--games/biorythm/files/patch-aa28
-rw-r--r--games/biorythm/pkg-comment1
-rw-r--r--games/biorythm/pkg-descr15
-rw-r--r--games/biorythm/pkg-plist5
6 files changed, 86 insertions, 0 deletions
diff --git a/games/biorythm/Makefile b/games/biorythm/Makefile
new file mode 100644
index 000000000000..219f5a412fdf
--- /dev/null
+++ b/games/biorythm/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: biorythm
+# Version required: 1.1.1
+# Date created: 4 May 1999
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= biorythm-1.1.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ http://home.sol.no/~sverrehu/pub-unix/files/
+MASTER_SITE_SUBDIR= games/amusements
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= shhmsg.1:${PORTSDIR}/devel/libshhmsg \
+ shhopt.1:${PORTSDIR}/devel/libshhopt
+
+USE_GMAKE= yes
+
+MAN6= biorythm.6
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/biorythm ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/biorythm.6 ${PREFIX}/man/man6
+
+post-install:
+.if !defined (NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/biorythm
+.for file in CREDITS ChangeLog README
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/biorythm
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/biorythm/distinfo b/games/biorythm/distinfo
new file mode 100644
index 000000000000..20b033d67a88
--- /dev/null
+++ b/games/biorythm/distinfo
@@ -0,0 +1 @@
+MD5 (biorythm-1.1.1.tar.gz) = 0c304a6c37d56cb2d3c11e77225745b5
diff --git a/games/biorythm/files/patch-aa b/games/biorythm/files/patch-aa
new file mode 100644
index 000000000000..dc818b4b8fb2
--- /dev/null
+++ b/games/biorythm/files/patch-aa
@@ -0,0 +1,28 @@
+--- Makefile Sun Jul 5 19:55:11 1998
++++ /home/andy/tmp/wrk/Makefile Tue May 4 10:55:11 1999
+@@ -11,10 +11,10 @@
+ ###########################################################################
+
+ # where are shhmsg and shhopt?
+-INCDIR = -I/usr/local/include
+-LIBDIR = -L/usr/local/lib
++INCDIR = -I$(LOCALBASE)/include
++LIBDIR = -L$(LOCALBASE)/lib
+
+-INSTBASEDIR = /usr/local
++INSTBASEDIR = $(PREFIX)
+ INSTBINDIR = $(INSTBASEDIR)/games
+ INSTMANDIR = $(INSTBASEDIR)/man/man6
+ INSTALL = install -m 644
+@@ -27,9 +27,9 @@
+
+ ###########################################################################
+
+-CC = gcc
++#CC = gcc
+
+-OPTIM = -O2
++OPTIM = $(CFLAGS)
+ CCOPT = -Wall $(OPTIM) $(INCDIR) $(DEFINES) $(CFLAGS)
+ LDOPT = -s $(LIBDIR) $(LDFLAGS)
+
diff --git a/games/biorythm/pkg-comment b/games/biorythm/pkg-comment
new file mode 100644
index 000000000000..8150895a0d64
--- /dev/null
+++ b/games/biorythm/pkg-comment
@@ -0,0 +1 @@
+simple biorythm calculation program
diff --git a/games/biorythm/pkg-descr b/games/biorythm/pkg-descr
new file mode 100644
index 000000000000..5fb94d9ee9e3
--- /dev/null
+++ b/games/biorythm/pkg-descr
@@ -0,0 +1,15 @@
+This program calculates a simple biorythm plot based on the given date
+of birth. The plot starts at the given first day of plot, and includes
+the number of days indicated on the command line.
+
+Dates must be entered according to ISO date format, that is:
+YYYY-MM-DD, four digit year, two digit month, and two digit day of
+month.
+
+The default plot includes emotional, intellectual and physical
+curves. This may be overridden by command line options.
+
+The author has no idea how to interpret the plot, so please don't ask
+him about it.
+
+WWW: http://home.sol.no/~sverrehu/pub-unix/
diff --git a/games/biorythm/pkg-plist b/games/biorythm/pkg-plist
new file mode 100644
index 000000000000..d20fc31815a5
--- /dev/null
+++ b/games/biorythm/pkg-plist
@@ -0,0 +1,5 @@
+bin/biorythm
+share/doc/biorythm/CREDITS
+share/doc/biorythm/ChangeLog
+share/doc/biorythm/README
+@dirrm share/doc/biorythm