aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>1999-04-13 09:46:50 +0000
committerJustin M. Seger <jseger@FreeBSD.org>1999-04-13 09:46:50 +0000
commit19d90672c31b1d327d68768c6df13ccc772383e5 (patch)
treeb8e893a647390b0e9786d29a7da3c47fa132f9d2 /games
parent0d5f5eb7dc3a4127de9e2dab5093c6cb5c00e5fb (diff)
downloadports-19d90672c31b1d327d68768c6df13ccc772383e5.tar.gz
ports-19d90672c31b1d327d68768c6df13ccc772383e5.zip
Import of drm 1.0
This is very simple tetris-like game. You kill "bugs" by dropping the right combination of blocks on them. PR: ports/7701 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=17830
Diffstat (limited to 'games')
-rw-r--r--games/drm/Makefile26
-rw-r--r--games/drm/distinfo1
-rw-r--r--games/drm/files/patch-aa24
-rw-r--r--games/drm/pkg-comment1
-rw-r--r--games/drm/pkg-descr2
-rw-r--r--games/drm/pkg-plist2
6 files changed, 56 insertions, 0 deletions
diff --git a/games/drm/Makefile b/games/drm/Makefile
new file mode 100644
index 000000000000..973f55d5c8d9
--- /dev/null
+++ b/games/drm/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: drm
+# Version required: 1.0
+# Date created: 4 August 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= dr_mario
+PKGNAME= drm-1.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= games/arcade
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= andy@icc.surw.chel.su
+
+ALL_TARGET=
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bugs ${PREFIX}/bin/drm
+.if !defined(NOPORTDOCS)
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/README.drm
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/drm/distinfo b/games/drm/distinfo
new file mode 100644
index 000000000000..c3801b4f9ef8
--- /dev/null
+++ b/games/drm/distinfo
@@ -0,0 +1 @@
+MD5 (dr_mario.tar.Z) = e7ac666a8291fb60dcd8095afa1733fa
diff --git a/games/drm/files/patch-aa b/games/drm/files/patch-aa
new file mode 100644
index 000000000000..282df431c488
--- /dev/null
+++ b/games/drm/files/patch-aa
@@ -0,0 +1,24 @@
+--- Makefile Tue Jun 16 03:13:11 1992
++++ /home/andy/tmp/wrk/Makefile Tue Aug 4 17:02:23 1998
+@@ -1,17 +1,17 @@
+ #makefile for BUGS I - SRN 7/12/91
+ # modified for Linux on 6/15/92 Ken Corey
+
+-CC= gcc
+-CFLAGS= -O3
++#CC= gcc
++#CFLAGS= -O3
+ OBJS= main.o startup.o loop.o meat.o
+
+ #bugs : & $(OBJS)
+ bugs : $(OBJS)
+ #use above line if parallel processing is not supported
+- ${CC} ${CFLAGS} -o bugs $(OBJS) -lcurses -ltermcap
++ ${CC} ${CFLAGS} -o bugs $(OBJS) -lcurses
+
+ main.o: main.c info.h
+- ${CC} ${CFLAGS} -DLINUX -o main.o main.c
++ ${CC} ${CFLAGS} -o main.o -c main.c
+
+ $(OBJS): info.h
+
diff --git a/games/drm/pkg-comment b/games/drm/pkg-comment
new file mode 100644
index 000000000000..f413471435a3
--- /dev/null
+++ b/games/drm/pkg-comment
@@ -0,0 +1 @@
+Very simple tetris-style game.
diff --git a/games/drm/pkg-descr b/games/drm/pkg-descr
new file mode 100644
index 000000000000..2566c9666d67
--- /dev/null
+++ b/games/drm/pkg-descr
@@ -0,0 +1,2 @@
+This is very simple tetris-like game. You kill "bugs" by dropping the
+right combination of blocks on them.
diff --git a/games/drm/pkg-plist b/games/drm/pkg-plist
new file mode 100644
index 000000000000..ca1e114040cf
--- /dev/null
+++ b/games/drm/pkg-plist
@@ -0,0 +1,2 @@
+bin/drm
+share/doc/README.drm