aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>1999-04-22 07:44:43 +0000
committerMichael Haro <mharo@FreeBSD.org>1999-04-22 07:44:43 +0000
commit41ad471fdfe9793de66c24477ba3680a12e9435f (patch)
tree56492f3826a6030a31cf656a80d47cb92a9b97ec /games
parentcde1fdd3890638f5eb5a0bbf4e2264304ee897b1 (diff)
downloadports-41ad471fdfe9793de66c24477ba3680a12e9435f.tar.gz
ports-41ad471fdfe9793de66c24477ba3680a12e9435f.zip
Update to 0.6 and mark as broken
Notes
Notes: svn path=/head/; revision=18074
Diffstat (limited to 'games')
-rw-r--r--games/block/Makefile12
-rw-r--r--games/block/distinfo2
-rw-r--r--games/block/files/patch-ab121
-rw-r--r--games/block/pkg-descr4
-rw-r--r--games/block/pkg-plist10
5 files changed, 82 insertions, 67 deletions
diff --git a/games/block/Makefile b/games/block/Makefile
index 25c531e824ed..04edc5a8432c 100644
--- a/games/block/Makefile
+++ b/games/block/Makefile
@@ -1,18 +1,20 @@
# New ports collection makefile for: block
-# Version required: 0.5
+# Version required: 0.5
# Date created: 10 May 1997
# Whom: Andrey Zakhvatov
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/05/21 03:34:47 asami Exp $
#
-DISTNAME= block-0.5
+DISTNAME= block-0.6
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/strategy
+EXTRACT_SUFX= .tgz
MAINTAINER= andy@icc.surw.chel.su
+BROKEN= "Segmentation fault (core dumped)"
WRKSRC= ${WRKDIR}/blocks
MAKEFILE= makefile
ALL_TARGET= block bed
@@ -28,8 +30,8 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/block.6 ${PREFIX}/man/man6
${INSTALL_MAN} ${WRKSRC}/bed.6 ${PREFIX}/man/man6
${MKDIR} ${PREFIX}/share/block
-.for file in another complex default pyramid
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/block/${file}.block
+.for file in 1 2 3 4 5 6
+ ${INSTALL_DATA} ${WRKSRC}/${file}.block ${PREFIX}/share/block/${file}.block
.endfor
.include <bsd.port.mk>
diff --git a/games/block/distinfo b/games/block/distinfo
index 8fa96414f74b..c60355915670 100644
--- a/games/block/distinfo
+++ b/games/block/distinfo
@@ -1 +1 @@
-MD5 (block-0.5.tar.gz) = c7a1e75e0f00d2cc5909460e6fb574ff
+MD5 (block-0.6.tgz) = b3ade7433427903512a3e1aae899bcd2
diff --git a/games/block/files/patch-ab b/games/block/files/patch-ab
index 2496d7e70910..8eb8c08b1f96 100644
--- a/games/block/files/patch-ab
+++ b/games/block/files/patch-ab
@@ -1,53 +1,68 @@
-*** block.c Mon Nov 20 19:02:24 1995
---- /home/andy/tmp/wrk/block.c Sat May 10 22:57:08 1997
-***************
-*** 31,37 ****
- #define FF_HOME 4
- #define FF_OVEN 5
-
-! #define DEFGAME "/usr/games/lib/default.block"
-
- /* uncomment if you like lots of diagnostic garbage */
- /* #define DEBUG 1 */
---- 31,37 ----
- #define FF_HOME 4
- #define FF_OVEN 5
-
-! #define DEFGAME PREFIX "/share/block/default.block"
-
- /* uncomment if you like lots of diagnostic garbage */
- /* #define DEBUG 1 */
-***************
-*** 140,146 ****
- break;
- case 1 :
- case 2 : printf("Hmmm... trouble reading file %s\n",lname);
-! sprintf(tmp,"/usr/games/lib/%s.block",lname);
- if(loadnext(&cw,tmp)){
- printf("Could not read %s either\n",tmp);
- if(loadnext(&cw,"default")){
---- 140,146 ----
- break;
- case 1 :
- case 2 : printf("Hmmm... trouble reading file %s\n",lname);
-! sprintf(tmp, PREFIX "/share/block/%s.block",lname);
- if(loadnext(&cw,tmp)){
- printf("Could not read %s either\n",tmp);
- if(loadnext(&cw,"default")){
-***************
-*** 495,501 ****
- }
- /*Hope they come back again*/
-
-! sprintf(lname,"/usr/games/lib/%s.block",cw.fname);
- /* yuck - a messy kludge - the fname stores the name of the next game*/
- moves=0;
- if(looper)looper=2;
---- 495,501 ----
- }
- /*Hope they come back again*/
-
-! sprintf(lname,"/share/block/%s.block",cw.fname);
- /* yuck - a messy kludge - the fname stores the name of the next game*/
- moves=0;
- if(looper)looper=2;
+--- block.c.orig Wed Mar 24 01:39:36 1999
++++ block.c Sat Apr 10 09:57:16 1999
+@@ -32,7 +32,7 @@
+ #define FF_HOME 4
+ #define FF_OVEN 5
+
+-#define SCORE_FILE "/usr/games/lib/save/score"
++#define SCORE_FILE PREFIX "/share/block/save/score"
+ /* uncomment if you like lots of diagnostic garbage */
+ /* #define DEBUG 1 */
+
+@@ -93,16 +93,16 @@
+
+
+ username = (char *) getlogin();
+- sprintf(buf,"/usr/games/lib/save/%s",username);
++ sprintf(buf, PREFIX "/share/block/%s",username);
+ fp = fopen( buf , "rt");
+ if( fp != NULL ) {
+ fscanf(fp , "%d", &level);
+ fclose(fp);
+ }
+ if( level != 0 ) {
+- sprintf( buf , "/usr/games/lib/%d.block" , level);
++ sprintf( buf , PREFIX "/share/block/%d.block" , level);
+ } else {
+- sprintf( buf , "/usr/games/lib/1.block");
++ sprintf( buf , PREFIX "/share/block/1.block");
+ level=1;
+ }
+ strcpy(lname,buf);
+@@ -172,7 +172,7 @@
+ break;
+ case 1 :
+ case 2 : printf("Hmmm... trouble reading file %s\n",lname);
+- sprintf(tmp,"/usr/games/lib/%s.block",lname);
++ sprintf(tmp, PREFIX "/share/block/%s.block",lname);
+ if(loadnext(&cw,tmp)){
+ printf("Could not read %s either\n",tmp);
+ if(loadnext(&cw,"default")){
+@@ -539,7 +539,7 @@
+ printw( "\t\t %2d. %8s %4d %5ld %5ld\n", i+1, (char *)High[i].Name,High[i].Level,High[i].Score,High[i].Moves);
+ }
+ level++;
+- sprintf(buf,"/usr/games/lib/save/%s",username);
++ sprintf(buf,PREFIX "/share/block/save/%s",username);
+ fp = fopen(buf,"wt");
+ if( fp != NULL ) {
+ fprintf(fp , "%d", level);
+@@ -557,7 +557,7 @@
+ endwin();
+ /*Hope they come back again*/
+
+- sprintf(lname,"/usr/games/lib/%d.block",level);
++ sprintf(lname,PREFIX "/share/block/%d.block",level);
+ /* yuck - a messy kludge - the fname stores the name of the next game*/
+ moves=0;
+ if(looper)looper=2;
+@@ -756,7 +756,9 @@
+ High[j].Moves = High[j-1].Moves;
+ strncpy(High[j].Name,High[j-1].Name,10);
+ }
++ #if 0
+ cuserid((char *) High[i].Name);
++ #endif
+ High[i].Score = ThisScore;
+ High[i].Level = Level;
+ High[i].Moves = Moves;
diff --git a/games/block/pkg-descr b/games/block/pkg-descr
index 8c97c62e811f..cb05243bed1a 100644
--- a/games/block/pkg-descr
+++ b/games/block/pkg-descr
@@ -1,13 +1,10 @@
Blocks - a small tty based games using ncurses
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+
-
Written by marc welz (rather : kluged by marc welz) - Redistribution is
subject to the GNU public license.
-
Notes
-----
-
Good idea to restrict file names to 20 chars.
The editor tries to fill the entire screen - so if you write a level on
@@ -19,7 +16,6 @@ Notes
Thanks
------
-
A big THANK YOU goes to Joey Hess (jeh22@conell.edu) who contributed
the pyramid level, wrote the man pages for the game and pointed out a
couple of minor bugs.
diff --git a/games/block/pkg-plist b/games/block/pkg-plist
index fe2a8f987890..496c24472d6e 100644
--- a/games/block/pkg-plist
+++ b/games/block/pkg-plist
@@ -1,7 +1,9 @@
bin/block
bin/bed
-share/block/another.block
-share/block/complex.block
-share/block/default.block
-share/block/pyramid.block
+share/block/1.block
+share/block/2.block
+share/block/3.block
+share/block/4.block
+share/block/5.block
+share/block/6.block
@dirrm share/block