aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-05-01 02:02:41 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-05-01 02:02:41 +0000
commitb5c20cf4dcbf604acfed26056adfc31658cf1d60 (patch)
tree2d378abc7e2c4190b88686ee1660834541f21b5e /games
parent54a24d3747a97db636050154bf7265e8819fdf74 (diff)
downloadports-b5c20cf4dcbf604acfed26056adfc31658cf1d60.tar.gz
ports-b5c20cf4dcbf604acfed26056adfc31658cf1d60.zip
Solitaire card game for X Window System.
PR: 11379 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=18252
Diffstat (limited to 'games')
-rw-r--r--games/sol/Makefile40
-rw-r--r--games/sol/distinfo1
-rw-r--r--games/sol/files/patch-aa11
-rw-r--r--games/sol/pkg-comment1
-rw-r--r--games/sol/pkg-descr5
-rw-r--r--games/sol/pkg-plist15
6 files changed, 73 insertions, 0 deletions
diff --git a/games/sol/Makefile b/games/sol/Makefile
new file mode 100644
index 000000000000..afc491d57b46
--- /dev/null
+++ b/games/sol/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: sol
+# Version required: 1.0.6
+# Date created: 12 April 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= sol-1.0.6
+CATEGORIES= games
+MASTER_SITES= http://home.sol.no/~sverrehu/pub-unix/files/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
+ shhopt.1:${PORTSDIR}/devel/libshhopt \
+ shhmsg.1:${PORTSDIR}/devel/libshhmsg \
+ xalloc.1:${PORTSDIR}/devel/libxalloc \
+ shhcards.1:${PORTSDIR}/games/libshhcards
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+MAN6= sol.6
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/sol ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/sol
+ @ ${INSTALL_DATA} ${WRKSRC}/sol.score ${PREFIX}/share/sol
+ @ ${INSTALL_MAN} ${WRKSRC}/sol.6 ${PREFIX}/man/man6
+ @ ${MKDIR} ${PREFIX}/share/doc/sol
+ @ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/sol
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sol
+ @ chown games:games ${PREFIX}/bin/sol
+ @ chown games:games ${PREFIX}/share/sol/sol.score
+ @ chmod 6755 ${PREFIX}/bin/sol
+ @ chmod 770 ${PREFIX}/share/sol
+ @ chmod 660 ${PREFIX}/share/sol/sol.score
+
+.include <bsd.port.mk>
diff --git a/games/sol/distinfo b/games/sol/distinfo
new file mode 100644
index 000000000000..472b26ff0dfa
--- /dev/null
+++ b/games/sol/distinfo
@@ -0,0 +1 @@
+MD5 (sol-1.0.6.tar.gz) = cbc5c9091506646b9ce2c34674df0ce5
diff --git a/games/sol/files/patch-aa b/games/sol/files/patch-aa
new file mode 100644
index 000000000000..72e8fe34b763
--- /dev/null
+++ b/games/sol/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile Wed Aug 13 20:37:02 1997
++++ /home/andy/tmp/wrk/Makefile Sun Apr 12 19:14:29 1998
+@@ -62,7 +62,7 @@
+ ###########################################################################
+
+ # Where do you want to install the program and the highscore file?
+-INSTLIBDIR = /var/local/lib/games
++INSTLIBDIR = /usr/X11R6/share/sol
+ INSTBINDIR = /usr/local/games
+ INSTMANDIR = /usr/local/man/man6
+ #INSTLIBDIR = /hom/sverrehu/lib
diff --git a/games/sol/pkg-comment b/games/sol/pkg-comment
new file mode 100644
index 000000000000..4257bafd651c
--- /dev/null
+++ b/games/sol/pkg-comment
@@ -0,0 +1 @@
+Solitaire card game for X Window System.
diff --git a/games/sol/pkg-descr b/games/sol/pkg-descr
new file mode 100644
index 000000000000..834ba43def51
--- /dev/null
+++ b/games/sol/pkg-descr
@@ -0,0 +1,5 @@
+This is a Solitaire card game highly inspired by the one
+bundeled with a well known "operating system". Features
+a site-wide highscore table.
+
+http://home.sol.no/~sverrehu/pub-unix/html/sol.html
diff --git a/games/sol/pkg-plist b/games/sol/pkg-plist
new file mode 100644
index 000000000000..66fc984102b9
--- /dev/null
+++ b/games/sol/pkg-plist
@@ -0,0 +1,15 @@
+@owner games
+@group games
+@mode 6755
+bin/sol
+@owner
+@group
+@mode
+share/doc/sol/CREDITS
+share/doc/sol/README
+@owner games
+@group games
+@mode 660
+share/sol/sol.score
+@dirrm share/doc/sol
+@dirrm share/sol