aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-05-03 04:31:15 +0000
committerSteve Price <steve@FreeBSD.org>1999-05-03 04:31:15 +0000
commitd0f327b6c2de9013b815dadec8cdff08c4b1517b (patch)
tree63537c44bb90839d2dc6924b619fcf88c99f3716 /games
parentaf551dbbe5b0aa73f1910d9a4d90498e979d6109 (diff)
downloadports-d0f327b6c2de9013b815dadec8cdff08c4b1517b.tar.gz
ports-d0f327b6c2de9013b815dadec8cdff08c4b1517b.zip
Initial import of wmtictactoe version 0.4.
A dockable TicTacToe game for WindowMaker and AfterStep. PR: 11400 Submitted by: Jim Mock <jim@phrantic.phear.net>
Notes
Notes: svn path=/head/; revision=18413
Diffstat (limited to 'games')
-rw-r--r--games/wmtictactoe/Makefile28
-rw-r--r--games/wmtictactoe/distinfo1
-rw-r--r--games/wmtictactoe/files/patch-aa22
-rw-r--r--games/wmtictactoe/pkg-comment1
-rw-r--r--games/wmtictactoe/pkg-descr7
-rw-r--r--games/wmtictactoe/pkg-plist1
6 files changed, 60 insertions, 0 deletions
diff --git a/games/wmtictactoe/Makefile b/games/wmtictactoe/Makefile
new file mode 100644
index 000000000000..554d05c4f2c8
--- /dev/null
+++ b/games/wmtictactoe/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: wmtictactoe
+# Version required: 0.4
+# Date created: 28 Apr 1999
+# Whom: Jim Mock <jim@phrantic.phear.net>
+#
+# $Id$
+#
+
+DISTNAME= wmtictactoe-0.4
+CATEGORIES= games windowmaker afterstep
+MASTER_SITES= http://atlas.ucpel.tche.br/~acamargo/
+
+MAINTAINER= jim@phrantic.phear.net
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/wmtictactoe.app/wmtictactoe
+USE_X_PREFIX= yes
+
+post-install:
+ @${ECHO} " "
+ @${ECHO} "-------------------------------------------------------"
+ @${ECHO} "===> Run 'wmtictactoe --help' for the available options"
+ @${ECHO} "-------------------------------------------------------"
+ @${ECHO} " "
+
+.include <bsd.port.mk>
diff --git a/games/wmtictactoe/distinfo b/games/wmtictactoe/distinfo
new file mode 100644
index 000000000000..ee721ad6053b
--- /dev/null
+++ b/games/wmtictactoe/distinfo
@@ -0,0 +1 @@
+MD5 (wmtictactoe-0.4.tar.gz) = dd96623a1748f50d62cc7c94deacdfea
diff --git a/games/wmtictactoe/files/patch-aa b/games/wmtictactoe/files/patch-aa
new file mode 100644
index 000000000000..64085be503a2
--- /dev/null
+++ b/games/wmtictactoe/files/patch-aa
@@ -0,0 +1,22 @@
+--- Makefile.orig Mon Mar 29 09:41:40 1999
++++ Makefile Sat May 1 21:48:22 1999
+@@ -1,9 +1,10 @@
+-LIBDIR = -L/usr/X11R6/lib
++INCLUDES = -I${X11BASE}/include
++LIBDIR = -L${X11BASE}/lib
+ LIBS = -lXpm -lXext -lX11
+ OBJS = wmtictactoe.o ../wmgeneral/wmgeneral.o
+
+ .c.o:
+- cc -c -g -O2 -Wall $< -o $*.o
++ cc -c -g -O2 -Wall $(INCLUDES) $< -o $*.o
+
+ all: wmtictactoe
+
+@@ -17,5 +18,4 @@
+ rm wmtictactoe
+
+ install:
+- /usr/bin/install -c -o 0 -g 0 -s -m 755 wmtictactoe /usr/local/bin/wmtictactoe
+-
++ /usr/bin/install -c -o 0 -g 0 -s -m 755 wmtictactoe ${PREFIX}/bin/wmtictactoe
diff --git a/games/wmtictactoe/pkg-comment b/games/wmtictactoe/pkg-comment
new file mode 100644
index 000000000000..bab0823a5fa3
--- /dev/null
+++ b/games/wmtictactoe/pkg-comment
@@ -0,0 +1 @@
+A dockable TicTacToe game for WindowMaker and AfterStep.
diff --git a/games/wmtictactoe/pkg-descr b/games/wmtictactoe/pkg-descr
new file mode 100644
index 000000000000..a13e03a37e34
--- /dev/null
+++ b/games/wmtictactoe/pkg-descr
@@ -0,0 +1,7 @@
+Yet another app for the Window Maker dock or AfterStep Wharf.
+wmTicTacToe is exactly what it sounds like.. Tic-Tac-Toe in a dock
+app.
+
+WWW Homepage: http://atlas.ucpel.tche.br/~acamargo/
+
+- Jim <jim@phrantic.phear.net>
diff --git a/games/wmtictactoe/pkg-plist b/games/wmtictactoe/pkg-plist
new file mode 100644
index 000000000000..66a24b9ab7fe
--- /dev/null
+++ b/games/wmtictactoe/pkg-plist
@@ -0,0 +1 @@
+bin/wmtictactoe