aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-09-11 08:09:49 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-09-11 08:09:49 +0000
commit9c55c35b136b653e3986d41287d208d8e4fa00c9 (patch)
treefc9b17fd537c3ba0432e8188a9340ed8b35a5772 /games
parent5d6556dc39098800e88d6345d23bd810c72d0b39 (diff)
downloadports-9c55c35b136b653e3986d41287d208d8e4fa00c9.tar.gz
ports-9c55c35b136b653e3986d41287d208d8e4fa00c9.zip
- Fix build on 6.3
- UNBREAK Approved by: portmgr (linimon)
Notes
Notes: svn path=/head/; revision=220332
Diffstat (limited to 'games')
-rw-r--r--games/battletanks/Makefile4
-rw-r--r--games/battletanks/files/patch-mrt_logger.cpp11
2 files changed, 11 insertions, 4 deletions
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index a6ac23c0b7aa..880e0d4f4f6c 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -30,10 +30,6 @@ OPTIONS= LUA "Build with Lua scripting support" off
.include <bsd.port.pre.mk>
-.if ${ARCH} == i386
-BROKEN= does not build
-.endif
-
.if defined(WITH_LUA)
USE_LUA= 5.0+
.else
diff --git a/games/battletanks/files/patch-mrt_logger.cpp b/games/battletanks/files/patch-mrt_logger.cpp
new file mode 100644
index 000000000000..fec967f35c16
--- /dev/null
+++ b/games/battletanks/files/patch-mrt_logger.cpp
@@ -0,0 +1,11 @@
+--- mrt/logger.cpp.orig 2008-09-11 09:12:44.000000000 +0200
++++ mrt/logger.cpp 2008-09-11 09:14:32.000000000 +0200
+@@ -81,7 +81,7 @@
+ gettimeofday(&tv, NULL);
+
+ struct tm tm;
+- localtime_r(&tv.tv_sec, &tm);
++ localtime_r((time_t *)&tv.tv_sec, &tm);
+
+ h = tm.tm_hour;
+ m = tm.tm_min;