aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-06 22:36:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-06 22:36:25 +0000
commitaf7af4c86a5b7ce24d74e24ae6028875d341cc72 (patch)
tree4c2f42525edccc81c3e8b2f919f0e86e1dc2a2ad /games
parentd57c50c64a845069edb286efbeeb572bec97b89c (diff)
downloadports-af7af4c86a5b7ce24d74e24ae6028875d341cc72.tar.gz
ports-af7af4c86a5b7ce24d74e24ae6028875d341cc72.zip
- Update to 1.3.9
- Unbreak (now works without problems) - Split patch for convenience PR: 126870 Submitted by: me Approved by: "Pierre-Paul Lavoie" <ppl@idios.org> (maintainer)
Notes
Notes: svn path=/head/; revision=220028
Diffstat (limited to 'games')
-rw-r--r--games/holotz-castle/Makefile7
-rw-r--r--games/holotz-castle/distinfo6
-rw-r--r--games/holotz-castle/files/patch-JLib-JLib-Util-JFS.cpp13
-rw-r--r--games/holotz-castle/files/patch-JLib-Makefile31
-rw-r--r--games/holotz-castle/files/patch-all78
-rw-r--r--games/holotz-castle/files/patch-src-Makefile44
-rw-r--r--games/holotz-castle/pkg-plist54
7 files changed, 147 insertions, 86 deletions
diff --git a/games/holotz-castle/Makefile b/games/holotz-castle/Makefile
index 9c544bc0b805..7c474cf2088c 100644
--- a/games/holotz-castle/Makefile
+++ b/games/holotz-castle/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= holotz-castle
-PORTVERSION= 1.3.9
-PORTREVISION= 3
+PORTVERSION= 1.3.11
CATEGORIES= games
MASTER_SITES= http://www.mainreactor.net/holotzcastle/download/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -15,12 +14,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ppl@nbnet.nb.ca
COMMENT= A platform game with high doses of mystery
-MAKE_ARGS= HC_BASE=${PREFIX}/share/${PORTNAME}/ HC_BIN_DIR=${PREFIX}/bin/ CXX=${CXX}
+MAKE_ARGS= HC_BASE=${PREFIX}/share/${PORTNAME}/ HC_BIN_DIR=${PREFIX}/bin/
USE_GL= gl
USE_SDL= image mixer sdl ttf
USE_GMAKE= yes
-IGNORE= Does not run (No video mode large enough for 676550817x676551540)
-
.include <bsd.port.mk>
diff --git a/games/holotz-castle/distinfo b/games/holotz-castle/distinfo
index 646edf7cfe79..f36c68a3c746 100644
--- a/games/holotz-castle/distinfo
+++ b/games/holotz-castle/distinfo
@@ -1,3 +1,3 @@
-MD5 (holotz-castle-1.3.9-src.tar.gz) = e25d7a328d07a9dca36ad80a40e685c0
-SHA256 (holotz-castle-1.3.9-src.tar.gz) = 33328a3a5e29ba87acff63c38704df2b824b98ef664d0421b9f33398a764972e
-SIZE (holotz-castle-1.3.9-src.tar.gz) = 3617589
+MD5 (holotz-castle-1.3.11-src.tar.gz) = 04cfdfe3bd3152f6a26aad56ef6455cd
+SHA256 (holotz-castle-1.3.11-src.tar.gz) = a918cc8832e73f34c8b496a2bcb7a2b5d7093dacea9c826bd3dd289f86f08735
+SIZE (holotz-castle-1.3.11-src.tar.gz) = 3690807
diff --git a/games/holotz-castle/files/patch-JLib-JLib-Util-JFS.cpp b/games/holotz-castle/files/patch-JLib-JLib-Util-JFS.cpp
new file mode 100644
index 000000000000..3fd9b8589df5
--- /dev/null
+++ b/games/holotz-castle/files/patch-JLib-JLib-Util-JFS.cpp
@@ -0,0 +1,13 @@
+--- JLib/JLib/Util/JFS.cpp.orig 2008-08-23 22:36:06.000000000 +0400
++++ JLib/JLib/Util/JFS.cpp 2008-08-25 17:58:54.000000000 +0400
+@@ -886,8 +886,8 @@
+ s32 n, k;
+
+ // Si es un directorio lo importa recursivamente
+- struct dirent64 **namelist;
+- n = scandir64(filename, &namelist, 0, alphasort);
++ struct dirent **namelist;
++ n = scandir(filename, &namelist, 0, alphasort);
+
+ if (n < 0)
+ {
diff --git a/games/holotz-castle/files/patch-JLib-Makefile b/games/holotz-castle/files/patch-JLib-Makefile
new file mode 100644
index 000000000000..ad43f316d70a
--- /dev/null
+++ b/games/holotz-castle/files/patch-JLib-Makefile
@@ -0,0 +1,31 @@
+--- JLib/Makefile.orig 2008-08-23 22:36:06.000000000 +0400
++++ JLib/Makefile 2008-08-25 18:00:54.000000000 +0400
+@@ -19,7 +19,7 @@
+ endif
+
+ # Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
+-CFLAGS=-I. -I/usr/local/include/SDL -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
++CXXFLAGS+=-I. -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
+
+ # Sample LDFLAGS for applications
+ # LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+@@ -28,15 +28,15 @@
+
+ # JLib
+ libJLib: $(JLIB_OBJS)
+- g++-4.1 -shared -L/usr/lib -fPIC -o $@.so $? \
++ $(CXX) -shared -fPIC -o $@.so $? \
+ && ar rvus $@.a $? \
+
+ $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) ${CXXFLAGS} -c -o $@ $<
+ $(UTIL)/%.o: $(UTIL)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) ${CXXFLAGS} -c -o $@ $<
+ $(MATH)/%.o: $(MATH)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) ${CXXFLAGS} -c -o $@ $<
+
+ .PHONY: install
+ install:
diff --git a/games/holotz-castle/files/patch-all b/games/holotz-castle/files/patch-all
deleted file mode 100644
index ccd2ec751a2f..000000000000
--- a/games/holotz-castle/files/patch-all
+++ /dev/null
@@ -1,78 +0,0 @@
-diff -ruN JLib/JLib/Util/JFS.cpp JLib/JLib/Util/JFS.cpp
---- JLib/JLib/Util/JFS.cpp 2007-11-01 02:27:55.000000000 +0000
-+++ JLib/JLib/Util/JFS.cpp 2007-11-01 02:28:00.000000000 +0000
-@@ -886,8 +886,8 @@
- s32 n, k;
-
- // Si es un directorio lo importa recursivamente
-- struct dirent64 **namelist;
-- n = scandir64(filename, &namelist, 0, alphasort);
-+ struct dirent **namelist;
-+ n = scandir(filename, &namelist, 0, alphasort);
-
- if (n < 0)
- {
-diff -ruN JLib/Makefile JLib/Makefile
---- JLib/Makefile 2007-11-01 02:27:55.000000000 +0000
-+++ JLib/Makefile 2007-11-01 02:29:12.000000000 +0000
-@@ -19,7 +19,7 @@
- endif
-
- # Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
--CFLAGS=-I. -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
-+CFLAGS+=-I$(LOCALBASE)/include -I. -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
-
- # Sample LDFLAGS for applications
- # LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
-@@ -28,15 +28,15 @@
-
- # JLib
- libJLib: $(JLIB_OBJS)
-- g++ -shared -fPIC -o $@.so $? \
-+ $(CXX) -shared -fPIC -o $@.so $? \
- && ar rvus $@.a $? \
-
- $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
-- g++ $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CFLAGS) -c -o $@ $<
- $(UTIL)/%.o: $(UTIL)/%.cpp
-- g++ $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CFLAGS) -c -o $@ $<
- $(MATH)/%.o: $(MATH)/%.cpp
-- g++ $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CFLAGS) -c -o $@ $<
-
- .PHONY: install
- install:
-diff -ruN src/Makefile src/Makefile
---- src/Makefile 2007-11-01 02:27:56.000000000 +0000
-+++ src/Makefile 2007-11-01 02:28:55.000000000 +0000
-@@ -42,23 +42,23 @@
-
- # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
- # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
--CFLAGS=-I. -I../JLib -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c `$(SDL_CONFIG) --cflags`
--LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
-+CFLAGS+=-I$(LOCALBASE)/include -I. -I../JLib -Wall -Wshadow $(CPU_OPTS) -c `$(SDL_CONFIG) --cflags`
-+LDFLAGS=-L$(LOCALBASE)/lib -L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
-
-
- JLib:
- $(MAKE) -C ../JLib;
-
- %.o: %.cpp %.h
-- g++ $(CFLAGS) $(DEFINES) $< -o $@
-+ $(CXX) $(CFLAGS) $(DEFINES) $< -o $@
-
- HC: $(HC_OBJS) $(HC_OBJ_MAIN) ../JLib/libJLib.a
-- g++ $(LDFLAGS) $? -o $@;\
-+ $(CXX) $(LDFLAGS) $? -o $@;\
- mv HC ../holotz-castle
-
- # HCed (Holotz's Castle editor).
- HCed: $(HC_OBJS) $(HCED_OBJ_MAIN) ../JLib/libJLib.a
-- g++ $(LDFLAGS) $? -o $@;\
-+ $(CXX) $(LDFLAGS) $? -o $@;\
- mv HCed ../holotz-castle-editor
-
- install:
diff --git a/games/holotz-castle/files/patch-src-Makefile b/games/holotz-castle/files/patch-src-Makefile
new file mode 100644
index 000000000000..353cd45a6541
--- /dev/null
+++ b/games/holotz-castle/files/patch-src-Makefile
@@ -0,0 +1,44 @@
+--- src/Makefile.orig 2008-08-23 22:36:07.000000000 +0400
++++ src/Makefile 2008-08-25 18:04:07.000000000 +0400
+@@ -21,12 +21,8 @@
+ # Edita estas l�neas para cambiar el directorio de instalaci�n de datos y del juego o bien
+ # comenta estas l�neas si no quieres instalar el juego (y descomenta las de arriba)
+
+-ifndef I486_BUILD
+-HC_BASE = /usr/share/games/holotz-castle/
+ HC_DATA = $(HC_BASE)game/
+ HCED_DATA = $(HC_BASE)editor/
+-HC_BIN_DIR = /usr/local/bin/
+-endif
+
+ DEFINES = -DHC_DATA_DIR=\"$(HC_DATA)\" -DHCED_DATA_DIR=\"$(HCED_DATA)\"
+
+@@ -42,23 +38,23 @@
+
+ # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
+ # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
+-CFLAGS=-fno-strict-aliasing -I. -I../JLib `$(SDL_CONFIG) --cflags` -I/usr/local/include/ -I/usr/local/include/SDL -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c
+-LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
++CXXFLAGS+=-I. -I../JLib `$(SDL_CONFIG) --cflags` -Wall -Wshadow -c
++LDFLAGS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+
+
+ JLib:
+ $(MAKE) -C ../JLib;
+
+ %.o: %.cpp %.h
+- g++ $(CFLAGS) $(DEFINES) $< -o $@
++ $(CXX) $(CXXFLAGS) $(DEFINES) $< -o $@
+
+ HC: $(HC_OBJS) $(HC_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ $(CXX) $(LDFLAGS) $? -o $@;\
+ mv HC ../holotz-castle
+
+ # HCed (Holotz's Castle editor).
+ HCed: $(HC_OBJS) $(HCED_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ $(CXX) $(LDFLAGS) $? -o $@;\
+ mv HCed ../holotz-castle-editor
+
+ install:
diff --git a/games/holotz-castle/pkg-plist b/games/holotz-castle/pkg-plist
index 8a01cf11121d..5199af4d8d22 100644
--- a/games/holotz-castle/pkg-plist
+++ b/games/holotz-castle/pkg-plist
@@ -54,6 +54,8 @@ bin/holotz-castle-editor
%%DATADIR%%/game/help/es/help.txt
%%DATADIR%%/game/help/eu/help.txt
%%DATADIR%%/game/help/fr/help.txt
+%%DATADIR%%/game/help/it/help.txt
+%%DATADIR%%/game/help/nl/help.txt
%%DATADIR%%/game/help/pt/help.txt
%%DATADIR%%/game/help/ru/help.txt
%%DATADIR%%/game/help/ua/help.txt
@@ -63,8 +65,11 @@ bin/holotz-castle-editor
%%DATADIR%%/game/intro/en/intro.txt
%%DATADIR%%/game/intro/es/intro.txt
%%DATADIR%%/game/intro/eu/intro.txt
+%%DATADIR%%/game/intro/ff.tga
%%DATADIR%%/game/intro/fr/intro.txt
%%DATADIR%%/game/intro/intro.tga
+%%DATADIR%%/game/intro/it/intro.txt
+%%DATADIR%%/game/intro/nl/intro.txt
%%DATADIR%%/game/intro/pt/intro.txt
%%DATADIR%%/game/intro/ru/intro.txt
%%DATADIR%%/game/intro/ua/intro.txt
@@ -77,6 +82,8 @@ bin/holotz-castle-editor
%%DATADIR%%/game/menu/es/menu.txt
%%DATADIR%%/game/menu/eu/menu.txt
%%DATADIR%%/game/menu/fr/menu.txt
+%%DATADIR%%/game/menu/it/menu.txt
+%%DATADIR%%/game/menu/nl/menu.txt
%%DATADIR%%/game/menu/pt/menu.txt
%%DATADIR%%/game/menu/ru/menu.txt
%%DATADIR%%/game/menu/ua/menu.txt
@@ -86,6 +93,8 @@ bin/holotz-castle-editor
%%DATADIR%%/game/messages/es/messages.txt
%%DATADIR%%/game/messages/eu/messages.txt
%%DATADIR%%/game/messages/fr/messages.txt
+%%DATADIR%%/game/messages/it/messages.txt
+%%DATADIR%%/game/messages/nl/messages.txt
%%DATADIR%%/game/messages/pt/messages.txt
%%DATADIR%%/game/messages/ru/messages.txt
%%DATADIR%%/game/messages/ua/messages.txt
@@ -211,6 +220,28 @@ bin/holotz-castle-editor
%%DATADIR%%/game/stories/holotzcastle/script/fr/level030.hcs
%%DATADIR%%/game/stories/holotzcastle/script/fr/level032.hcs
%%DATADIR%%/game/stories/holotzcastle/script/fr/level033.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level001.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level002.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level007.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level014.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level016.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level019.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level020.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level025.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level030.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level032.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/it/level033.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level001.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level002.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level007.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level014.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level016.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level019.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level020.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level025.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level030.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level032.hcs
+%%DATADIR%%/game/stories/holotzcastle/script/nl/level033.hcs
%%DATADIR%%/game/stories/holotzcastle/script/pt/level001.hcs
%%DATADIR%%/game/stories/holotzcastle/script/pt/level002.hcs
%%DATADIR%%/game/stories/holotzcastle/script/pt/level007.hcs
@@ -244,6 +275,18 @@ bin/holotz-castle-editor
%%DATADIR%%/game/stories/holotzcastle/script/ua/level030.hcs
%%DATADIR%%/game/stories/holotzcastle/script/ua/level032.hcs
%%DATADIR%%/game/stories/holotzcastle/script/ua/level033.hcs
+%%DATADIR%%/game/stories/milanb/level001.hlv
+%%DATADIR%%/game/stories/milanb/level002.hlv
+%%DATADIR%%/game/stories/milanb/level003.hlv
+%%DATADIR%%/game/stories/milanb/level004.hlv
+%%DATADIR%%/game/stories/milanb/level005.hlv
+%%DATADIR%%/game/stories/milanb/level006.hlv
+%%DATADIR%%/game/stories/milanb/level007.hlv
+%%DATADIR%%/game/stories/milanb/level008.hlv
+%%DATADIR%%/game/stories/milanb/level009.hlv
+%%DATADIR%%/game/stories/milanb/level010.hlv
+%%DATADIR%%/game/stories/milanb/level011.hlv
+%%DATADIR%%/game/stories/milanb/level012.hlv
%%DATADIR%%/game/theme/default/bar/1/bar.tga
%%DATADIR%%/game/theme/default/bar/2/bar.tga
%%DATADIR%%/game/theme/default/bar/3/bar.tga
@@ -1425,9 +1468,12 @@ bin/holotz-castle-editor
@dirrm %%DATADIR%%/game/theme/default/bar
@dirrm %%DATADIR%%/game/theme/default
@dirrm %%DATADIR%%/game/theme
+@dirrm %%DATADIR%%/game/stories/milanb
@dirrm %%DATADIR%%/game/stories/holotzcastle/script/ua
@dirrm %%DATADIR%%/game/stories/holotzcastle/script/ru
@dirrm %%DATADIR%%/game/stories/holotzcastle/script/pt
+@dirrm %%DATADIR%%/game/stories/holotzcastle/script/nl
+@dirrm %%DATADIR%%/game/stories/holotzcastle/script/it
@dirrm %%DATADIR%%/game/stories/holotzcastle/script/fr
@dirrm %%DATADIR%%/game/stories/holotzcastle/script/eu
@dirrm %%DATADIR%%/game/stories/holotzcastle/script/es
@@ -1442,6 +1488,8 @@ bin/holotz-castle-editor
@dirrm %%DATADIR%%/game/messages/ua
@dirrm %%DATADIR%%/game/messages/ru
@dirrm %%DATADIR%%/game/messages/pt
+@dirrm %%DATADIR%%/game/messages/nl
+@dirrm %%DATADIR%%/game/messages/it
@dirrm %%DATADIR%%/game/messages/fr
@dirrm %%DATADIR%%/game/messages/eu
@dirrm %%DATADIR%%/game/messages/es
@@ -1452,6 +1500,8 @@ bin/holotz-castle-editor
@dirrm %%DATADIR%%/game/menu/ua
@dirrm %%DATADIR%%/game/menu/ru
@dirrm %%DATADIR%%/game/menu/pt
+@dirrm %%DATADIR%%/game/menu/nl
+@dirrm %%DATADIR%%/game/menu/it
@dirrm %%DATADIR%%/game/menu/fr
@dirrm %%DATADIR%%/game/menu/eu
@dirrm %%DATADIR%%/game/menu/es
@@ -1463,6 +1513,8 @@ bin/holotz-castle-editor
@dirrm %%DATADIR%%/game/intro/ua
@dirrm %%DATADIR%%/game/intro/ru
@dirrm %%DATADIR%%/game/intro/pt
+@dirrm %%DATADIR%%/game/intro/nl
+@dirrm %%DATADIR%%/game/intro/it
@dirrm %%DATADIR%%/game/intro/fr
@dirrm %%DATADIR%%/game/intro/eu
@dirrm %%DATADIR%%/game/intro/es
@@ -1474,6 +1526,8 @@ bin/holotz-castle-editor
@dirrm %%DATADIR%%/game/help/ua
@dirrm %%DATADIR%%/game/help/ru
@dirrm %%DATADIR%%/game/help/pt
+@dirrm %%DATADIR%%/game/help/nl
+@dirrm %%DATADIR%%/game/help/it
@dirrm %%DATADIR%%/game/help/fr
@dirrm %%DATADIR%%/game/help/eu
@dirrm %%DATADIR%%/game/help/es