aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-03 16:03:01 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-03 16:03:01 +0000
commitdc94ed062b799cba2ee6bea886ab8f1558b0729c (patch)
tree17dcf2c4055547d704c6013c0e0825af8638a2fc /games
parentfeba621254c9831d67cc5238d7d6fe581c571c69 (diff)
downloadports-dc94ed062b799cba2ee6bea886ab8f1558b0729c.tar.gz
ports-dc94ed062b799cba2ee6bea886ab8f1558b0729c.zip
- Update to 0.4-0
Notes
Notes: svn path=/head/; revision=219783
Diffstat (limited to 'games')
-rw-r--r--games/love/Makefile8
-rw-r--r--games/love/distinfo6
-rw-r--r--games/love/files/patch-Makefile6
3 files changed, 12 insertions, 8 deletions
diff --git a/games/love/Makefile b/games/love/Makefile
index c104eafde0c7..8c03eb30e3d2 100644
--- a/games/love/Makefile
+++ b/games/love/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= love
-DISTVERSION= 0.3-2
+DISTVERSION= 0.4-0
CATEGORIES= games devel
MASTER_SITES= SF
@@ -33,8 +33,12 @@ PLIST_FILES= bin/love lib/liblove.a
PORTDOCS= *
PORTEXAMPLES= *
+post-extract:
+ cd ${WRKSRC} && ${FIND} . -name "*.o" -delete
+
post-patch:
- @${REINPLACE_CMD} -e 's|ILvoid|void|' ${WRKSRC}/src/opengl/Image.cpp
+ @${REINPLACE_CMD} -e 's|ILvoid|void|' ${WRKSRC}/src/opengl/Image.cpp \
+ ${WRKSRC}/src/opengl/love_opengl.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/love ${PREFIX}/bin
diff --git a/games/love/distinfo b/games/love/distinfo
index 911d128600b2..99a43ff681e0 100644
--- a/games/love/distinfo
+++ b/games/love/distinfo
@@ -1,3 +1,3 @@
-MD5 (love-0.3-2.tar.bz2) = 04baa99ea1f237d87fb6e12a4da3d126
-SHA256 (love-0.3-2.tar.bz2) = d86b424ad7af8078c37ab604c6e20315f538ea95f6d563c8214d3d0505f67bf9
-SIZE (love-0.3-2.tar.bz2) = 885790
+MD5 (love-0.4-0.tar.bz2) = b77ed79c7d2aedc0e7c79c8631db0681
+SHA256 (love-0.4-0.tar.bz2) = 287f0f16ac419fd2339ed5c0eef9123745c3ef9424086a3365b3d2468969156d
+SIZE (love-0.4-0.tar.bz2) = 846487
diff --git a/games/love/files/patch-Makefile b/games/love/files/patch-Makefile
index e1eb1dcb1c9c..f7243aaff534 100644
--- a/games/love/files/patch-Makefile
+++ b/games/love/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile.orig 2008-07-04 03:25:34.000000000 +0400
-+++ Makefile 2008-08-01 16:27:46.000000000 +0400
+--- Makefile.orig 2008-08-29 03:42:40.000000000 +0400
++++ Makefile 2008-08-29 18:09:43.000000000 +0400
@@ -3,20 +3,19 @@
# You may need to modify parts of this makefile for your system.
######################################################################
-CC = g++
--CFLAGS = -g -O2 -Wall
+-CFLAGS = -g0 -O3 -Wall
-CFLAGS_MOD = -g0 -O3
+CFLAGS += -Wall
+CFLAGS_MOD = $(CFLAGS)