aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-14 23:29:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-14 23:29:14 +0000
commite1c3b01efdc962a9ebb57c37d4e1db7afa43c2e8 (patch)
treeb28796541dec5a926885baf953780bde4d970b07 /games
parent3ba03fca82bbb5c23d6a35130c470ab789eac4b9 (diff)
downloadports-e1c3b01efdc962a9ebb57c37d4e1db7afa43c2e8.tar.gz
ports-e1c3b01efdc962a9ebb57c37d4e1db7afa43c2e8.zip
- Fix build on FreeBSD 4.X
PR: ports/80740 Submitted by: Martin Kaeske <Martin.Kaeske@Stud.TU-Ilmenau.DE> Approved by: maintainer timeout (des; 4 months)
Notes
Notes: svn path=/head/; revision=142768
Diffstat (limited to 'games')
-rw-r--r--games/flightgear/Makefile8
-rw-r--r--games/flightgear/files/patch-cstdio81
2 files changed, 82 insertions, 7 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 0da34e45991f..eb3edcda140f 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -41,12 +41,6 @@ CONFIGURE_ARGS= --program-transform-name='s/^${CONFIGURE_TARGET}-//' \
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
post-extract:
@${FIND} ${WRKSRC} \( -name '.#*' -or -name '*~' \) -delete
@@ -54,4 +48,4 @@ do-install:
@${ECHO} ">> Installing program"
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/flightgear/files/patch-cstdio b/games/flightgear/files/patch-cstdio
new file mode 100644
index 000000000000..219659afa994
--- /dev/null
+++ b/games/flightgear/files/patch-cstdio
@@ -0,0 +1,81 @@
+--- src/FDM/JSBSim/FGEngine.cpp.orig Sat May 7 15:55:16 2005
++++ src/FDM/JSBSim/FGEngine.cpp Sat May 7 15:57:56 2005
+@@ -52,6 +52,7 @@
+ # include <fstream>
+ # endif
+ #endif
++#include <cstdio>
+
+ #include "FGEngine.h"
+ #include "FGTank.h"
+--- src/FDM/JSBSim/FGFCS.cpp.orig Sat May 7 15:55:16 2005
++++ src/FDM/JSBSim/FGFCS.cpp Sat May 7 15:57:43 2005
+@@ -36,6 +36,7 @@
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
+ INCLUDES
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
++#include <cstdio>
+
+ #include "FGFCS.h"
+ #include "FGFDMExec.h"
+--- src/FDM/JSBSim/FGNozzle.cpp.orig Sat May 7 15:55:16 2005
++++ src/FDM/JSBSim/FGNozzle.cpp Sat May 7 15:57:32 2005
+@@ -36,6 +36,7 @@
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
+
+ #include <sstream>
++#include <cstdio>
+
+ #include "FGNozzle.h"
+ #include "FGAtmosphere.h"
+--- src/FDM/JSBSim/FGPropeller.cpp.orig Sat May 7 15:55:16 2005
++++ src/FDM/JSBSim/FGPropeller.cpp Sat May 7 15:57:23 2005
+@@ -36,6 +36,7 @@
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
+
+ #include <sstream>
++#include <cstdio>
+
+ #include "FGPropeller.h"
+ #include "FGPropagate.h"
+--- src/FDM/JSBSim/FGState.cpp.orig Sat May 7 15:55:16 2005
++++ src/FDM/JSBSim/FGState.cpp Sat May 7 15:57:13 2005
+@@ -51,6 +51,8 @@
+ //#define snprintf _snprintf
+ #endif
+
++#include <cstdio>
++
+ #include "FGState.h"
+
+ namespace JSBSim {
+--- src/FDM/JSBSim/FGThruster.cpp.orig Sat May 7 15:55:16 2005
++++ src/FDM/JSBSim/FGThruster.cpp Sat May 7 15:56:47 2005
+@@ -36,6 +36,7 @@
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
+
+ #include <sstream>
++#include <cstdio>
+
+ #include "FGThruster.h"
+
+--- src/FDM/JSBSim/FGTrim.cpp.orig Sat May 7 15:55:16 2005
++++ src/FDM/JSBSim/FGTrim.cpp Sat May 7 15:56:25 2005
+@@ -45,6 +45,7 @@
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
+
+ #include <stdlib.h>
++#include <cstdio>
+
+ #include "FGFDMExec.h"
+ #include "FGAtmosphere.h"
+--- src/FDM/JSBSim/FGTurbine.cpp.orig Sat May 7 15:55:16 2005
++++ src/FDM/JSBSim/FGTurbine.cpp Sat May 7 15:56:36 2005
+@@ -41,6 +41,7 @@
+
+ #include <vector>
+ #include <sstream>
++#include <cstdio>
+
+ #include "FGTurbine.h"
+