aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-10 17:42:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-10 17:42:09 +0000
commit6817b34126ea3273ceeb855d5179debca6f25998 (patch)
tree5aee6baff2289b31e3d8a58c12f338a248f5086f /games
parentd3603f46a7692cfcea475e847ff526093e04e3b1 (diff)
downloadports-6817b34126ea3273ceeb855d5179debca6f25998.tar.gz
ports-6817b34126ea3273ceeb855d5179debca6f25998.zip
- Update to v0.8a
PR: 144623 Submitted by: Ganael Laplanche <ganael.laplanche@martymac.com> (maintainer)
Notes
Notes: svn path=/head/; revision=250860
Diffstat (limited to 'games')
-rw-r--r--games/blobby/Makefile16
-rw-r--r--games/blobby/distinfo6
-rw-r--r--games/blobby/files/patch-config.h.in7
-rw-r--r--games/blobby/files/patch-data-CMakeLists.txt9
-rw-r--r--games/blobby/pkg-plist3
5 files changed, 29 insertions, 12 deletions
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index 527fe6ce1fcb..89f1946dffcb 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= blobby
-PORTVERSION= 0.6a
-PORTREVISION= 1
+PORTVERSION= 0.8a
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/Blobby%20Volley%202%20%28Linux%29/Alpha%206
+MASTER_SITES= SF/${PORTNAME}/Blobby%20Volley%202%20%28Linux%29/Alpha%208
DISTNAME= blobby2-linux-${PORTVERSION}
MAINTAINER= ganael.laplanche@martymac.com
@@ -17,14 +16,15 @@ COMMENT= Official continuation of the famous Blobby Volley 1.x game
LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs \
drm:${PORTSDIR}/graphics/libdrm
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ ${LOCALBASE}/include/boost/crc.hpp:${PORTSDIR}/devel/boost-libs
-USE_XORG= x11 xext xxf86vm xdamage xfixes xau xdmcp xrandr xrender
+USE_XORG= ice x11 xext xxf86vm xdamage xfixes xau xdmcp xrandr xrender
USE_SDL= sdl
USE_GL= glu
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-WRKSRC= ${WRKDIR}/blobby-alpha-6
+USE_CMAKE= yes
+CMAKE_ARGS+= -DDATADIR:PATH="${DATADIR}"
+WRKSRC= ${WRKDIR}/blobby-alpha-8
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
diff --git a/games/blobby/distinfo b/games/blobby/distinfo
index 560a6806b6b3..b55178480a69 100644
--- a/games/blobby/distinfo
+++ b/games/blobby/distinfo
@@ -1,3 +1,3 @@
-MD5 (blobby2-linux-0.6a.tar.gz) = fdef3e59f0870d890be8dffaccd773ca
-SHA256 (blobby2-linux-0.6a.tar.gz) = da070839fd2c99269fcb0d4dfc0de10bb9fab980ca28408d2a27490244bce526
-SIZE (blobby2-linux-0.6a.tar.gz) = 2110392
+MD5 (blobby2-linux-0.8a.tar.gz) = 75e7d46039d5e8fe1ed2d174244143a9
+SHA256 (blobby2-linux-0.8a.tar.gz) = ff259e1fb16b6a444c056bcf9971ce85de0e7a16b6bac813d675cdb19365e8f3
+SIZE (blobby2-linux-0.8a.tar.gz) = 1493181
diff --git a/games/blobby/files/patch-config.h.in b/games/blobby/files/patch-config.h.in
new file mode 100644
index 000000000000..4dfe380eb273
--- /dev/null
+++ b/games/blobby/files/patch-config.h.in
@@ -0,0 +1,7 @@
+--- config.h.in.orig 2010-03-10 07:19:26.023348777 +0000
++++ config.h.in 2010-03-10 07:20:03.718760903 +0000
+@@ -20,3 +20,4 @@
+ #pragma once
+
+ #define BLOBBY_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}"
++#define GAMEDATADIR "${DATADIR}"
diff --git a/games/blobby/files/patch-data-CMakeLists.txt b/games/blobby/files/patch-data-CMakeLists.txt
new file mode 100644
index 000000000000..8828dddbaef0
--- /dev/null
+++ b/games/blobby/files/patch-data-CMakeLists.txt
@@ -0,0 +1,9 @@
+--- data/CMakeLists.txt.orig 2010-03-10 06:56:11.633734175 +0000
++++ data/CMakeLists.txt 2010-03-10 06:59:30.458786242 +0000
+@@ -29,5 +29,5 @@
+ if (WIN32)
+ install(FILES ${install_files} DESTINATION data)
+ elseif (UNIX)
+- install(FILES ${install_files} DESTINATION share/blobby)
++ install(FILES ${install_files} DESTINATION ${DATADIR})
+ endif (WIN32)
diff --git a/games/blobby/pkg-plist b/games/blobby/pkg-plist
index e817f346e7bf..90575f30ad12 100644
--- a/games/blobby/pkg-plist
+++ b/games/blobby/pkg-plist
@@ -1,9 +1,10 @@
bin/blobby
bin/blobby-server
%%DATADIR%%/gfx.zip
-%%DATADIR%%/gf2x.zip
%%DATADIR%%/sounds.zip
%%DATADIR%%/scripts.zip
+%%DATADIR%%/backgrounds.zip
%%DATADIR%%/config.xml
%%DATADIR%%/inputconfig.xml
+%%DATADIR%%/server.xml
@dirrm %%DATADIR%%