aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-07-20 18:31:26 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-07-20 18:31:26 +0000
commit9f01a34627a2a8310e21391bc50e57ff0f704dbb (patch)
treea335282a54191dbbae09b4675b854e3c859654d1 /games
parentcf102495f71e456e6d82dfed709f1eb7d0d4ff1d (diff)
downloadports-9f01a34627a2a8310e21391bc50e57ff0f704dbb.tar.gz
ports-9f01a34627a2a8310e21391bc50e57ff0f704dbb.zip
A scrolling, platform-jumping, key-collecting, ancient pyramid exploring game,
vaguely in the style of similar games for the Commodore+4. The game is intended to show young people (I'm writing it for my son's birthday) all the cool games they missed. WWW: http://abe.sourceforge.net/ PR: ports/83162 Submitted by: Alejandro Pulver <alejandro@varnet.biz> Approved by: flz (mentor)
Notes
Notes: svn path=/head/; revision=139731
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/abe/Makefile54
-rw-r--r--games/abe/distinfo2
-rw-r--r--games/abe/pkg-descr9
-rw-r--r--games/abe/pkg-plist21
5 files changed, 87 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 86cc6c3b7db9..486373959a32 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -13,6 +13,7 @@
SUBDIR += CaribbeanStud
SUBDIR += HeroesOfMightAndMagic
SUBDIR += KnightCap
+ SUBDIR += abe
SUBDIR += abridge
SUBDIR += abuse
SUBDIR += abuse_sdl
diff --git a/games/abe/Makefile b/games/abe/Makefile
new file mode 100644
index 000000000000..e43c64672f65
--- /dev/null
+++ b/games/abe/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: games/abe
+# Date created: 8 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= abe
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Abe's Amazing Adventure
+
+USE_GMAKE= yes
+USE_SDL= mixer sdl
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-data-dir=${DATADIR}
+
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
+
+OPTIONS= GOD_MODE "Enable God Mode (toggle with 'g')" off \
+ OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+
+post-install:
+ @${MKDIR} ${DATADIR}
+.for d in images maps sounds
+ @${CP} -R ${WRKSRC}/${d} ${DATADIR}
+.endfor
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GOD_MODE) || defined(WITHOUT_OPTIMIZED_CFLAGS)
+USE_REINPLACE= yes
+
+post-patch:
+. if defined(WITH_GOD_MODE)
+ @${REINPLACE_CMD} -e 's|\(#define GOD_MODE\) 0|\1 1|' \
+ ${WRKSRC}/src/Game.h
+. endif
+. if defined(WITHOUT_OPTIMIZED_CFLAGS)
+ @${REINPLACE_CMD} -e 's|-O2||g ; \
+ s|-fomit-frame-pointer||g ; \
+ s|-ffast-math||g ; \
+ s|-fexpensive-optimizations||g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+. endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/abe/distinfo b/games/abe/distinfo
new file mode 100644
index 000000000000..ece4cd1511e5
--- /dev/null
+++ b/games/abe/distinfo
@@ -0,0 +1,2 @@
+MD5 (abe-1.1.tar.gz) = 5537920e1746708e1a631d84d3500f5c
+SIZE (abe-1.1.tar.gz) = 3321075
diff --git a/games/abe/pkg-descr b/games/abe/pkg-descr
new file mode 100644
index 000000000000..4e87f801c760
--- /dev/null
+++ b/games/abe/pkg-descr
@@ -0,0 +1,9 @@
+A scrolling, platform-jumping, key-collecting, ancient pyramid exploring game,
+vaguely in the style of similar games for the Commodore+4. The game is intended
+to show young people (I'm writing it for my son's birthday) all the cool games
+they missed.
+
+WWW: http://abe.sourceforge.net/
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/abe/pkg-plist b/games/abe/pkg-plist
new file mode 100644
index 000000000000..f7085d01fbe9
--- /dev/null
+++ b/games/abe/pkg-plist
@@ -0,0 +1,21 @@
+bin/abe
+%%DATADIR%%/images/images.tar
+%%DATADIR%%/maps/default.dat
+%%DATADIR%%/maps/intro.dat
+%%DATADIR%%/sounds/bubble.wav
+%%DATADIR%%/sounds/closed.wav
+%%DATADIR%%/sounds/death.wav
+%%DATADIR%%/sounds/door.wav
+%%DATADIR%%/sounds/game.ogg
+%%DATADIR%%/sounds/gem.wav
+%%DATADIR%%/sounds/intro.ogg
+%%DATADIR%%/sounds/jump.wav
+%%DATADIR%%/sounds/menu.wav
+%%DATADIR%%/sounds/object.wav
+%%DATADIR%%/sounds/platform.wav
+%%DATADIR%%/sounds/pop.wav
+%%DATADIR%%/sounds/spring.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/maps
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%