aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-03-10 03:23:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-03-10 03:23:35 +0000
commit0bf024826017053bfba38b09c473470a1b104685 (patch)
tree7293535c30dbd6bcbabc1e657cd9e031e73a17c6 /games
parentde4af321520ed988864cf5e3e9cecb6a59683a3d (diff)
downloadports-0bf024826017053bfba38b09c473470a1b104685.tar.gz
ports-0bf024826017053bfba38b09c473470a1b104685.zip
- Update to 0.143
Feature safe: yes
Notes
Notes: svn path=/head/; revision=293034
Diffstat (limited to 'games')
-rw-r--r--games/springlobby/Makefile2
-rw-r--r--games/springlobby/distinfo4
-rw-r--r--games/springlobby/files/patch-src-battlelistctrl.cpp11
3 files changed, 14 insertions, 3 deletions
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index d9bd3c33516f..83c6bbe4ee9f 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= springlobby
-PORTVERSION= 0.130
+PORTVERSION= 0.143
CATEGORIES= games net
MASTER_SITES= http://www.springlobby.info/tarballs/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/games/springlobby/distinfo b/games/springlobby/distinfo
index 29aaf8487f57..204564085198 100644
--- a/games/springlobby/distinfo
+++ b/games/springlobby/distinfo
@@ -1,2 +1,2 @@
-SHA256 (springlobby-0.130.tar.bz2) = 5641185829d41f2506a8790f8f89fb10c83f2cba65ee905b907ac895d9abf3e1
-SIZE (springlobby-0.130.tar.bz2) = 1788541
+SHA256 (springlobby-0.143.tar.bz2) = 4694a0d88c7409a42cc83cd10b80226aa2cc5b2f0f83fa95351638fee3e77b61
+SIZE (springlobby-0.143.tar.bz2) = 1797369
diff --git a/games/springlobby/files/patch-src-battlelistctrl.cpp b/games/springlobby/files/patch-src-battlelistctrl.cpp
new file mode 100644
index 000000000000..cec646876e1f
--- /dev/null
+++ b/games/springlobby/files/patch-src-battlelistctrl.cpp
@@ -0,0 +1,11 @@
+--- src/battlelistctrl.cpp.orig 2012-03-09 20:01:28.000000000 +0400
++++ src/battlelistctrl.cpp 2012-03-10 07:08:45.273705553 +0400
+@@ -103,7 +103,7 @@
+ case 7: return wxFormat(_T("%d") ) % int(battle.GetSpectators());
+ case 8: return wxFormat(_T("%d") ) % (int(battle.GetNumUsers()) - int(battle.GetSpectators()));
+ case 9: return wxFormat(_T("%d") ) % int(battle.GetMaxPlayers());
+- case 10: return ( wxDateTime(battle.GetBattleRunningTime()).FormatISOTime() );
++ case 10: return ( wxDateTime((time_t)battle.GetBattleRunningTime()).FormatISOTime() );
+ }
+ }
+