aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-04 12:25:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-04 12:25:06 +0000
commit28110cef3398aafdc29e63279359ddaa981a58ce (patch)
treed8c7c21c0b166156c256f178f5a22c7efe107cab /games
parent1683b7d7c552c5e429886f57c4808f0f194a2c6e (diff)
downloadports-28110cef3398aafdc29e63279359ddaa981a58ce.tar.gz
ports-28110cef3398aafdc29e63279359ddaa981a58ce.zip
- Update to 0.5.6
PR: 163655 Submitted by: Armin Pirkovitsch <armin@frozen-zone.org>
Notes
Notes: svn path=/head/; revision=292663
Diffstat (limited to 'games')
-rw-r--r--games/odamex/Makefile5
-rw-r--r--games/odamex/distinfo4
-rw-r--r--games/odamex/files/patch-Makefile16
-rw-r--r--games/odamex/files/patch-client__src__d_main.cpp20
-rw-r--r--games/odamex/files/patch-odalaunch__Makefile12
-rw-r--r--games/odamex/files/patch-server__src__d_main.cpp20
-rw-r--r--games/odamex/pkg-plist1
7 files changed, 38 insertions, 40 deletions
diff --git a/games/odamex/Makefile b/games/odamex/Makefile
index fe5174f02bdb..2d92b0af288b 100644
--- a/games/odamex/Makefile
+++ b/games/odamex/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= odamex
-PORTVERSION= 0.4.3
-PORTREVISION= 3
+PORTVERSION= 0.5.6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Odamex/${PORTVERSION}
DISTNAME= odamex-src-${PORTVERSION}
@@ -48,7 +47,7 @@ post-patch:
.endif
do-install:
-.for f in odamaster odamex odasrv
+.for f in odamex odasrv
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
.if defined(WITH_LAUNCHER)
diff --git a/games/odamex/distinfo b/games/odamex/distinfo
index 55982ce28f86..57a8f4074cef 100644
--- a/games/odamex/distinfo
+++ b/games/odamex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (odamex-src-0.4.3.tar.bz2) = a958b5e34acd57bdc4a0131c939161d64042bf9efcd71560cd970014c1eb0430
-SIZE (odamex-src-0.4.3.tar.bz2) = 1299002
+SHA256 (odamex-src-0.5.6.tar.bz2) = fc832ac2df2fceeed79b512cd789d0d30c93c46b246f50af973bb867b02a3440
+SIZE (odamex-src-0.5.6.tar.bz2) = 2954090
diff --git a/games/odamex/files/patch-Makefile b/games/odamex/files/patch-Makefile
index b39e4ee8f538..3e795597cafd 100644
--- a/games/odamex/files/patch-Makefile
+++ b/games/odamex/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig 2009-03-08 00:28:16.000000000 -0500
-+++ ./Makefile 2009-05-16 17:15:11.000000000 -0400
+--- Makefile.orig 2011-11-05 05:00:05.000000000 +0100
++++ Makefile 2011-12-01 05:33:47.415968992 +0100
@@ -3,8 +3,8 @@
OBJDIR = obj
# denis - fixme - remove mkdir -p
@@ -31,7 +31,7 @@
SDL_CFLAGS = $(shell $(SDL_CFLAGS_COMMAND))
SDL_LFLAGS = $(shell $(SDL_LFLAGS_COMMAND)) $(X11_LFLAGS)
endif
-@@ -174,7 +174,7 @@
+@@ -177,7 +177,7 @@
TARGETS = $(SERVER_TARGET) $(CLIENT_TARGET) $(MASTER_TARGET) $(WADFILE_TARGET)
# denis - fixme - cflags are quite messy, but removing these is a very delicate act, also use -Wall -Werror
@@ -40,17 +40,17 @@
LFLAGS = $(LFLAGS_PLATFORM)
CFLAGS_RELEASE = $(CFLAGS_PLATFORM) -DNOASM -Icommon -O3
-@@ -210,7 +210,12 @@
+@@ -213,7 +213,12 @@
# denis - end fixme
# All
--all: $(SERVER_TARGET) $(CLIENT_TARGET) $(MASTER_TARGET) $(WADFILE_TARGET)
-+all: $(SERVER_TARGET) $(CLIENT_TARGET) $(MASTER_TARGET) $(WADFILE_TARGET) launcher
+-all: $(SERVER_TARGET) $(CLIENT_TARGET) $(WADFILE_TARGET)
++all: $(SERVER_TARGET) $(CLIENT_TARGET) $(WADFILE_TARGET) launcher
+
+launcher:
+ifdef WITH_LAUNCHER
+ $(MAKE) -C odalaunch odalaunch
+endif
- # Common for server
- $(OBJDIR)/$(COMMON_DIR)/server_%.o: $(COMMON_DIR)/%.cpp $(COMMON_HEADERS) $(SERVER_HEADERS)
+ # Textscreen
+ $(OBJDIR)/$(TEXTSCREEN_DIR)/%.o: $(TEXTSCREEN_DIR)/%.cpp $(TEXTSCREEN_HEADERS) $(COMMON_HEADERS)
diff --git a/games/odamex/files/patch-client__src__d_main.cpp b/games/odamex/files/patch-client__src__d_main.cpp
index ea1cd0f09cc2..ecf11ca67996 100644
--- a/games/odamex/files/patch-client__src__d_main.cpp
+++ b/games/odamex/files/patch-client__src__d_main.cpp
@@ -1,11 +1,11 @@
---- ./client/src/d_main.cpp.orig 2009-03-08 00:28:16.000000000 -0500
-+++ ./client/src/d_main.cpp 2009-05-16 18:23:51.000000000 -0400
-@@ -807,6 +807,8 @@
- AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
- AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
- AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
-+ AddSearchDir(dirs, "%%DATADIR%%", separator);
-+ AddSearchDir(dirs, "%%DMDIR%%", separator);
- AddSearchDir(dirs, getenv("HOME"), separator);
+--- client/src/d_main.cpp.orig 2011-11-05 05:00:05.000000000 +0100
++++ client/src/d_main.cpp 2011-12-01 05:33:47.422967926 +0100
+@@ -843,6 +843,8 @@
+ D_AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
+ D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
+ D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
++ D_AddSearchDir(dirs, "/usr/local/share/odamex", separator);
++ D_AddSearchDir(dirs, "/usr/local/share/doom", separator);
+ D_AddSearchDir(dirs, getenv("HOME"), separator);
+ D_AddSearchDir(dirs, waddirs.cstring(), separator);
- dirs.erase(std::unique(dirs.begin(), dirs.end()), dirs.end());
diff --git a/games/odamex/files/patch-odalaunch__Makefile b/games/odamex/files/patch-odalaunch__Makefile
index edb2284c07fd..0329615c46a1 100644
--- a/games/odamex/files/patch-odalaunch__Makefile
+++ b/games/odamex/files/patch-odalaunch__Makefile
@@ -1,8 +1,8 @@
---- ./odalaunch/Makefile.orig 2009-03-08 00:28:10.000000000 -0500
-+++ ./odalaunch/Makefile 2009-05-16 18:32:01.000000000 -0400
-@@ -11,11 +11,11 @@
-
- HEADERS = src/*.h
+--- odalaunch/Makefile.orig 2011-11-05 05:00:03.000000000 +0100
++++ odalaunch/Makefile 2011-12-01 05:33:47.418968116 +0100
+@@ -23,11 +23,11 @@
+ -I./res \
+ -I../odalpapi
-CC = g++
-LD = g++
@@ -14,5 +14,5 @@
+WXCONFIG = $(WX_CONFIG)
+WXRC = $(WXRC_CMD)
- # Sometimes wx-config will uee the lowest version available, which is what
+ # Sometimes wx-config will use the lowest version available, which is what
# we do no want! -- GhostlyDeath
diff --git a/games/odamex/files/patch-server__src__d_main.cpp b/games/odamex/files/patch-server__src__d_main.cpp
index d2107cd18259..896d4fd6bd50 100644
--- a/games/odamex/files/patch-server__src__d_main.cpp
+++ b/games/odamex/files/patch-server__src__d_main.cpp
@@ -1,11 +1,11 @@
---- ./server/src/d_main.cpp.orig 2009-03-08 00:28:11.000000000 -0500
-+++ ./server/src/d_main.cpp 2009-05-18 16:40:24.000000000 -0400
-@@ -597,6 +597,8 @@
- AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
- AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
- AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
-+ AddSearchDir(dirs, "%%DATADIR%%", separator);
-+ AddSearchDir(dirs, "%%DMDIR%%", separator);
- AddSearchDir(dirs, getenv("HOME"), separator);
+--- server/src/d_main.cpp.orig 2011-11-05 04:59:48.000000000 +0100
++++ server/src/d_main.cpp 2011-12-01 05:33:47.423967844 +0100
+@@ -627,6 +627,8 @@
+ D_AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
+ D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
+ D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
++ D_AddSearchDir(dirs, "/usr/local/share/odamex", separator);
++ D_AddSearchDir(dirs, "/usr/local/share/doom", separator);
+ D_AddSearchDir(dirs, getenv("HOME"), separator);
+ D_AddSearchDir(dirs, waddirs.cstring(), separator);
- dirs.erase(std::unique(dirs.begin(), dirs.end()), dirs.end());
diff --git a/games/odamex/pkg-plist b/games/odamex/pkg-plist
index 7d4f30f0a33c..dfbc32d366be 100644
--- a/games/odamex/pkg-plist
+++ b/games/odamex/pkg-plist
@@ -1,5 +1,4 @@
%%LAUNCHER%%bin/odalaunch
-bin/odamaster
bin/odamex
bin/odasrv
%%DATADIR%%/odamex.wad