aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2004-12-04 19:18:43 +0000
committerJames E. Housley <jeh@FreeBSD.org>2004-12-04 19:18:43 +0000
commit2f040af06ec274b764027d9386d75b439910031e (patch)
tree063c52c505c142e0a50f64836939ebd497156c52 /games
parent2d6fafe95cbd0ff3c9ac62e2938a6a4e4db1af65 (diff)
downloadports-2f040af06ec274b764027d9386d75b439910031e.tar.gz
ports-2f040af06ec274b764027d9386d75b439910031e.zip
Allows games/tank to compile on fbsd 5/6
PR: 74681 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=123124
Diffstat (limited to 'games')
-rw-r--r--games/tank/Makefile4
-rw-r--r--games/tank/files/patch-Makefile.Linux.Mesa8
2 files changed, 4 insertions, 8 deletions
diff --git a/games/tank/Makefile b/games/tank/Makefile
index d3c7ed51b1f6..a5d49ccafdb8 100644
--- a/games/tank/Makefile
+++ b/games/tank/Makefile
@@ -24,10 +24,6 @@ ALL_TARGET= linux-mesa-elf
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tank ${PREFIX}/bin
${MKDIR} ${DATADIR}
diff --git a/games/tank/files/patch-Makefile.Linux.Mesa b/games/tank/files/patch-Makefile.Linux.Mesa
index 44c9dd40cfe1..92cd5a521a83 100644
--- a/games/tank/files/patch-Makefile.Linux.Mesa
+++ b/games/tank/files/patch-Makefile.Linux.Mesa
@@ -1,11 +1,11 @@
---- Makefile.Linux.Mesa.orig Sun Feb 2 18:59:42 1997
-+++ Makefile.Linux.Mesa Sun Nov 16 19:16:50 2003
+--- Makefile.Linux.Mesa.orig Sun Feb 2 12:59:42 1997
++++ Makefile.Linux.Mesa Sat Dec 4 08:56:39 2004
@@ -3,23 +3,23 @@
.SUFFIXES: .cc .o
-ARCH = -DLINUX -DMESA #-DSOUND
-+ARCH = -DLINUX -DPREFIX=\"$(PREFIX)\" #-DUSING_MESA -DSOUND
++TARCH = -DLINUX -DPREFIX=\"$(PREFIX)\" #-DUSING_MESA -DSOUND
MESA = Mesa
@@ -14,7 +14,7 @@
-CFLAGS = $(INCLUDE) $(ARCH) -O2 -m486 -Wall -pipe \
- -pedantic -funroll-loops -mieee-fp
-+CFLAGS += $(INCLUDE) $(ARCH) -DSOUND -Wall -pipe ${PTHREAD_CFLAGS} \
++CFLAGS += $(INCLUDE) $(TARCH) -DSOUND -Wall -pipe ${PTHREAD_CFLAGS} \
+ -pedantic -funroll-loops
-LDFLAGS = -L/usr/X11R6/lib -L$(MESA)/lib