aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-02-20 14:25:13 +0000
committerSteve Wills <swills@FreeBSD.org>2012-02-20 14:25:13 +0000
commit55dc1ce637b067ac87c5381c7a1e9d8b7a6101ff (patch)
treed20fd77ad6bad39a77581e75de7dc84b261f5ba6 /games
parentf1dfe8ba1e917f750b36caa6353eaaaa5836c18f (diff)
downloadports-55dc1ce637b067ac87c5381c7a1e9d8b7a6101ff.tar.gz
ports-55dc1ce637b067ac87c5381c7a1e9d8b7a6101ff.zip
- Fix build with new png
Submitted by: avg
Notes
Notes: svn path=/head/; revision=291936
Diffstat (limited to 'games')
-rw-r--r--games/prboom/Makefile2
-rw-r--r--games/prboom/files/patch-i_sshot.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/games/prboom/Makefile b/games/prboom/Makefile
index b10fbf25a800..178ec16032d8 100644
--- a/games/prboom/Makefile
+++ b/games/prboom/Makefile
@@ -7,7 +7,7 @@
PORTNAME= prboom
PORTVERSION= 2.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
diff --git a/games/prboom/files/patch-i_sshot.c b/games/prboom/files/patch-i_sshot.c
new file mode 100644
index 000000000000..b4e7485740a8
--- /dev/null
+++ b/games/prboom/files/patch-i_sshot.c
@@ -0,0 +1,20 @@
+--- src/SDL/i_sshot.c.orig 2010-05-19 13:40:36.506099313 +0300
++++ src/SDL/i_sshot.c 2010-05-19 13:41:50.837973800 +0300
+@@ -231,7 +231,7 @@
+ if (fp)
+ {
+ png_struct *png_ptr = png_create_write_struct(
+- PNG_LIBPNG_VER_STRING, png_error_ptr_NULL, error_fn, warning_fn);
++ PNG_LIBPNG_VER_STRING, NULL, error_fn, warning_fn);
+
+ if (png_ptr)
+ {
+@@ -279,7 +279,7 @@
+ break;
+ }
+ }
+- png_destroy_write_struct(&png_ptr, png_infopp_NULL);
++ png_destroy_write_struct(&png_ptr, NULL);
+ }
+ fclose(fp);
+ }